X-Git-Url: https://git.madduck.net/code/myrepos.git/blobdiff_plain/08e80ec74eafb9b4407d42c5334026bcffcfd839..379abaa4ed00707a7fd7bf8f596126914b06249b:/debian/rules?ds=inline

diff --git a/debian/rules b/debian/rules
index 7815fff..d688d4b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,38 +1,7 @@
 #!/usr/bin/make -f
-
-build:
-	pod2man -c mr mr > mr.1
-	(echo "[]"; echo "checkout=") > mrconfig.tmp
-	./mr -c mrconfig.tmp ed | grep -q "horse"
-	rm -f mrconfig.tmp
-
-clean:
-	dh_testdir
-	dh_testroot
-	dh_clean mr.1
-
-binary-arch: build
-
-binary-indep: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k
-	dh_install mr usr/bin
-	dh_installdocs README TODO
-	dh_installexamples mrconfig mrconfig.*
-	dh_installman *.1
-	dh_installchangelogs
-	dh_compress
-	dh_fixperms
-	dh_perl
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+%:
+	dh $@
 
 # Not intended for use by anyone except the author.
 announcedir:
 	@echo ${HOME}/src/joeywiki/code/mr/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary