X-Git-Url: https://git.madduck.net/code/myrepos.git/blobdiff_plain/3a9ac2e5e8c2911fa1eb848824e86cbed20bbf1b..92842b91c27593c122fc53d5d7fa6c162d303b8a:/debian/rules

diff --git a/debian/rules b/debian/rules
index 4155333..d688d4b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,35 +1,7 @@
 #!/usr/bin/make -f
-
-build:
-	pod2man -c mr mr > mr.1
-
-clean:
-	dh_testdir
-	dh_testroot
-	dh_clean mr.1
-
-binary-arch: build
-
-binary-indep: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k
-	dh_install mr usr/bin
-	dh_installdocs README TODO
-	dh_installexamples mrconfig
-	dh_installman *.1
-	dh_installchangelogs
-	dh_compress
-	dh_fixperms
-	dh_perl
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+%:
+	dh $@
 
 # Not intended for use by anyone except the author.
 announcedir:
 	@echo ${HOME}/src/joeywiki/code/mr/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary