X-Git-Url: https://git.madduck.net/code/myrepos.git/blobdiff_plain/511e30d827dbf773f8ea61d7bd1de79a6a1e7ba6..fd045fb534f7e0cb68f8ffa65111de086a1c37ae:/debian/rules?ds=inline

diff --git a/debian/rules b/debian/rules
index 41d2804..1cc28db 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,10 @@
 #!/usr/bin/make -f
 
 build:
-	./mr help > mr.1
+	pod2man -c mr mr > mr.1
+	(echo "[]"; echo "checkout=") > mrconfig.tmp
+	./mr -c mrconfig.tmp ed | grep -q "horse"
+	rm -f mrconfig.tmp
 
 clean:
 	dh_testdir
@@ -15,8 +18,9 @@ binary-indep: build
 	dh_testroot
 	dh_clean -k
 	dh_install mr usr/bin
-	dh_installdocs README
-	dh_installexamples mrconfig
+	dh_installdocs README TODO
+	dh_installexamples mrconfig mrconfig.complex
+	dh_install lib/* usr/share/mr
 	dh_installman *.1
 	dh_installchangelogs
 	dh_compress
@@ -27,5 +31,9 @@ binary-indep: build
 	dh_md5sums
 	dh_builddeb
 
+# Not intended for use by anyone except the author.
+announcedir:
+	@echo ${HOME}/src/joeywiki/code/mr/news
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary