X-Git-Url: https://git.madduck.net/code/myrepos.git/blobdiff_plain/577638b7115d3c4ecad1ca3536802035650dd651..7993c3fea43f94925a6a4e0a1f3f5731aeb80fdb:/debian/rules?ds=sidebyside

diff --git a/debian/rules b/debian/rules
index cf5dd3a..d688d4b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,38 +1,7 @@
 #!/usr/bin/make -f
-
-build:
-	pod2man -c mr mr > mr.1
-	(echo "[]"; echo "checkout=") > mrconfig.tmp
-	./mr -c mrconfig.tmp ed | grep -q "horse"
-	rm -f mrconfig.tmp
-
-clean:
-	dh_testdir
-	dh_testroot
-	dh_clean mr.1
-
-binary-arch: build
-
-binary-indep: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k
-	dh_install mr usr/bin
-	dh_installdocs README TODO
-	dh_installexamples mrconfig mrconfig.complex
-	dh_installman *.1
-	dh_installchangelogs
-	dh_compress
-	dh_fixperms
-	dh_perl
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+%:
+	dh $@
 
 # Not intended for use by anyone except the author.
 announcedir:
 	@echo ${HOME}/src/joeywiki/code/mr/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary