X-Git-Url: https://git.madduck.net/code/myrepos.git/blobdiff_plain/a3d385d71b084edfa4a32a497ddfcc28cea78b9e..311c6efa8e64a24f406955373eff67e4a35ad0c0:/debian/changelog

diff --git a/debian/changelog b/debian/changelog
index 691163b..e0214f3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,109 @@
-mr (0.4) UNRELEASED; urgency=low
+mr (0.11) UNRELEASED; urgency=low
+
+  * Avoid using commands like git-config and instead use "git config".
+    In some configurations, only the main git command is in the path.
+  * Allow option bundling, mostly so "-j2" will work.
+  * Better error message if more than one repo type test matches a single
+    directory.
+
+ -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 22:41:44 -0400
+
+mr (0.10) unstable; urgency=low
+
+  * Add a lib file for using unison with mr.
+  * Make registration work when no config file yet exists. Closes: #448422
+
+ -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
+
+mr (0.9) unstable; urgency=low
+
+  * Split up actions, so each rcs has its own set of action commands,
+    and mr tests to see what rcs is used by a repository, and dispatches
+    the command.
+
+    This will make it much easier to add new rcses, or modify just the
+    command that mr uses for one command for one rcs, without duplicating a
+    lot of code, and without needing to modify mr at all.
+
+    The old style unsplit actions are still supported, and are what most
+    mrconfig files will still use; this change is fully backwards compatible.
+  * Changed some things in the enviroment for the register action.
+    It's now run in the directory that the user specifies, and MR_REPO
+    is set to contain the basename of the directory that the checkout
+    command should check out. These changes should be backware compatible
+    to existing register actions.
+  * Add info and warning functions to the shell library. (madduck)
+  * Add git_bare and git_fake_bare rcs types to handle
+    bare and fake bare (non-bare with a detached worktree) git repositories.
+    (Diff and commit do not work yet to fake bare repos). (madduck)
+  * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
+  * Add support for including one mrconfig file from another. Unlike chaining,
+    this doesn't change the paths, and is not tied to a particular
+    subdirectory. It's useful for loading up library mrconfig files.
+  * Split git fake-bare support out into a lib/git-fake-bare.
+    Partly because it's a good example of how to add a new revision control
+    type and use includes, and partly because it's currently too ugly to be
+    in mr itself due to bugs and limitations in git.
+
+ -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
+
+mr (0.8) unstable; urgency=low
+
+  * Improve "in subdir" message.
+  * Patch from Simon McVittie, to pass -a to darcs commands to avoid
+    interactive updates. Closes: #447999
+
+ -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
+
+mr (0.7) unstable; urgency=low
+
+  * Fix inverted tests in tags command. (madduck)
+  * Patch from Simon McVittie, adding support for darcs repositories.
+    Closes: #447729
+
+ -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
+
+mr (0.6) unstable; urgency=low
+
+  * Add to the example mrconfig a "tags" command that lists tags.
+    (Currently only for svn and git.)
+  * hours_since was broken by design, and fixing it involved changing
+    its calling convention. If you used the old version, the new version
+    will error out.
+  * Add ability to reorder repos, if you want mr to act on a given repo first
+    or last.
+
+ -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
+
+mr (0.5) unstable; urgency=low
+
+  [ Joey Hess ]
+  * Removed special case repository deletion handling code. The same
+    thing can be accomplished in a mrconfig by skipping a repo unless
+    it exists, and printing a reminder on update. See the mrconfig file
+    for an example.
+  * Fix output of "mr config DEFAULT lib".
+  * Change mr update to use git pull -t origin master, to make sure new tags
+    are pulled. And since those might not always be the right parameters
+    for git pull, any parameters passed to mr update will replace them.
+
+  [ Alexander Wirt ]
+  * Add support for mercurial.
+
+  [ Joey Hess ]
+  * Incorporate code based on Anthony Towns's mrs, to allow running
+    multiple jobs in parallel. The -j flag controls this.
+    This can produce enormous speedups. For me, mr update takes
+    12 minutes, while mr -j 10 update takes 1 minute!
+
+ -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
+
+mr (0.4) unstable; urgency=low
 
   * Fix mr register of a subdir to also work with -c.
   * Signal handling for commands run by mr, including handling of SIGINT
     to stop mr.
-  * Ensure parent dir exists prior to checkout. (madduck)
+  * Ensure parent dirs exist prior to checkout. (madduck)
   * Output list of failed repos to stderr when -s is used.
   * Fix a bug caused by a stupid typo.
   * Add the -n switch, for disabling recursion.