X-Git-Url: https://git.madduck.net/code/myrepos.git/blobdiff_plain/adc607b0b5563afe596fdfa73347ea1cb9f1da49..a1d6605bed222f885a4fb6200c36a5b2c3b537fc:/debian/rules

diff --git a/debian/rules b/debian/rules
index a537c15..1cc28db 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,9 @@
 
 build:
 	pod2man -c mr mr > mr.1
+	(echo "[]"; echo "checkout=") > mrconfig.tmp
+	./mr -c mrconfig.tmp ed | grep -q "horse"
+	rm -f mrconfig.tmp
 
 clean:
 	dh_testdir
@@ -16,7 +19,8 @@ binary-indep: build
 	dh_clean -k
 	dh_install mr usr/bin
 	dh_installdocs README TODO
-	dh_installexamples mrconfig
+	dh_installexamples mrconfig mrconfig.complex
+	dh_install lib/* usr/share/mr
 	dh_installman *.1
 	dh_installchangelogs
 	dh_compress
@@ -27,5 +31,9 @@ binary-indep: build
 	dh_md5sums
 	dh_builddeb
 
+# Not intended for use by anyone except the author.
+announcedir:
+	@echo ${HOME}/src/joeywiki/code/mr/news
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary