X-Git-Url: https://git.madduck.net/code/myrepos.git/blobdiff_plain/f968e2a52a21b715d83ad8a6fb4af1697491b4be..16632d827f322c0767ee67056df7eab90cad016a:/debian/rules

diff --git a/debian/rules b/debian/rules
index f43c64c..d688d4b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,36 +1,7 @@
 #!/usr/bin/make -f
-
-build:
-	pod2man -c mr mr > mr.1
-	./mr ed | grep -q "horse"
-
-clean:
-	dh_testdir
-	dh_testroot
-	dh_clean mr.1
-
-binary-arch: build
-
-binary-indep: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k
-	dh_install mr usr/bin
-	dh_installdocs README TODO
-	dh_installexamples mrconfig mrconfig.complex
-	dh_installman *.1
-	dh_installchangelogs
-	dh_compress
-	dh_fixperms
-	dh_perl
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+%:
+	dh $@
 
 # Not intended for use by anyone except the author.
 announcedir:
 	@echo ${HOME}/src/joeywiki/code/mr/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary