]> git.madduck.net Git - code/myrepos.git/blobdiff - debian/rules

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

prep
[code/myrepos.git] / debian / rules
index 7815fffab2fc0a53b664755b6f70956313853ad9..d1c5d97848909a5c13e89490ce421128f58d48f8 100755 (executable)
@@ -1,38 +1,7 @@
 #!/usr/bin/make -f
-
-build:
-       pod2man -c mr mr > mr.1
-       (echo "[]"; echo "checkout=") > mrconfig.tmp
-       ./mr -c mrconfig.tmp ed | grep -q "horse"
-       rm -f mrconfig.tmp
-
-clean:
-       dh_testdir
-       dh_testroot
-       dh_clean mr.1
-
-binary-arch: build
-
-binary-indep: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_install mr usr/bin
-       dh_installdocs README TODO
-       dh_installexamples mrconfig mrconfig.*
-       dh_installman *.1
-       dh_installchangelogs
-       dh_compress
-       dh_fixperms
-       dh_perl
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+%:
+       dh $@
 
 # Not intended for use by anyone except the author.
 announcedir:
-       @echo ${HOME}/src/joeywiki/code/mr/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+       @echo ${HOME}/src/myrepos/doc/news