madduck's git repository
Every one of the projects in this repository is available at the canonical
URL git://git.madduck.net/madduck/pub/<projectpath> — see
each project's metadata for the exact URL.
All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
SSH access, as well as push access can be individually
arranged.
If you use my repositories frequently, consider adding the following
snippet to ~/.gitconfig and using the third clone URL listed for each
project:
[url "git://git.madduck.net/madduck/"]
insteadOf = madduck:
build:
pod2man -c mr mr > mr.1
build:
pod2man -c mr mr > mr.1
+ (echo "[]"; echo "checkout=") > mrconfig.tmp
+ ./mr -c mrconfig.tmp ed | grep -q "horse"
+ rm -f mrconfig.tmp
dh_testroot
dh_clean -k
dh_install mr usr/bin
dh_testroot
dh_clean -k
dh_install mr usr/bin
- dh_installdocs
- dh_installexamples mrconfig
+ dh_installdocs README TODO
+ dh_installexamples mrconfig mrconfig.complex
+ dh_install lib/* usr/share/mr
dh_installman *.1
dh_installchangelogs
dh_compress
dh_installman *.1
dh_installchangelogs
dh_compress
+# Not intended for use by anyone except the author.
+announcedir:
+ @echo ${HOME}/src/joeywiki/code/mr/news
+
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary