]> git.madduck.net Git - code/myrepos.git/blobdiff - debian/rules

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

Merge remote-tracking branch 'mr/master'
[code/myrepos.git] / debian / rules
index 41d2804dd639bb49f35c8053e8742140286c0a34..d688d4baba447803dc05005f25b9dbe021d873ed 100755 (executable)
@@ -1,31 +1,7 @@
 #!/usr/bin/make -f
+%:
+       dh $@
 
-build:
-       ./mr help > mr.1
-
-clean:
-       dh_testdir
-       dh_testroot
-       dh_clean mr.1
-
-binary-arch: build
-
-binary-indep: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_install mr usr/bin
-       dh_installdocs README
-       dh_installexamples mrconfig
-       dh_installman *.1
-       dh_installchangelogs
-       dh_compress
-       dh_fixperms
-       dh_perl
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+# Not intended for use by anyone except the author.
+announcedir:
+       @echo ${HOME}/src/joeywiki/code/mr/news