]> git.madduck.net Git - code/myrepos.git/blobdiff - debian/rules

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* -c was broken, fix. Closes: #449539
[code/myrepos.git] / debian / rules
index a537c15f3ebf18d3597b119864798b545d39b7f6..1cc28dbb5f4ec1d2cc39c5c0a8e3ce34448ca81c 100755 (executable)
@@ -2,6 +2,9 @@
 
 build:
        pod2man -c mr mr > mr.1
+       (echo "[]"; echo "checkout=") > mrconfig.tmp
+       ./mr -c mrconfig.tmp ed | grep -q "horse"
+       rm -f mrconfig.tmp
 
 clean:
        dh_testdir
@@ -16,7 +19,8 @@ binary-indep: build
        dh_clean -k
        dh_install mr usr/bin
        dh_installdocs README TODO
-       dh_installexamples mrconfig
+       dh_installexamples mrconfig mrconfig.complex
+       dh_install lib/* usr/share/mr
        dh_installman *.1
        dh_installchangelogs
        dh_compress
@@ -27,5 +31,9 @@ binary-indep: build
        dh_md5sums
        dh_builddeb
 
+# Not intended for use by anyone except the author.
+announcedir:
+       @echo ${HOME}/src/joeywiki/code/mr/news
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary