-mr (0.4) UNRELEASED; urgency=low
+mr (0.7) unstable; urgency=low
- * Fix mr register to work when -c is specified using a relative path and
- is used to register a sibdirectory.
+ * Fix inverted tests in tags command. (madduck)
+ * Patch from Simon McVittie, adding support for darcs repositories.
+ Closes: #447729
+
+ -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
+
+mr (0.6) unstable; urgency=low
+
+ * Add to the example mrconfig a "tags" command that lists tags.
+ (Currently only for svn and git.)
+ * hours_since was broken by design, and fixing it involved changing
+ its calling convention. If you used the old version, the new version
+ will error out.
+ * Add ability to reorder repos, if you want mr to act on a given repo first
+ or last.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
+
+mr (0.5) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Removed special case repository deletion handling code. The same
+ thing can be accomplished in a mrconfig by skipping a repo unless
+ it exists, and printing a reminder on update. See the mrconfig file
+ for an example.
+ * Fix output of "mr config DEFAULT lib".
+ * Change mr update to use git pull -t origin master, to make sure new tags
+ are pulled. And since those might not always be the right parameters
+ for git pull, any parameters passed to mr update will replace them.
+
+ [ Alexander Wirt ]
+ * Add support for mercurial.
+
+ [ Joey Hess ]
+ * Incorporate code based on Anthony Towns's mrs, to allow running
+ multiple jobs in parallel. The -j flag controls this.
+ This can produce enormous speedups. For me, mr update takes
+ 12 minutes, while mr -j 10 update takes 1 minute!
+
+ -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
+
+mr (0.4) unstable; urgency=low
+
+ * Fix mr register of a subdir to also work with -c.
* Signal handling for commands run by mr, including handling of SIGINT
to stop mr.
- * Ensure parent dir exists prior to checkout. (madduck)
+ * Ensure parent dirs exist prior to checkout. (madduck)
+ * Output list of failed repos to stderr when -s is used.
+ * Fix a bug caused by a stupid typo.
+ * Add the -n switch, for disabling recursion.
+ * Allow for more complex deleted tests, such as marking a repo deleted on
+ some hosts, while not on others.
+ * Support registering CVS repositories. Closes: #447171
+ * MR_CONFIG now points to the config file that contains the repo mr is
+ acting on.
+ * Make mr register smarter about what mrconfig file to write to.
+ (It probably does what you'd expect it to do now; if it doesn't, -c
+ can still override.)
- -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 13:57:41 -0400
+ -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
mr (0.3) unstable; urgency=low
* Add a check to make sure the expected directory exists after checkout.
* mr register will now write to whatever config file is specified with -c
- * Typo files from madduck.
+ * Typo fixes from madduck.
-- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400