madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

Bump required aiohttp version to 3.7.4 (#2509)
authorZsolt Dollenstein <zsol.zsol@gmail.com>
Sat, 25 Sep 2021 19:45:13 +0000 (20:45 +0100)
committerGitHub <noreply@github.com>
Sat, 25 Sep 2021 19:45:13 +0000 (15:45 -0400)
Commit history before merge:

* Bump required aiohttp version to 3.7.4

This release includes an important security fix
(https://github.com/aio-libs/aiohttp/security/advisories/GHSA-v6wp-4m6f-gcjg) and many
other improvements.

* add changelog entry
* Let's not forget about Pipfile

Co-authored-by: Richard Si <63936253+ichard26@users.noreply.github.com>
CHANGES.md
Pipfile
setup.py

index 2a9b649d25cfe0776a34e655dd85b8b36bf20781..1ff2cea84ca2d6e82d3536543196b1968d1d79dd 100644 (file)
@@ -5,6 +5,7 @@
 ### _Blackd_
 
 - Remove dependency on aiohttp-cors (#2500)
+- Bump required aiohttp version to 3.7.4 (#2509)
 
 ## 21.9b0
 
diff --git a/Pipfile b/Pipfile
index 66ded8b857010019cc7e26432c6591a3993a4482..6c635a63c66df3d793e76ec48a3d1d2e48202470 100644 (file)
--- a/Pipfile
+++ b/Pipfile
@@ -40,7 +40,7 @@ readme_renderer = "*"
 black = {editable = true, extras = ["d", "jupyter"], path = "."}
 
 [packages]
-aiohttp = ">=3.6.0"
+aiohttp = ">=3.7.4"
 platformdirs= ">=2"
 click = ">=8.0.0"
 mypy_extensions = ">=0.4.3"
index 19df9beb24eb8369250f8af7d2a915236e6528ea..015f321eaa9c63c7c9f9d7a600baed1395cabe34 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -86,7 +86,7 @@ setup(
         "mypy_extensions>=0.4.3",
     ],
     extras_require={
-        "d": ["aiohttp>=3.6.0"],
+        "d": ["aiohttp>=3.7.4"],
         "colorama": ["colorama>=0.4.3"],
         "python2": ["typed-ast>=1.4.2"],
         "uvloop": ["uvloop>=0.15.2"],