]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Cut number of rcs tests run in half.
[code/myrepos.git] / debian / changelog
1 mr (0.14) UNRELEASED; urgency=low
2
3   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
4     Bloom. Closes: #449592
5   * Cut number of rcs tests run in half.
6
7  -- Joey Hess <joeyh@debian.org>  Thu, 08 Nov 2007 21:29:44 -0500
8
9 mr (0.13) unstable; urgency=low
10
11   * -c was broken, fix. Closes: #449539
12
13  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
14
15 mr (0.12) unstable; urgency=low
16
17   * Avoid creating parent directory for a checkout that will ultimately be
18     skipped.
19   * Don't try to test the repo type when doing a checkout, that can't work
20     since the repo isn't there yet. It was actually checking the repo type
21     of the parent directory, which caused several unexpected behaviors.
22
23  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
24
25 mr (0.11) unstable; urgency=low
26
27   * Avoid using commands like git-config and instead use "git config".
28     In some configurations, only the main git command is in the path.
29   * Allow option bundling, mostly so "-j2" will work.
30   * Better error message if more than one repo type test matches a single
31     directory.
32
33  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
34
35 mr (0.10) unstable; urgency=low
36
37   * Add a lib file for using unison with mr.
38   * Make registration work when no config file yet exists. Closes: #448422
39
40  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
41
42 mr (0.9) unstable; urgency=low
43
44   * Split up actions, so each rcs has its own set of action commands,
45     and mr tests to see what rcs is used by a repository, and dispatches
46     the command.
47
48     This will make it much easier to add new rcses, or modify just the
49     command that mr uses for one command for one rcs, without duplicating a
50     lot of code, and without needing to modify mr at all.
51
52     The old style unsplit actions are still supported, and are what most
53     mrconfig files will still use; this change is fully backwards compatible.
54   * Changed some things in the enviroment for the register action.
55     It's now run in the directory that the user specifies, and MR_REPO
56     is set to contain the basename of the directory that the checkout
57     command should check out. These changes should be backware compatible
58     to existing register actions.
59   * Add info and warning functions to the shell library. (madduck)
60   * Add git_bare and git_fake_bare rcs types to handle
61     bare and fake bare (non-bare with a detached worktree) git repositories.
62     (Diff and commit do not work yet to fake bare repos). (madduck)
63   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
64   * Add support for including one mrconfig file from another. Unlike chaining,
65     this doesn't change the paths, and is not tied to a particular
66     subdirectory. It's useful for loading up library mrconfig files.
67   * Split git fake-bare support out into a lib/git-fake-bare.
68     Partly because it's a good example of how to add a new revision control
69     type and use includes, and partly because it's currently too ugly to be
70     in mr itself due to bugs and limitations in git.
71
72  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
73
74 mr (0.8) unstable; urgency=low
75
76   * Improve "in subdir" message.
77   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
78     interactive updates. Closes: #447999
79
80  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
81
82 mr (0.7) unstable; urgency=low
83
84   * Fix inverted tests in tags command. (madduck)
85   * Patch from Simon McVittie, adding support for darcs repositories.
86     Closes: #447729
87
88  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
89
90 mr (0.6) unstable; urgency=low
91
92   * Add to the example mrconfig a "tags" command that lists tags.
93     (Currently only for svn and git.)
94   * hours_since was broken by design, and fixing it involved changing
95     its calling convention. If you used the old version, the new version
96     will error out.
97   * Add ability to reorder repos, if you want mr to act on a given repo first
98     or last.
99
100  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
101
102 mr (0.5) unstable; urgency=low
103
104   [ Joey Hess ]
105   * Removed special case repository deletion handling code. The same
106     thing can be accomplished in a mrconfig by skipping a repo unless
107     it exists, and printing a reminder on update. See the mrconfig file
108     for an example.
109   * Fix output of "mr config DEFAULT lib".
110   * Change mr update to use git pull -t origin master, to make sure new tags
111     are pulled. And since those might not always be the right parameters
112     for git pull, any parameters passed to mr update will replace them.
113
114   [ Alexander Wirt ]
115   * Add support for mercurial.
116
117   [ Joey Hess ]
118   * Incorporate code based on Anthony Towns's mrs, to allow running
119     multiple jobs in parallel. The -j flag controls this.
120     This can produce enormous speedups. For me, mr update takes
121     12 minutes, while mr -j 10 update takes 1 minute!
122
123  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
124
125 mr (0.4) unstable; urgency=low
126
127   * Fix mr register of a subdir to also work with -c.
128   * Signal handling for commands run by mr, including handling of SIGINT
129     to stop mr.
130   * Ensure parent dirs exist prior to checkout. (madduck)
131   * Output list of failed repos to stderr when -s is used.
132   * Fix a bug caused by a stupid typo.
133   * Add the -n switch, for disabling recursion.
134   * Allow for more complex deleted tests, such as marking a repo deleted on
135     some hosts, while not on others.
136   * Support registering CVS repositories. Closes: #447171
137   * MR_CONFIG now points to the config file that contains the repo mr is
138     acting on.
139   * Make mr register smarter about what mrconfig file to write to.
140     (It probably does what you'd expect it to do now; if it doesn't, -c
141     can still override.)
142
143  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
144
145 mr (0.3) unstable; urgency=low
146
147   * Add a check to make sure the expected directory exists after checkout.
148   * mr register will now write to whatever config file is specified with -c
149   * Typo fixes from madduck.
150
151  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
152
153 mr (0.2) unstable; urgency=low
154
155   * Fix line number display for config file parse errors.
156   * Fix a bug in inheritance of default settings in chained .mrconfig files.
157   * Add the -s option.
158
159  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
160
161 mr (0.1) unstable; urgency=low
162
163   * First release.
164
165  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400