]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Allow -n to be passed a number to specify how deep to go into
[code/myrepos.git] / debian / changelog
1 mr (0.15) UNRELEASED; urgency=low
2
3   * Allow -n to be passed a number to specify how deep to go into
4     subdirectories to find repositories to act on.
5
6  -- Joey Hess <joeyh@debian.org>  Sun, 25 Nov 2007 12:02:40 -0500
7
8 mr (0.14) unstable; urgency=low
9
10   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
11     Bloom. Closes: #449592
12   * Cut number of rcs tests run in half.
13
14  -- Joey Hess <joeyh@debian.org>  Sun, 11 Nov 2007 01:10:18 -0500
15
16 mr (0.13) unstable; urgency=low
17
18   * -c was broken, fix. Closes: #449539
19
20  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
21
22 mr (0.12) unstable; urgency=low
23
24   * Avoid creating parent directory for a checkout that will ultimately be
25     skipped.
26   * Don't try to test the repo type when doing a checkout, that can't work
27     since the repo isn't there yet. It was actually checking the repo type
28     of the parent directory, which caused several unexpected behaviors.
29
30  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
31
32 mr (0.11) unstable; urgency=low
33
34   * Avoid using commands like git-config and instead use "git config".
35     In some configurations, only the main git command is in the path.
36   * Allow option bundling, mostly so "-j2" will work.
37   * Better error message if more than one repo type test matches a single
38     directory.
39
40  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
41
42 mr (0.10) unstable; urgency=low
43
44   * Add a lib file for using unison with mr.
45   * Make registration work when no config file yet exists. Closes: #448422
46
47  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
48
49 mr (0.9) unstable; urgency=low
50
51   * Split up actions, so each rcs has its own set of action commands,
52     and mr tests to see what rcs is used by a repository, and dispatches
53     the command.
54
55     This will make it much easier to add new rcses, or modify just the
56     command that mr uses for one command for one rcs, without duplicating a
57     lot of code, and without needing to modify mr at all.
58
59     The old style unsplit actions are still supported, and are what most
60     mrconfig files will still use; this change is fully backwards compatible.
61   * Changed some things in the enviroment for the register action.
62     It's now run in the directory that the user specifies, and MR_REPO
63     is set to contain the basename of the directory that the checkout
64     command should check out. These changes should be backware compatible
65     to existing register actions.
66   * Add info and warning functions to the shell library. (madduck)
67   * Add git_bare and git_fake_bare rcs types to handle
68     bare and fake bare (non-bare with a detached worktree) git repositories.
69     (Diff and commit do not work yet to fake bare repos). (madduck)
70   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
71   * Add support for including one mrconfig file from another. Unlike chaining,
72     this doesn't change the paths, and is not tied to a particular
73     subdirectory. It's useful for loading up library mrconfig files.
74   * Split git fake-bare support out into a lib/git-fake-bare.
75     Partly because it's a good example of how to add a new revision control
76     type and use includes, and partly because it's currently too ugly to be
77     in mr itself due to bugs and limitations in git.
78
79  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
80
81 mr (0.8) unstable; urgency=low
82
83   * Improve "in subdir" message.
84   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
85     interactive updates. Closes: #447999
86
87  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
88
89 mr (0.7) unstable; urgency=low
90
91   * Fix inverted tests in tags command. (madduck)
92   * Patch from Simon McVittie, adding support for darcs repositories.
93     Closes: #447729
94
95  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
96
97 mr (0.6) unstable; urgency=low
98
99   * Add to the example mrconfig a "tags" command that lists tags.
100     (Currently only for svn and git.)
101   * hours_since was broken by design, and fixing it involved changing
102     its calling convention. If you used the old version, the new version
103     will error out.
104   * Add ability to reorder repos, if you want mr to act on a given repo first
105     or last.
106
107  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
108
109 mr (0.5) unstable; urgency=low
110
111   [ Joey Hess ]
112   * Removed special case repository deletion handling code. The same
113     thing can be accomplished in a mrconfig by skipping a repo unless
114     it exists, and printing a reminder on update. See the mrconfig file
115     for an example.
116   * Fix output of "mr config DEFAULT lib".
117   * Change mr update to use git pull -t origin master, to make sure new tags
118     are pulled. And since those might not always be the right parameters
119     for git pull, any parameters passed to mr update will replace them.
120
121   [ Alexander Wirt ]
122   * Add support for mercurial.
123
124   [ Joey Hess ]
125   * Incorporate code based on Anthony Towns's mrs, to allow running
126     multiple jobs in parallel. The -j flag controls this.
127     This can produce enormous speedups. For me, mr update takes
128     12 minutes, while mr -j 10 update takes 1 minute!
129
130  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
131
132 mr (0.4) unstable; urgency=low
133
134   * Fix mr register of a subdir to also work with -c.
135   * Signal handling for commands run by mr, including handling of SIGINT
136     to stop mr.
137   * Ensure parent dirs exist prior to checkout. (madduck)
138   * Output list of failed repos to stderr when -s is used.
139   * Fix a bug caused by a stupid typo.
140   * Add the -n switch, for disabling recursion.
141   * Allow for more complex deleted tests, such as marking a repo deleted on
142     some hosts, while not on others.
143   * Support registering CVS repositories. Closes: #447171
144   * MR_CONFIG now points to the config file that contains the repo mr is
145     acting on.
146   * Make mr register smarter about what mrconfig file to write to.
147     (It probably does what you'd expect it to do now; if it doesn't, -c
148     can still override.)
149
150  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
151
152 mr (0.3) unstable; urgency=low
153
154   * Add a check to make sure the expected directory exists after checkout.
155   * mr register will now write to whatever config file is specified with -c
156   * Typo fixes from madduck.
157
158  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
159
160 mr (0.2) unstable; urgency=low
161
162   * Fix line number display for config file parse errors.
163   * Fix a bug in inheritance of default settings in chained .mrconfig files.
164   * Add the -s option.
165
166  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
167
168 mr (0.1) unstable; urgency=low
169
170   * First release.
171
172  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400