All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.17) unstable; urgency=low
3 * Even bigger hammer: Set LC_ALL. Closes: #453305
5 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
7 mr (0.16) unstable; urgency=low
9 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
10 won't override it. Closes: #453305
12 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
14 mr (0.15) unstable; urgency=low
17 * Allow -n to be passed a number to specify how deep to go into
18 subdirectories to find repositories to act on. Closes: #450621
21 * Make -j with no argument run unlimited jobs in parallel, like make -j
25 * Add a warning about runing too many jobs at a time.
27 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
29 mr (0.14) unstable; urgency=low
31 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
32 Bloom. Closes: #449592
33 * Cut number of rcs tests run in half.
35 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
37 mr (0.13) unstable; urgency=low
39 * -c was broken, fix. Closes: #449539
41 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
43 mr (0.12) unstable; urgency=low
45 * Avoid creating parent directory for a checkout that will ultimately be
47 * Don't try to test the repo type when doing a checkout, that can't work
48 since the repo isn't there yet. It was actually checking the repo type
49 of the parent directory, which caused several unexpected behaviors.
51 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
53 mr (0.11) unstable; urgency=low
55 * Avoid using commands like git-config and instead use "git config".
56 In some configurations, only the main git command is in the path.
57 * Allow option bundling, mostly so "-j2" will work.
58 * Better error message if more than one repo type test matches a single
61 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
63 mr (0.10) unstable; urgency=low
65 * Add a lib file for using unison with mr.
66 * Make registration work when no config file yet exists. Closes: #448422
68 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
70 mr (0.9) unstable; urgency=low
72 * Split up actions, so each rcs has its own set of action commands,
73 and mr tests to see what rcs is used by a repository, and dispatches
76 This will make it much easier to add new rcses, or modify just the
77 command that mr uses for one command for one rcs, without duplicating a
78 lot of code, and without needing to modify mr at all.
80 The old style unsplit actions are still supported, and are what most
81 mrconfig files will still use; this change is fully backwards compatible.
82 * Changed some things in the enviroment for the register action.
83 It's now run in the directory that the user specifies, and MR_REPO
84 is set to contain the basename of the directory that the checkout
85 command should check out. These changes should be backware compatible
86 to existing register actions.
87 * Add info and warning functions to the shell library. (madduck)
88 * Add git_bare and git_fake_bare rcs types to handle
89 bare and fake bare (non-bare with a detached worktree) git repositories.
90 (Diff and commit do not work yet to fake bare repos). (madduck)
91 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
92 * Add support for including one mrconfig file from another. Unlike chaining,
93 this doesn't change the paths, and is not tied to a particular
94 subdirectory. It's useful for loading up library mrconfig files.
95 * Split git fake-bare support out into a lib/git-fake-bare.
96 Partly because it's a good example of how to add a new revision control
97 type and use includes, and partly because it's currently too ugly to be
98 in mr itself due to bugs and limitations in git.
100 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
102 mr (0.8) unstable; urgency=low
104 * Improve "in subdir" message.
105 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
106 interactive updates. Closes: #447999
108 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
110 mr (0.7) unstable; urgency=low
112 * Fix inverted tests in tags command. (madduck)
113 * Patch from Simon McVittie, adding support for darcs repositories.
116 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
118 mr (0.6) unstable; urgency=low
120 * Add to the example mrconfig a "tags" command that lists tags.
121 (Currently only for svn and git.)
122 * hours_since was broken by design, and fixing it involved changing
123 its calling convention. If you used the old version, the new version
125 * Add ability to reorder repos, if you want mr to act on a given repo first
128 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
130 mr (0.5) unstable; urgency=low
133 * Removed special case repository deletion handling code. The same
134 thing can be accomplished in a mrconfig by skipping a repo unless
135 it exists, and printing a reminder on update. See the mrconfig file
137 * Fix output of "mr config DEFAULT lib".
138 * Change mr update to use git pull -t origin master, to make sure new tags
139 are pulled. And since those might not always be the right parameters
140 for git pull, any parameters passed to mr update will replace them.
143 * Add support for mercurial.
146 * Incorporate code based on Anthony Towns's mrs, to allow running
147 multiple jobs in parallel. The -j flag controls this.
148 This can produce enormous speedups. For me, mr update takes
149 12 minutes, while mr -j 10 update takes 1 minute!
151 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
153 mr (0.4) unstable; urgency=low
155 * Fix mr register of a subdir to also work with -c.
156 * Signal handling for commands run by mr, including handling of SIGINT
158 * Ensure parent dirs exist prior to checkout. (madduck)
159 * Output list of failed repos to stderr when -s is used.
160 * Fix a bug caused by a stupid typo.
161 * Add the -n switch, for disabling recursion.
162 * Allow for more complex deleted tests, such as marking a repo deleted on
163 some hosts, while not on others.
164 * Support registering CVS repositories. Closes: #447171
165 * MR_CONFIG now points to the config file that contains the repo mr is
167 * Make mr register smarter about what mrconfig file to write to.
168 (It probably does what you'd expect it to do now; if it doesn't, -c
171 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
173 mr (0.3) unstable; urgency=low
175 * Add a check to make sure the expected directory exists after checkout.
176 * mr register will now write to whatever config file is specified with -c
177 * Typo fixes from madduck.
179 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
181 mr (0.2) unstable; urgency=low
183 * Fix line number display for config file parse errors.
184 * Fix a bug in inheritance of default settings in chained .mrconfig files.
187 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
189 mr (0.1) unstable; urgency=low
193 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400