]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Add a lib file for using unison with mr.
[code/myrepos.git] / debian / changelog
1 mr (0.10) UNRELEASED; urgency=low
2
3   * Add a lib file for using unison with mr.
4
5  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:57:51 -0400
6
7 mr (0.9) unstable; urgency=low
8
9   * Split up actions, so each rcs has its own set of action commands,
10     and mr tests to see what rcs is used by a repository, and dispatches
11     the command.
12
13     This will make it much easier to add new rcses, or modify just the
14     command that mr uses for one command for one rcs, without duplicating a
15     lot of code, and without needing to modify mr at all.
16
17     The old style unsplit actions are still supported, and are what most
18     mrconfig files will still use; this change is fully backwards compatible.
19   * Changed some things in the enviroment for the register action.
20     It's now run in the directory that the user specifies, and MR_REPO
21     is set to contain the basename of the directory that the checkout
22     command should check out. These changes should be backware compatible
23     to existing register actions.
24   * Add info and warning functions to the shell library. (madduck)
25   * Add git_bare and git_fake_bare rcs types to handle
26     bare and fake bare (non-bare with a detached worktree) git repositories.
27     (Diff and commit do not work yet to fake bare repos). (madduck)
28   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
29   * Add support for including one mrconfig file from another. Unlike chaining,
30     this doesn't change the paths, and is not tied to a particular
31     subdirectory. It's useful for loading up library mrconfig files.
32   * Split git fake-bare support out into a lib/git-fake-bare.
33     Partly because it's a good example of how to add a new revision control
34     type and use includes, and partly because it's currently too ugly to be
35     in mr itself due to bugs and limitations in git.
36
37  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
38
39 mr (0.8) unstable; urgency=low
40
41   * Improve "in subdir" message.
42   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
43     interactive updates. Closes: #447999
44
45  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
46
47 mr (0.7) unstable; urgency=low
48
49   * Fix inverted tests in tags command. (madduck)
50   * Patch from Simon McVittie, adding support for darcs repositories.
51     Closes: #447729
52
53  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
54
55 mr (0.6) unstable; urgency=low
56
57   * Add to the example mrconfig a "tags" command that lists tags.
58     (Currently only for svn and git.)
59   * hours_since was broken by design, and fixing it involved changing
60     its calling convention. If you used the old version, the new version
61     will error out.
62   * Add ability to reorder repos, if you want mr to act on a given repo first
63     or last.
64
65  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
66
67 mr (0.5) unstable; urgency=low
68
69   [ Joey Hess ]
70   * Removed special case repository deletion handling code. The same
71     thing can be accomplished in a mrconfig by skipping a repo unless
72     it exists, and printing a reminder on update. See the mrconfig file
73     for an example.
74   * Fix output of "mr config DEFAULT lib".
75   * Change mr update to use git pull -t origin master, to make sure new tags
76     are pulled. And since those might not always be the right parameters
77     for git pull, any parameters passed to mr update will replace them.
78
79   [ Alexander Wirt ]
80   * Add support for mercurial.
81
82   [ Joey Hess ]
83   * Incorporate code based on Anthony Towns's mrs, to allow running
84     multiple jobs in parallel. The -j flag controls this.
85     This can produce enormous speedups. For me, mr update takes
86     12 minutes, while mr -j 10 update takes 1 minute!
87
88  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
89
90 mr (0.4) unstable; urgency=low
91
92   * Fix mr register of a subdir to also work with -c.
93   * Signal handling for commands run by mr, including handling of SIGINT
94     to stop mr.
95   * Ensure parent dirs exist prior to checkout. (madduck)
96   * Output list of failed repos to stderr when -s is used.
97   * Fix a bug caused by a stupid typo.
98   * Add the -n switch, for disabling recursion.
99   * Allow for more complex deleted tests, such as marking a repo deleted on
100     some hosts, while not on others.
101   * Support registering CVS repositories. Closes: #447171
102   * MR_CONFIG now points to the config file that contains the repo mr is
103     acting on.
104   * Make mr register smarter about what mrconfig file to write to.
105     (It probably does what you'd expect it to do now; if it doesn't, -c
106     can still override.)
107
108  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
109
110 mr (0.3) unstable; urgency=low
111
112   * Add a check to make sure the expected directory exists after checkout.
113   * mr register will now write to whatever config file is specified with -c
114   * Typo fixes from madduck.
115
116  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
117
118 mr (0.2) unstable; urgency=low
119
120   * Fix line number display for config file parse errors.
121   * Fix a bug in inheritance of default settings in chained .mrconfig files.
122   * Add the -s option.
123
124  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
125
126 mr (0.1) unstable; urgency=low
127
128   * First release.
129
130  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400