All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.23) unstable; urgency=low
3 * Fix tests in git-svn include file to use MR_REPO. Closes: #463941
5 -- Joey Hess <joeyh@debian.org> Tue, 05 Feb 2008 13:26:05 -0500
7 mr (0.22) unstable; urgency=low
9 * Update bzr registration code to work with current version of bzr,
10 using bzr info to get the url. Closes: #463867
12 -- Joey Hess <joeyh@debian.org> Sun, 03 Feb 2008 17:04:59 -0500
14 mr (0.21) unstable; urgency=low
16 * Add a git-svn file, which can be included to add support for git-svn
17 repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
18 for implementations. Closes: #462408
20 -- Joey Hess <joeyh@debian.org> Thu, 24 Jan 2008 13:45:05 -0500
22 mr (0.20) unstable; urgency=low
25 * darcs: Add -u to diff to get a more usual unified diff.
26 * Add a "record" subcommand, borrowing termonology from darcs. This does a
27 local commit, but does not push changes to remote repos.
28 * Improve unison support.
30 -- Joey Hess <joeyh@debian.org> Wed, 02 Jan 2008 22:49:53 -0500
32 mr (0.19) unstable; urgency=low
34 * Support versions of man that don't use -l.
35 * Updating git repos no longer uses git-pull -t by default. Git makes it
36 to much of a PITA to do this, since -t makes git-pull require the
37 repository and refspec be specified at the command line (which is a bug in
38 git (#456035). mr used to hardcode those to "origin" and "master", but
39 that's not always the right choice. So give up on forcing git to be sane
40 about pulling down all tags. It's insane. Live with it, or configure your
43 -- Joey Hess <joeyh@debian.org> Wed, 12 Dec 2007 21:30:45 -0500
45 mr (0.18) unstable; urgency=low
47 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
48 * darcs: De-p register code. Closes: #453502
50 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
52 mr (0.17) unstable; urgency=low
54 * Even bigger hammer: Set LC_ALL. Closes: #453305
56 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
58 mr (0.16) unstable; urgency=low
60 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
61 won't override it. Closes: #453305
63 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
65 mr (0.15) unstable; urgency=low
68 * Allow -n to be passed a number to specify how deep to go into
69 subdirectories to find repositories to act on. Closes: #450621
72 * Make -j with no argument run unlimited jobs in parallel, like make -j
76 * Add a warning about runing too many jobs at a time.
78 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
80 mr (0.14) unstable; urgency=low
82 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
83 Bloom. Closes: #449592
84 * Cut number of rcs tests run in half.
86 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
88 mr (0.13) unstable; urgency=low
90 * -c was broken, fix. Closes: #449539
92 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
94 mr (0.12) unstable; urgency=low
96 * Avoid creating parent directory for a checkout that will ultimately be
98 * Don't try to test the repo type when doing a checkout, that can't work
99 since the repo isn't there yet. It was actually checking the repo type
100 of the parent directory, which caused several unexpected behaviors.
102 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
104 mr (0.11) unstable; urgency=low
106 * Avoid using commands like git-config and instead use "git config".
107 In some configurations, only the main git command is in the path.
108 * Allow option bundling, mostly so "-j2" will work.
109 * Better error message if more than one repo type test matches a single
112 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
114 mr (0.10) unstable; urgency=low
116 * Add a lib file for using unison with mr.
117 * Make registration work when no config file yet exists. Closes: #448422
119 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
121 mr (0.9) unstable; urgency=low
123 * Split up actions, so each rcs has its own set of action commands,
124 and mr tests to see what rcs is used by a repository, and dispatches
127 This will make it much easier to add new rcses, or modify just the
128 command that mr uses for one command for one rcs, without duplicating a
129 lot of code, and without needing to modify mr at all.
131 The old style unsplit actions are still supported, and are what most
132 mrconfig files will still use; this change is fully backwards compatible.
133 * Changed some things in the enviroment for the register action.
134 It's now run in the directory that the user specifies, and MR_REPO
135 is set to contain the basename of the directory that the checkout
136 command should check out. These changes should be backware compatible
137 to existing register actions.
138 * Add info and warning functions to the shell library. (madduck)
139 * Add git_bare and git_fake_bare rcs types to handle
140 bare and fake bare (non-bare with a detached worktree) git repositories.
141 (Diff and commit do not work yet to fake bare repos). (madduck)
142 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
143 * Add support for including one mrconfig file from another. Unlike chaining,
144 this doesn't change the paths, and is not tied to a particular
145 subdirectory. It's useful for loading up library mrconfig files.
146 * Split git fake-bare support out into a lib/git-fake-bare.
147 Partly because it's a good example of how to add a new revision control
148 type and use includes, and partly because it's currently too ugly to be
149 in mr itself due to bugs and limitations in git.
151 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
153 mr (0.8) unstable; urgency=low
155 * Improve "in subdir" message.
156 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
157 interactive updates. Closes: #447999
159 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
161 mr (0.7) unstable; urgency=low
163 * Fix inverted tests in tags command. (madduck)
164 * Patch from Simon McVittie, adding support for darcs repositories.
167 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
169 mr (0.6) unstable; urgency=low
171 * Add to the example mrconfig a "tags" command that lists tags.
172 (Currently only for svn and git.)
173 * hours_since was broken by design, and fixing it involved changing
174 its calling convention. If you used the old version, the new version
176 * Add ability to reorder repos, if you want mr to act on a given repo first
179 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
181 mr (0.5) unstable; urgency=low
184 * Removed special case repository deletion handling code. The same
185 thing can be accomplished in a mrconfig by skipping a repo unless
186 it exists, and printing a reminder on update. See the mrconfig file
188 * Fix output of "mr config DEFAULT lib".
189 * Change mr update to use git pull -t origin master, to make sure new tags
190 are pulled. And since those might not always be the right parameters
191 for git pull, any parameters passed to mr update will replace them.
194 * Add support for mercurial.
197 * Incorporate code based on Anthony Towns's mrs, to allow running
198 multiple jobs in parallel. The -j flag controls this.
199 This can produce enormous speedups. For me, mr update takes
200 12 minutes, while mr -j 10 update takes 1 minute!
202 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
204 mr (0.4) unstable; urgency=low
206 * Fix mr register of a subdir to also work with -c.
207 * Signal handling for commands run by mr, including handling of SIGINT
209 * Ensure parent dirs exist prior to checkout. (madduck)
210 * Output list of failed repos to stderr when -s is used.
211 * Fix a bug caused by a stupid typo.
212 * Add the -n switch, for disabling recursion.
213 * Allow for more complex deleted tests, such as marking a repo deleted on
214 some hosts, while not on others.
215 * Support registering CVS repositories. Closes: #447171
216 * MR_CONFIG now points to the config file that contains the repo mr is
218 * Make mr register smarter about what mrconfig file to write to.
219 (It probably does what you'd expect it to do now; if it doesn't, -c
222 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
224 mr (0.3) unstable; urgency=low
226 * Add a check to make sure the expected directory exists after checkout.
227 * mr register will now write to whatever config file is specified with -c
228 * Typo fixes from madduck.
230 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
232 mr (0.2) unstable; urgency=low
234 * Fix line number display for config file parse errors.
235 * Fix a bug in inheritance of default settings in chained .mrconfig files.
238 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
240 mr (0.1) unstable; urgency=low
244 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400