]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
[code/myrepos.git] / debian / changelog
1 mr (0.16) unstable; urgency=low
2
3   * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
4     won't override it. Closes: #453305
5
6  -- Joey Hess <joeyh@debian.org>  Wed, 28 Nov 2007 15:46:38 -0500
7
8 mr (0.15) unstable; urgency=low
9
10   [ Joey Hess ]
11   * Allow -n to be passed a number to specify how deep to go into
12     subdirectories to find repositories to act on. Closes: #450621
13
14   [ Josh Triplett ]
15   * Make -j with no argument run unlimited jobs in parallel, like make -j
16     Closes: #452467
17
18   [ Joey Hess ]
19   * Add a warning about runing too many jobs at a time.
20
21  -- Joey Hess <joeyh@debian.org>  Sun, 25 Nov 2007 13:13:47 -0500
22
23 mr (0.14) unstable; urgency=low
24
25   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
26     Bloom. Closes: #449592
27   * Cut number of rcs tests run in half.
28
29  -- Joey Hess <joeyh@debian.org>  Sun, 11 Nov 2007 01:10:18 -0500
30
31 mr (0.13) unstable; urgency=low
32
33   * -c was broken, fix. Closes: #449539
34
35  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
36
37 mr (0.12) unstable; urgency=low
38
39   * Avoid creating parent directory for a checkout that will ultimately be
40     skipped.
41   * Don't try to test the repo type when doing a checkout, that can't work
42     since the repo isn't there yet. It was actually checking the repo type
43     of the parent directory, which caused several unexpected behaviors.
44
45  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
46
47 mr (0.11) unstable; urgency=low
48
49   * Avoid using commands like git-config and instead use "git config".
50     In some configurations, only the main git command is in the path.
51   * Allow option bundling, mostly so "-j2" will work.
52   * Better error message if more than one repo type test matches a single
53     directory.
54
55  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
56
57 mr (0.10) unstable; urgency=low
58
59   * Add a lib file for using unison with mr.
60   * Make registration work when no config file yet exists. Closes: #448422
61
62  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
63
64 mr (0.9) unstable; urgency=low
65
66   * Split up actions, so each rcs has its own set of action commands,
67     and mr tests to see what rcs is used by a repository, and dispatches
68     the command.
69
70     This will make it much easier to add new rcses, or modify just the
71     command that mr uses for one command for one rcs, without duplicating a
72     lot of code, and without needing to modify mr at all.
73
74     The old style unsplit actions are still supported, and are what most
75     mrconfig files will still use; this change is fully backwards compatible.
76   * Changed some things in the enviroment for the register action.
77     It's now run in the directory that the user specifies, and MR_REPO
78     is set to contain the basename of the directory that the checkout
79     command should check out. These changes should be backware compatible
80     to existing register actions.
81   * Add info and warning functions to the shell library. (madduck)
82   * Add git_bare and git_fake_bare rcs types to handle
83     bare and fake bare (non-bare with a detached worktree) git repositories.
84     (Diff and commit do not work yet to fake bare repos). (madduck)
85   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
86   * Add support for including one mrconfig file from another. Unlike chaining,
87     this doesn't change the paths, and is not tied to a particular
88     subdirectory. It's useful for loading up library mrconfig files.
89   * Split git fake-bare support out into a lib/git-fake-bare.
90     Partly because it's a good example of how to add a new revision control
91     type and use includes, and partly because it's currently too ugly to be
92     in mr itself due to bugs and limitations in git.
93
94  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
95
96 mr (0.8) unstable; urgency=low
97
98   * Improve "in subdir" message.
99   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
100     interactive updates. Closes: #447999
101
102  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
103
104 mr (0.7) unstable; urgency=low
105
106   * Fix inverted tests in tags command. (madduck)
107   * Patch from Simon McVittie, adding support for darcs repositories.
108     Closes: #447729
109
110  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
111
112 mr (0.6) unstable; urgency=low
113
114   * Add to the example mrconfig a "tags" command that lists tags.
115     (Currently only for svn and git.)
116   * hours_since was broken by design, and fixing it involved changing
117     its calling convention. If you used the old version, the new version
118     will error out.
119   * Add ability to reorder repos, if you want mr to act on a given repo first
120     or last.
121
122  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
123
124 mr (0.5) unstable; urgency=low
125
126   [ Joey Hess ]
127   * Removed special case repository deletion handling code. The same
128     thing can be accomplished in a mrconfig by skipping a repo unless
129     it exists, and printing a reminder on update. See the mrconfig file
130     for an example.
131   * Fix output of "mr config DEFAULT lib".
132   * Change mr update to use git pull -t origin master, to make sure new tags
133     are pulled. And since those might not always be the right parameters
134     for git pull, any parameters passed to mr update will replace them.
135
136   [ Alexander Wirt ]
137   * Add support for mercurial.
138
139   [ Joey Hess ]
140   * Incorporate code based on Anthony Towns's mrs, to allow running
141     multiple jobs in parallel. The -j flag controls this.
142     This can produce enormous speedups. For me, mr update takes
143     12 minutes, while mr -j 10 update takes 1 minute!
144
145  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
146
147 mr (0.4) unstable; urgency=low
148
149   * Fix mr register of a subdir to also work with -c.
150   * Signal handling for commands run by mr, including handling of SIGINT
151     to stop mr.
152   * Ensure parent dirs exist prior to checkout. (madduck)
153   * Output list of failed repos to stderr when -s is used.
154   * Fix a bug caused by a stupid typo.
155   * Add the -n switch, for disabling recursion.
156   * Allow for more complex deleted tests, such as marking a repo deleted on
157     some hosts, while not on others.
158   * Support registering CVS repositories. Closes: #447171
159   * MR_CONFIG now points to the config file that contains the repo mr is
160     acting on.
161   * Make mr register smarter about what mrconfig file to write to.
162     (It probably does what you'd expect it to do now; if it doesn't, -c
163     can still override.)
164
165  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
166
167 mr (0.3) unstable; urgency=low
168
169   * Add a check to make sure the expected directory exists after checkout.
170   * mr register will now write to whatever config file is specified with -c
171   * Typo fixes from madduck.
172
173  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
174
175 mr (0.2) unstable; urgency=low
176
177   * Fix line number display for config file parse errors.
178   * Fix a bug in inheritance of default settings in chained .mrconfig files.
179   * Add the -s option.
180
181  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
182
183 mr (0.1) unstable; urgency=low
184
185   * First release.
186
187  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400