All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.20) UNRELEASED; urgency=low
4 * darcs: Add -u to diff to get a more usual unified diff.
5 * Add a "record" subcommand, borrowing termonology from darcs. This does a
6 local commit, but does not push changes to remote repos.
8 -- Joey Hess <joeyh@debian.org> Sat, 22 Dec 2007 13:53:31 -0500
10 mr (0.19) unstable; urgency=low
12 * Support versions of man that don't use -l.
13 * Updating git repos no longer uses git-pull -t by default. Git makes it
14 to much of a PITA to do this, since -t makes git-pull require the
15 repository and refspec be specified at the command line (which is a bug in
16 git (#456035). mr used to hardcode those to "origin" and "master", but
17 that's not always the right choice. So give up on forcing git to be sane
18 about pulling down all tags. It's insane. Live with it, or configure your
21 -- Joey Hess <joeyh@debian.org> Wed, 12 Dec 2007 21:30:45 -0500
23 mr (0.18) unstable; urgency=low
25 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
26 * darcs: De-p register code. Closes: #453502
28 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
30 mr (0.17) unstable; urgency=low
32 * Even bigger hammer: Set LC_ALL. Closes: #453305
34 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
36 mr (0.16) unstable; urgency=low
38 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
39 won't override it. Closes: #453305
41 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
43 mr (0.15) unstable; urgency=low
46 * Allow -n to be passed a number to specify how deep to go into
47 subdirectories to find repositories to act on. Closes: #450621
50 * Make -j with no argument run unlimited jobs in parallel, like make -j
54 * Add a warning about runing too many jobs at a time.
56 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
58 mr (0.14) unstable; urgency=low
60 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
61 Bloom. Closes: #449592
62 * Cut number of rcs tests run in half.
64 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
66 mr (0.13) unstable; urgency=low
68 * -c was broken, fix. Closes: #449539
70 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
72 mr (0.12) unstable; urgency=low
74 * Avoid creating parent directory for a checkout that will ultimately be
76 * Don't try to test the repo type when doing a checkout, that can't work
77 since the repo isn't there yet. It was actually checking the repo type
78 of the parent directory, which caused several unexpected behaviors.
80 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
82 mr (0.11) unstable; urgency=low
84 * Avoid using commands like git-config and instead use "git config".
85 In some configurations, only the main git command is in the path.
86 * Allow option bundling, mostly so "-j2" will work.
87 * Better error message if more than one repo type test matches a single
90 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
92 mr (0.10) unstable; urgency=low
94 * Add a lib file for using unison with mr.
95 * Make registration work when no config file yet exists. Closes: #448422
97 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
99 mr (0.9) unstable; urgency=low
101 * Split up actions, so each rcs has its own set of action commands,
102 and mr tests to see what rcs is used by a repository, and dispatches
105 This will make it much easier to add new rcses, or modify just the
106 command that mr uses for one command for one rcs, without duplicating a
107 lot of code, and without needing to modify mr at all.
109 The old style unsplit actions are still supported, and are what most
110 mrconfig files will still use; this change is fully backwards compatible.
111 * Changed some things in the enviroment for the register action.
112 It's now run in the directory that the user specifies, and MR_REPO
113 is set to contain the basename of the directory that the checkout
114 command should check out. These changes should be backware compatible
115 to existing register actions.
116 * Add info and warning functions to the shell library. (madduck)
117 * Add git_bare and git_fake_bare rcs types to handle
118 bare and fake bare (non-bare with a detached worktree) git repositories.
119 (Diff and commit do not work yet to fake bare repos). (madduck)
120 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
121 * Add support for including one mrconfig file from another. Unlike chaining,
122 this doesn't change the paths, and is not tied to a particular
123 subdirectory. It's useful for loading up library mrconfig files.
124 * Split git fake-bare support out into a lib/git-fake-bare.
125 Partly because it's a good example of how to add a new revision control
126 type and use includes, and partly because it's currently too ugly to be
127 in mr itself due to bugs and limitations in git.
129 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
131 mr (0.8) unstable; urgency=low
133 * Improve "in subdir" message.
134 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
135 interactive updates. Closes: #447999
137 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
139 mr (0.7) unstable; urgency=low
141 * Fix inverted tests in tags command. (madduck)
142 * Patch from Simon McVittie, adding support for darcs repositories.
145 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
147 mr (0.6) unstable; urgency=low
149 * Add to the example mrconfig a "tags" command that lists tags.
150 (Currently only for svn and git.)
151 * hours_since was broken by design, and fixing it involved changing
152 its calling convention. If you used the old version, the new version
154 * Add ability to reorder repos, if you want mr to act on a given repo first
157 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
159 mr (0.5) unstable; urgency=low
162 * Removed special case repository deletion handling code. The same
163 thing can be accomplished in a mrconfig by skipping a repo unless
164 it exists, and printing a reminder on update. See the mrconfig file
166 * Fix output of "mr config DEFAULT lib".
167 * Change mr update to use git pull -t origin master, to make sure new tags
168 are pulled. And since those might not always be the right parameters
169 for git pull, any parameters passed to mr update will replace them.
172 * Add support for mercurial.
175 * Incorporate code based on Anthony Towns's mrs, to allow running
176 multiple jobs in parallel. The -j flag controls this.
177 This can produce enormous speedups. For me, mr update takes
178 12 minutes, while mr -j 10 update takes 1 minute!
180 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
182 mr (0.4) unstable; urgency=low
184 * Fix mr register of a subdir to also work with -c.
185 * Signal handling for commands run by mr, including handling of SIGINT
187 * Ensure parent dirs exist prior to checkout. (madduck)
188 * Output list of failed repos to stderr when -s is used.
189 * Fix a bug caused by a stupid typo.
190 * Add the -n switch, for disabling recursion.
191 * Allow for more complex deleted tests, such as marking a repo deleted on
192 some hosts, while not on others.
193 * Support registering CVS repositories. Closes: #447171
194 * MR_CONFIG now points to the config file that contains the repo mr is
196 * Make mr register smarter about what mrconfig file to write to.
197 (It probably does what you'd expect it to do now; if it doesn't, -c
200 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
202 mr (0.3) unstable; urgency=low
204 * Add a check to make sure the expected directory exists after checkout.
205 * mr register will now write to whatever config file is specified with -c
206 * Typo fixes from madduck.
208 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
210 mr (0.2) unstable; urgency=low
212 * Fix line number display for config file parse errors.
213 * Fix a bug in inheritance of default settings in chained .mrconfig files.
216 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
218 mr (0.1) unstable; urgency=low
222 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400