All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.20) UNRELEASED; urgency=low
4 * darcs: Add -u to diff to get a more usual unified diff.
6 -- Joey Hess <joeyh@debian.org> Sat, 22 Dec 2007 13:53:31 -0500
8 mr (0.19) unstable; urgency=low
10 * Support versions of man that don't use -l.
11 * Updating git repos no longer uses git-pull -t by default. Git makes it
12 to much of a PITA to do this, since -t makes git-pull require the
13 repository and refspec be specified at the command line (which is a bug in
14 git (#456035). mr used to hardcode those to "origin" and "master", but
15 that's not always the right choice. So give up on forcing git to be sane
16 about pulling down all tags. It's insane. Live with it, or configure your
19 -- Joey Hess <joeyh@debian.org> Wed, 12 Dec 2007 21:30:45 -0500
21 mr (0.18) unstable; urgency=low
23 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
24 * darcs: De-p register code. Closes: #453502
26 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
28 mr (0.17) unstable; urgency=low
30 * Even bigger hammer: Set LC_ALL. Closes: #453305
32 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
34 mr (0.16) unstable; urgency=low
36 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
37 won't override it. Closes: #453305
39 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
41 mr (0.15) unstable; urgency=low
44 * Allow -n to be passed a number to specify how deep to go into
45 subdirectories to find repositories to act on. Closes: #450621
48 * Make -j with no argument run unlimited jobs in parallel, like make -j
52 * Add a warning about runing too many jobs at a time.
54 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
56 mr (0.14) unstable; urgency=low
58 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
59 Bloom. Closes: #449592
60 * Cut number of rcs tests run in half.
62 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
64 mr (0.13) unstable; urgency=low
66 * -c was broken, fix. Closes: #449539
68 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
70 mr (0.12) unstable; urgency=low
72 * Avoid creating parent directory for a checkout that will ultimately be
74 * Don't try to test the repo type when doing a checkout, that can't work
75 since the repo isn't there yet. It was actually checking the repo type
76 of the parent directory, which caused several unexpected behaviors.
78 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
80 mr (0.11) unstable; urgency=low
82 * Avoid using commands like git-config and instead use "git config".
83 In some configurations, only the main git command is in the path.
84 * Allow option bundling, mostly so "-j2" will work.
85 * Better error message if more than one repo type test matches a single
88 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
90 mr (0.10) unstable; urgency=low
92 * Add a lib file for using unison with mr.
93 * Make registration work when no config file yet exists. Closes: #448422
95 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
97 mr (0.9) unstable; urgency=low
99 * Split up actions, so each rcs has its own set of action commands,
100 and mr tests to see what rcs is used by a repository, and dispatches
103 This will make it much easier to add new rcses, or modify just the
104 command that mr uses for one command for one rcs, without duplicating a
105 lot of code, and without needing to modify mr at all.
107 The old style unsplit actions are still supported, and are what most
108 mrconfig files will still use; this change is fully backwards compatible.
109 * Changed some things in the enviroment for the register action.
110 It's now run in the directory that the user specifies, and MR_REPO
111 is set to contain the basename of the directory that the checkout
112 command should check out. These changes should be backware compatible
113 to existing register actions.
114 * Add info and warning functions to the shell library. (madduck)
115 * Add git_bare and git_fake_bare rcs types to handle
116 bare and fake bare (non-bare with a detached worktree) git repositories.
117 (Diff and commit do not work yet to fake bare repos). (madduck)
118 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
119 * Add support for including one mrconfig file from another. Unlike chaining,
120 this doesn't change the paths, and is not tied to a particular
121 subdirectory. It's useful for loading up library mrconfig files.
122 * Split git fake-bare support out into a lib/git-fake-bare.
123 Partly because it's a good example of how to add a new revision control
124 type and use includes, and partly because it's currently too ugly to be
125 in mr itself due to bugs and limitations in git.
127 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
129 mr (0.8) unstable; urgency=low
131 * Improve "in subdir" message.
132 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
133 interactive updates. Closes: #447999
135 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
137 mr (0.7) unstable; urgency=low
139 * Fix inverted tests in tags command. (madduck)
140 * Patch from Simon McVittie, adding support for darcs repositories.
143 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
145 mr (0.6) unstable; urgency=low
147 * Add to the example mrconfig a "tags" command that lists tags.
148 (Currently only for svn and git.)
149 * hours_since was broken by design, and fixing it involved changing
150 its calling convention. If you used the old version, the new version
152 * Add ability to reorder repos, if you want mr to act on a given repo first
155 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
157 mr (0.5) unstable; urgency=low
160 * Removed special case repository deletion handling code. The same
161 thing can be accomplished in a mrconfig by skipping a repo unless
162 it exists, and printing a reminder on update. See the mrconfig file
164 * Fix output of "mr config DEFAULT lib".
165 * Change mr update to use git pull -t origin master, to make sure new tags
166 are pulled. And since those might not always be the right parameters
167 for git pull, any parameters passed to mr update will replace them.
170 * Add support for mercurial.
173 * Incorporate code based on Anthony Towns's mrs, to allow running
174 multiple jobs in parallel. The -j flag controls this.
175 This can produce enormous speedups. For me, mr update takes
176 12 minutes, while mr -j 10 update takes 1 minute!
178 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
180 mr (0.4) unstable; urgency=low
182 * Fix mr register of a subdir to also work with -c.
183 * Signal handling for commands run by mr, including handling of SIGINT
185 * Ensure parent dirs exist prior to checkout. (madduck)
186 * Output list of failed repos to stderr when -s is used.
187 * Fix a bug caused by a stupid typo.
188 * Add the -n switch, for disabling recursion.
189 * Allow for more complex deleted tests, such as marking a repo deleted on
190 some hosts, while not on others.
191 * Support registering CVS repositories. Closes: #447171
192 * MR_CONFIG now points to the config file that contains the repo mr is
194 * Make mr register smarter about what mrconfig file to write to.
195 (It probably does what you'd expect it to do now; if it doesn't, -c
198 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
200 mr (0.3) unstable; urgency=low
202 * Add a check to make sure the expected directory exists after checkout.
203 * mr register will now write to whatever config file is specified with -c
204 * Typo fixes from madduck.
206 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
208 mr (0.2) unstable; urgency=low
210 * Fix line number display for config file parse errors.
211 * Fix a bug in inheritance of default settings in chained .mrconfig files.
214 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
216 mr (0.1) unstable; urgency=low
220 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400