]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Don't try to test the repo type when doing a checkout, that can't work
[code/myrepos.git] / debian / changelog
1 mr (0.12) UNRELEASED; urgency=low
2
3   * Avoid creating parent directory for a checkout that will ultimately be
4     skipped.
5   * Don't try to test the repo type when doing a checkout, that can't work
6     since the repo isn't there yet. It was actually checking the repo type
7     of the parent directory, which caused several unexpected behaviors.
8
9  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:04:47 -0400
10
11 mr (0.11) unstable; urgency=low
12
13   * Avoid using commands like git-config and instead use "git config".
14     In some configurations, only the main git command is in the path.
15   * Allow option bundling, mostly so "-j2" will work.
16   * Better error message if more than one repo type test matches a single
17     directory.
18
19  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
20
21 mr (0.10) unstable; urgency=low
22
23   * Add a lib file for using unison with mr.
24   * Make registration work when no config file yet exists. Closes: #448422
25
26  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
27
28 mr (0.9) unstable; urgency=low
29
30   * Split up actions, so each rcs has its own set of action commands,
31     and mr tests to see what rcs is used by a repository, and dispatches
32     the command.
33
34     This will make it much easier to add new rcses, or modify just the
35     command that mr uses for one command for one rcs, without duplicating a
36     lot of code, and without needing to modify mr at all.
37
38     The old style unsplit actions are still supported, and are what most
39     mrconfig files will still use; this change is fully backwards compatible.
40   * Changed some things in the enviroment for the register action.
41     It's now run in the directory that the user specifies, and MR_REPO
42     is set to contain the basename of the directory that the checkout
43     command should check out. These changes should be backware compatible
44     to existing register actions.
45   * Add info and warning functions to the shell library. (madduck)
46   * Add git_bare and git_fake_bare rcs types to handle
47     bare and fake bare (non-bare with a detached worktree) git repositories.
48     (Diff and commit do not work yet to fake bare repos). (madduck)
49   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
50   * Add support for including one mrconfig file from another. Unlike chaining,
51     this doesn't change the paths, and is not tied to a particular
52     subdirectory. It's useful for loading up library mrconfig files.
53   * Split git fake-bare support out into a lib/git-fake-bare.
54     Partly because it's a good example of how to add a new revision control
55     type and use includes, and partly because it's currently too ugly to be
56     in mr itself due to bugs and limitations in git.
57
58  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
59
60 mr (0.8) unstable; urgency=low
61
62   * Improve "in subdir" message.
63   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
64     interactive updates. Closes: #447999
65
66  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
67
68 mr (0.7) unstable; urgency=low
69
70   * Fix inverted tests in tags command. (madduck)
71   * Patch from Simon McVittie, adding support for darcs repositories.
72     Closes: #447729
73
74  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
75
76 mr (0.6) unstable; urgency=low
77
78   * Add to the example mrconfig a "tags" command that lists tags.
79     (Currently only for svn and git.)
80   * hours_since was broken by design, and fixing it involved changing
81     its calling convention. If you used the old version, the new version
82     will error out.
83   * Add ability to reorder repos, if you want mr to act on a given repo first
84     or last.
85
86  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
87
88 mr (0.5) unstable; urgency=low
89
90   [ Joey Hess ]
91   * Removed special case repository deletion handling code. The same
92     thing can be accomplished in a mrconfig by skipping a repo unless
93     it exists, and printing a reminder on update. See the mrconfig file
94     for an example.
95   * Fix output of "mr config DEFAULT lib".
96   * Change mr update to use git pull -t origin master, to make sure new tags
97     are pulled. And since those might not always be the right parameters
98     for git pull, any parameters passed to mr update will replace them.
99
100   [ Alexander Wirt ]
101   * Add support for mercurial.
102
103   [ Joey Hess ]
104   * Incorporate code based on Anthony Towns's mrs, to allow running
105     multiple jobs in parallel. The -j flag controls this.
106     This can produce enormous speedups. For me, mr update takes
107     12 minutes, while mr -j 10 update takes 1 minute!
108
109  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
110
111 mr (0.4) unstable; urgency=low
112
113   * Fix mr register of a subdir to also work with -c.
114   * Signal handling for commands run by mr, including handling of SIGINT
115     to stop mr.
116   * Ensure parent dirs exist prior to checkout. (madduck)
117   * Output list of failed repos to stderr when -s is used.
118   * Fix a bug caused by a stupid typo.
119   * Add the -n switch, for disabling recursion.
120   * Allow for more complex deleted tests, such as marking a repo deleted on
121     some hosts, while not on others.
122   * Support registering CVS repositories. Closes: #447171
123   * MR_CONFIG now points to the config file that contains the repo mr is
124     acting on.
125   * Make mr register smarter about what mrconfig file to write to.
126     (It probably does what you'd expect it to do now; if it doesn't, -c
127     can still override.)
128
129  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
130
131 mr (0.3) unstable; urgency=low
132
133   * Add a check to make sure the expected directory exists after checkout.
134   * mr register will now write to whatever config file is specified with -c
135   * Typo fixes from madduck.
136
137  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
138
139 mr (0.2) unstable; urgency=low
140
141   * Fix line number display for config file parse errors.
142   * Fix a bug in inheritance of default settings in chained .mrconfig files.
143   * Add the -s option.
144
145  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
146
147 mr (0.1) unstable; urgency=low
148
149   * First release.
150
151  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400