All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.26) UNRELEASED; urgency=low
3 * Add -i option to start a shell if an operation fails. Closes: #474962
5 -- Joey Hess <joeyh@debian.org> Tue, 08 Apr 2008 13:54:35 -0400
7 mr (0.25) unstable; urgency=low
9 * git-fake-bare: Add support for diff, commit, and record. (madduck)
11 -- Joey Hess <joeyh@debian.org> Mon, 10 Mar 2008 15:56:17 -0400
13 mr (0.24) unstable; urgency=low
15 * Correct GIT_CONFIG settings in git-svn. Closes: #463941
17 -- Joey Hess <joeyh@debian.org> Wed, 06 Feb 2008 13:04:30 -0500
19 mr (0.23) unstable; urgency=low
21 * Fix tests in git-svn include file to use MR_REPO. Closes: #463941
23 -- Joey Hess <joeyh@debian.org> Tue, 05 Feb 2008 13:26:05 -0500
25 mr (0.22) unstable; urgency=low
27 * Update bzr registration code to work with current version of bzr,
28 using bzr info to get the url. Closes: #463867
30 -- Joey Hess <joeyh@debian.org> Sun, 03 Feb 2008 17:04:59 -0500
32 mr (0.21) unstable; urgency=low
34 * Add a git-svn file, which can be included to add support for git-svn
35 repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
36 for implementations. Closes: #462408
38 -- Joey Hess <joeyh@debian.org> Thu, 24 Jan 2008 13:45:05 -0500
40 mr (0.20) unstable; urgency=low
43 * darcs: Add -u to diff to get a more usual unified diff.
44 * Add a "record" subcommand, borrowing termonology from darcs. This does a
45 local commit, but does not push changes to remote repos.
46 * Improve unison support.
48 -- Joey Hess <joeyh@debian.org> Wed, 02 Jan 2008 22:49:53 -0500
50 mr (0.19) unstable; urgency=low
52 * Support versions of man that don't use -l.
53 * Updating git repos no longer uses git-pull -t by default. Git makes it
54 to much of a PITA to do this, since -t makes git-pull require the
55 repository and refspec be specified at the command line (which is a bug in
56 git (#456035). mr used to hardcode those to "origin" and "master", but
57 that's not always the right choice. So give up on forcing git to be sane
58 about pulling down all tags. It's insane. Live with it, or configure your
61 -- Joey Hess <joeyh@debian.org> Wed, 12 Dec 2007 21:30:45 -0500
63 mr (0.18) unstable; urgency=low
65 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
66 * darcs: De-p register code. Closes: #453502
68 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
70 mr (0.17) unstable; urgency=low
72 * Even bigger hammer: Set LC_ALL. Closes: #453305
74 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
76 mr (0.16) unstable; urgency=low
78 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
79 won't override it. Closes: #453305
81 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
83 mr (0.15) unstable; urgency=low
86 * Allow -n to be passed a number to specify how deep to go into
87 subdirectories to find repositories to act on. Closes: #450621
90 * Make -j with no argument run unlimited jobs in parallel, like make -j
94 * Add a warning about runing too many jobs at a time.
96 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
98 mr (0.14) unstable; urgency=low
100 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
101 Bloom. Closes: #449592
102 * Cut number of rcs tests run in half.
104 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
106 mr (0.13) unstable; urgency=low
108 * -c was broken, fix. Closes: #449539
110 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
112 mr (0.12) unstable; urgency=low
114 * Avoid creating parent directory for a checkout that will ultimately be
116 * Don't try to test the repo type when doing a checkout, that can't work
117 since the repo isn't there yet. It was actually checking the repo type
118 of the parent directory, which caused several unexpected behaviors.
120 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
122 mr (0.11) unstable; urgency=low
124 * Avoid using commands like git-config and instead use "git config".
125 In some configurations, only the main git command is in the path.
126 * Allow option bundling, mostly so "-j2" will work.
127 * Better error message if more than one repo type test matches a single
130 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
132 mr (0.10) unstable; urgency=low
134 * Add a lib file for using unison with mr.
135 * Make registration work when no config file yet exists. Closes: #448422
137 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
139 mr (0.9) unstable; urgency=low
141 * Split up actions, so each rcs has its own set of action commands,
142 and mr tests to see what rcs is used by a repository, and dispatches
145 This will make it much easier to add new rcses, or modify just the
146 command that mr uses for one command for one rcs, without duplicating a
147 lot of code, and without needing to modify mr at all.
149 The old style unsplit actions are still supported, and are what most
150 mrconfig files will still use; this change is fully backwards compatible.
151 * Changed some things in the enviroment for the register action.
152 It's now run in the directory that the user specifies, and MR_REPO
153 is set to contain the basename of the directory that the checkout
154 command should check out. These changes should be backware compatible
155 to existing register actions.
156 * Add info and warning functions to the shell library. (madduck)
157 * Add git_bare and git_fake_bare rcs types to handle
158 bare and fake bare (non-bare with a detached worktree) git repositories.
159 (Diff and commit do not work yet to fake bare repos). (madduck)
160 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
161 * Add support for including one mrconfig file from another. Unlike chaining,
162 this doesn't change the paths, and is not tied to a particular
163 subdirectory. It's useful for loading up library mrconfig files.
164 * Split git fake-bare support out into a lib/git-fake-bare.
165 Partly because it's a good example of how to add a new revision control
166 type and use includes, and partly because it's currently too ugly to be
167 in mr itself due to bugs and limitations in git.
169 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
171 mr (0.8) unstable; urgency=low
173 * Improve "in subdir" message.
174 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
175 interactive updates. Closes: #447999
177 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
179 mr (0.7) unstable; urgency=low
181 * Fix inverted tests in tags command. (madduck)
182 * Patch from Simon McVittie, adding support for darcs repositories.
185 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
187 mr (0.6) unstable; urgency=low
189 * Add to the example mrconfig a "tags" command that lists tags.
190 (Currently only for svn and git.)
191 * hours_since was broken by design, and fixing it involved changing
192 its calling convention. If you used the old version, the new version
194 * Add ability to reorder repos, if you want mr to act on a given repo first
197 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
199 mr (0.5) unstable; urgency=low
202 * Removed special case repository deletion handling code. The same
203 thing can be accomplished in a mrconfig by skipping a repo unless
204 it exists, and printing a reminder on update. See the mrconfig file
206 * Fix output of "mr config DEFAULT lib".
207 * Change mr update to use git pull -t origin master, to make sure new tags
208 are pulled. And since those might not always be the right parameters
209 for git pull, any parameters passed to mr update will replace them.
212 * Add support for mercurial.
215 * Incorporate code based on Anthony Towns's mrs, to allow running
216 multiple jobs in parallel. The -j flag controls this.
217 This can produce enormous speedups. For me, mr update takes
218 12 minutes, while mr -j 10 update takes 1 minute!
220 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
222 mr (0.4) unstable; urgency=low
224 * Fix mr register of a subdir to also work with -c.
225 * Signal handling for commands run by mr, including handling of SIGINT
227 * Ensure parent dirs exist prior to checkout. (madduck)
228 * Output list of failed repos to stderr when -s is used.
229 * Fix a bug caused by a stupid typo.
230 * Add the -n switch, for disabling recursion.
231 * Allow for more complex deleted tests, such as marking a repo deleted on
232 some hosts, while not on others.
233 * Support registering CVS repositories. Closes: #447171
234 * MR_CONFIG now points to the config file that contains the repo mr is
236 * Make mr register smarter about what mrconfig file to write to.
237 (It probably does what you'd expect it to do now; if it doesn't, -c
240 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
242 mr (0.3) unstable; urgency=low
244 * Add a check to make sure the expected directory exists after checkout.
245 * mr register will now write to whatever config file is specified with -c
246 * Typo fixes from madduck.
248 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
250 mr (0.2) unstable; urgency=low
252 * Fix line number display for config file parse errors.
253 * Fix a bug in inheritance of default settings in chained .mrconfig files.
256 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
258 mr (0.1) unstable; urgency=low
262 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400