]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Improve unison support.
[code/myrepos.git] / debian / changelog
1 mr (0.20) unstable; urgency=low
2
3   * Add -q flag.
4   * darcs: Add -u to diff to get a more usual unified diff.
5   * Add a "record" subcommand, borrowing termonology from darcs. This does a
6     local commit, but does not push changes to remote repos.
7   * Improve unison support.
8
9  -- Joey Hess <joeyh@debian.org>  Wed, 02 Jan 2008 22:49:53 -0500
10
11 mr (0.19) unstable; urgency=low
12
13   * Support versions of man that don't use -l.
14   * Updating git repos no longer uses git-pull -t by default. Git makes it
15     to much of a PITA to do this, since -t makes git-pull require the
16     repository and refspec be specified at the command line (which is a bug in
17     git (#456035). mr used to hardcode those to "origin" and "master", but
18     that's not always the right choice. So give up on forcing git to be sane
19     about pulling down all tags. It's insane. Live with it, or configure your
20     own update command.
21
22  -- Joey Hess <joeyh@debian.org>  Wed, 12 Dec 2007 21:30:45 -0500
23
24 mr (0.18) unstable; urgency=low
25
26   * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
27   * darcs: De-p register code. Closes: #453502
28
29  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 17:48:09 -0500
30
31 mr (0.17) unstable; urgency=low
32
33   * Even bigger hammer: Set LC_ALL. Closes: #453305
34
35  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 11:18:40 -0500
36
37 mr (0.16) unstable; urgency=low
38
39   * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
40     won't override it. Closes: #453305
41
42  -- Joey Hess <joeyh@debian.org>  Wed, 28 Nov 2007 15:46:38 -0500
43
44 mr (0.15) unstable; urgency=low
45
46   [ Joey Hess ]
47   * Allow -n to be passed a number to specify how deep to go into
48     subdirectories to find repositories to act on. Closes: #450621
49
50   [ Josh Triplett ]
51   * Make -j with no argument run unlimited jobs in parallel, like make -j
52     Closes: #452467
53
54   [ Joey Hess ]
55   * Add a warning about runing too many jobs at a time.
56
57  -- Joey Hess <joeyh@debian.org>  Sun, 25 Nov 2007 13:13:47 -0500
58
59 mr (0.14) unstable; urgency=low
60
61   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
62     Bloom. Closes: #449592
63   * Cut number of rcs tests run in half.
64
65  -- Joey Hess <joeyh@debian.org>  Sun, 11 Nov 2007 01:10:18 -0500
66
67 mr (0.13) unstable; urgency=low
68
69   * -c was broken, fix. Closes: #449539
70
71  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
72
73 mr (0.12) unstable; urgency=low
74
75   * Avoid creating parent directory for a checkout that will ultimately be
76     skipped.
77   * Don't try to test the repo type when doing a checkout, that can't work
78     since the repo isn't there yet. It was actually checking the repo type
79     of the parent directory, which caused several unexpected behaviors.
80
81  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
82
83 mr (0.11) unstable; urgency=low
84
85   * Avoid using commands like git-config and instead use "git config".
86     In some configurations, only the main git command is in the path.
87   * Allow option bundling, mostly so "-j2" will work.
88   * Better error message if more than one repo type test matches a single
89     directory.
90
91  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
92
93 mr (0.10) unstable; urgency=low
94
95   * Add a lib file for using unison with mr.
96   * Make registration work when no config file yet exists. Closes: #448422
97
98  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
99
100 mr (0.9) unstable; urgency=low
101
102   * Split up actions, so each rcs has its own set of action commands,
103     and mr tests to see what rcs is used by a repository, and dispatches
104     the command.
105
106     This will make it much easier to add new rcses, or modify just the
107     command that mr uses for one command for one rcs, without duplicating a
108     lot of code, and without needing to modify mr at all.
109
110     The old style unsplit actions are still supported, and are what most
111     mrconfig files will still use; this change is fully backwards compatible.
112   * Changed some things in the enviroment for the register action.
113     It's now run in the directory that the user specifies, and MR_REPO
114     is set to contain the basename of the directory that the checkout
115     command should check out. These changes should be backware compatible
116     to existing register actions.
117   * Add info and warning functions to the shell library. (madduck)
118   * Add git_bare and git_fake_bare rcs types to handle
119     bare and fake bare (non-bare with a detached worktree) git repositories.
120     (Diff and commit do not work yet to fake bare repos). (madduck)
121   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
122   * Add support for including one mrconfig file from another. Unlike chaining,
123     this doesn't change the paths, and is not tied to a particular
124     subdirectory. It's useful for loading up library mrconfig files.
125   * Split git fake-bare support out into a lib/git-fake-bare.
126     Partly because it's a good example of how to add a new revision control
127     type and use includes, and partly because it's currently too ugly to be
128     in mr itself due to bugs and limitations in git.
129
130  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
131
132 mr (0.8) unstable; urgency=low
133
134   * Improve "in subdir" message.
135   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
136     interactive updates. Closes: #447999
137
138  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
139
140 mr (0.7) unstable; urgency=low
141
142   * Fix inverted tests in tags command. (madduck)
143   * Patch from Simon McVittie, adding support for darcs repositories.
144     Closes: #447729
145
146  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
147
148 mr (0.6) unstable; urgency=low
149
150   * Add to the example mrconfig a "tags" command that lists tags.
151     (Currently only for svn and git.)
152   * hours_since was broken by design, and fixing it involved changing
153     its calling convention. If you used the old version, the new version
154     will error out.
155   * Add ability to reorder repos, if you want mr to act on a given repo first
156     or last.
157
158  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
159
160 mr (0.5) unstable; urgency=low
161
162   [ Joey Hess ]
163   * Removed special case repository deletion handling code. The same
164     thing can be accomplished in a mrconfig by skipping a repo unless
165     it exists, and printing a reminder on update. See the mrconfig file
166     for an example.
167   * Fix output of "mr config DEFAULT lib".
168   * Change mr update to use git pull -t origin master, to make sure new tags
169     are pulled. And since those might not always be the right parameters
170     for git pull, any parameters passed to mr update will replace them.
171
172   [ Alexander Wirt ]
173   * Add support for mercurial.
174
175   [ Joey Hess ]
176   * Incorporate code based on Anthony Towns's mrs, to allow running
177     multiple jobs in parallel. The -j flag controls this.
178     This can produce enormous speedups. For me, mr update takes
179     12 minutes, while mr -j 10 update takes 1 minute!
180
181  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
182
183 mr (0.4) unstable; urgency=low
184
185   * Fix mr register of a subdir to also work with -c.
186   * Signal handling for commands run by mr, including handling of SIGINT
187     to stop mr.
188   * Ensure parent dirs exist prior to checkout. (madduck)
189   * Output list of failed repos to stderr when -s is used.
190   * Fix a bug caused by a stupid typo.
191   * Add the -n switch, for disabling recursion.
192   * Allow for more complex deleted tests, such as marking a repo deleted on
193     some hosts, while not on others.
194   * Support registering CVS repositories. Closes: #447171
195   * MR_CONFIG now points to the config file that contains the repo mr is
196     acting on.
197   * Make mr register smarter about what mrconfig file to write to.
198     (It probably does what you'd expect it to do now; if it doesn't, -c
199     can still override.)
200
201  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
202
203 mr (0.3) unstable; urgency=low
204
205   * Add a check to make sure the expected directory exists after checkout.
206   * mr register will now write to whatever config file is specified with -c
207   * Typo fixes from madduck.
208
209  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
210
211 mr (0.2) unstable; urgency=low
212
213   * Fix line number display for config file parse errors.
214   * Fix a bug in inheritance of default settings in chained .mrconfig files.
215   * Add the -s option.
216
217  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
218
219 mr (0.1) unstable; urgency=low
220
221   * First release.
222
223  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400