]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Add a warning about runing too many jobs at a time.
[code/myrepos.git] / debian / changelog
1 mr (0.15) UNRELEASED; urgency=low
2
3   [ Joey Hess ]
4   * Allow -n to be passed a number to specify how deep to go into
5     subdirectories to find repositories to act on. Closes: #450621
6
7   [ Josh Triplett ]
8   * Make -j with no argument run unlimited jobs in parallel, like make -j
9     Closes: #452467
10
11   [ Joey Hess ]
12   * Add a warning about runing too many jobs at a time.
13
14  -- Joey Hess <joeyh@debian.org>  Sun, 25 Nov 2007 12:02:40 -0500
15
16 mr (0.14) unstable; urgency=low
17
18   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
19     Bloom. Closes: #449592
20   * Cut number of rcs tests run in half.
21
22  -- Joey Hess <joeyh@debian.org>  Sun, 11 Nov 2007 01:10:18 -0500
23
24 mr (0.13) unstable; urgency=low
25
26   * -c was broken, fix. Closes: #449539
27
28  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
29
30 mr (0.12) unstable; urgency=low
31
32   * Avoid creating parent directory for a checkout that will ultimately be
33     skipped.
34   * Don't try to test the repo type when doing a checkout, that can't work
35     since the repo isn't there yet. It was actually checking the repo type
36     of the parent directory, which caused several unexpected behaviors.
37
38  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
39
40 mr (0.11) unstable; urgency=low
41
42   * Avoid using commands like git-config and instead use "git config".
43     In some configurations, only the main git command is in the path.
44   * Allow option bundling, mostly so "-j2" will work.
45   * Better error message if more than one repo type test matches a single
46     directory.
47
48  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
49
50 mr (0.10) unstable; urgency=low
51
52   * Add a lib file for using unison with mr.
53   * Make registration work when no config file yet exists. Closes: #448422
54
55  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
56
57 mr (0.9) unstable; urgency=low
58
59   * Split up actions, so each rcs has its own set of action commands,
60     and mr tests to see what rcs is used by a repository, and dispatches
61     the command.
62
63     This will make it much easier to add new rcses, or modify just the
64     command that mr uses for one command for one rcs, without duplicating a
65     lot of code, and without needing to modify mr at all.
66
67     The old style unsplit actions are still supported, and are what most
68     mrconfig files will still use; this change is fully backwards compatible.
69   * Changed some things in the enviroment for the register action.
70     It's now run in the directory that the user specifies, and MR_REPO
71     is set to contain the basename of the directory that the checkout
72     command should check out. These changes should be backware compatible
73     to existing register actions.
74   * Add info and warning functions to the shell library. (madduck)
75   * Add git_bare and git_fake_bare rcs types to handle
76     bare and fake bare (non-bare with a detached worktree) git repositories.
77     (Diff and commit do not work yet to fake bare repos). (madduck)
78   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
79   * Add support for including one mrconfig file from another. Unlike chaining,
80     this doesn't change the paths, and is not tied to a particular
81     subdirectory. It's useful for loading up library mrconfig files.
82   * Split git fake-bare support out into a lib/git-fake-bare.
83     Partly because it's a good example of how to add a new revision control
84     type and use includes, and partly because it's currently too ugly to be
85     in mr itself due to bugs and limitations in git.
86
87  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
88
89 mr (0.8) unstable; urgency=low
90
91   * Improve "in subdir" message.
92   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
93     interactive updates. Closes: #447999
94
95  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
96
97 mr (0.7) unstable; urgency=low
98
99   * Fix inverted tests in tags command. (madduck)
100   * Patch from Simon McVittie, adding support for darcs repositories.
101     Closes: #447729
102
103  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
104
105 mr (0.6) unstable; urgency=low
106
107   * Add to the example mrconfig a "tags" command that lists tags.
108     (Currently only for svn and git.)
109   * hours_since was broken by design, and fixing it involved changing
110     its calling convention. If you used the old version, the new version
111     will error out.
112   * Add ability to reorder repos, if you want mr to act on a given repo first
113     or last.
114
115  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
116
117 mr (0.5) unstable; urgency=low
118
119   [ Joey Hess ]
120   * Removed special case repository deletion handling code. The same
121     thing can be accomplished in a mrconfig by skipping a repo unless
122     it exists, and printing a reminder on update. See the mrconfig file
123     for an example.
124   * Fix output of "mr config DEFAULT lib".
125   * Change mr update to use git pull -t origin master, to make sure new tags
126     are pulled. And since those might not always be the right parameters
127     for git pull, any parameters passed to mr update will replace them.
128
129   [ Alexander Wirt ]
130   * Add support for mercurial.
131
132   [ Joey Hess ]
133   * Incorporate code based on Anthony Towns's mrs, to allow running
134     multiple jobs in parallel. The -j flag controls this.
135     This can produce enormous speedups. For me, mr update takes
136     12 minutes, while mr -j 10 update takes 1 minute!
137
138  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
139
140 mr (0.4) unstable; urgency=low
141
142   * Fix mr register of a subdir to also work with -c.
143   * Signal handling for commands run by mr, including handling of SIGINT
144     to stop mr.
145   * Ensure parent dirs exist prior to checkout. (madduck)
146   * Output list of failed repos to stderr when -s is used.
147   * Fix a bug caused by a stupid typo.
148   * Add the -n switch, for disabling recursion.
149   * Allow for more complex deleted tests, such as marking a repo deleted on
150     some hosts, while not on others.
151   * Support registering CVS repositories. Closes: #447171
152   * MR_CONFIG now points to the config file that contains the repo mr is
153     acting on.
154   * Make mr register smarter about what mrconfig file to write to.
155     (It probably does what you'd expect it to do now; if it doesn't, -c
156     can still override.)
157
158  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
159
160 mr (0.3) unstable; urgency=low
161
162   * Add a check to make sure the expected directory exists after checkout.
163   * mr register will now write to whatever config file is specified with -c
164   * Typo fixes from madduck.
165
166  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
167
168 mr (0.2) unstable; urgency=low
169
170   * Fix line number display for config file parse errors.
171   * Fix a bug in inheritance of default settings in chained .mrconfig files.
172   * Add the -s option.
173
174  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
175
176 mr (0.1) unstable; urgency=low
177
178   * First release.
179
180  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400