]> git.madduck.net Git - code/myrepos.git/blob - debian/rules

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

rename INSTALL
[code/myrepos.git] / debian / rules
1 #!/usr/bin/make -f
2
3 build:
4         ./mr help > mr.1
5
6 clean:
7         dh_testdir
8         dh_testroot
9         dh_clean mr.1
10
11 binary-arch: build
12
13 binary-indep: build
14         dh_testdir
15         dh_testroot
16         dh_clean -k
17         dh_install mr usr/bin
18         dh_installdocs README
19         dh_installexamples mrconfig
20         dh_installman *.1
21         dh_installchangelogs
22         dh_compress
23         dh_fixperms
24         dh_perl
25         dh_installdeb
26         dh_gencontrol
27         dh_md5sums
28         dh_builddeb
29
30 binary: binary-indep binary-arch
31 .PHONY: build clean binary-indep binary-arch binary