]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

Remove dir_test hack and add a way for vcs tests to run perl code, using this for...
[code/myrepos.git] / debian / changelog
1 mr (1.09) unstable; urgency=low
2
3   * Remove dir_test hack and add a way for vcs tests to run perl code,
4     using this for the same optimisation. Fixes support for git-svn
5     etc. Closes: #652317
6
7  -- Joey Hess <joeyh@debian.org>  Fri, 16 Dec 2011 13:29:40 -0400
8
9 mr (1.08) unstable; urgency=low
10
11   * Fix vcs test code. Closes: #651976
12
13  -- Joey Hess <joeyh@debian.org>  Tue, 13 Dec 2011 16:21:19 -0400
14
15 mr (1.07) unstable; urgency=low
16
17   * Added support for vcsh, enable with: include = cat /usr/share/mr/vcsh
18     Thanks, Richard Hartmann 
19   * Block tty control codes in untrusted mr config files.
20   * Correct printing of line numbers when includes are used. Closes: #650952
21   * The previous fix for chaining to absolute paths broke chaining to relative
22     paths with more than one path segment. Thanks, Adam Spiers
23   * Support _append to add on to the existing value of a parameter.
24     Thanks, Adam Spiers
25   * Optimizations. Commands like "mr list" run up to 5 times faster.
26   * Fix shell escaping of parameters passed to mr commands. Closes: #644672
27   * Added --force option that disables repository skipping.
28   * Repositories using skip = lazy will not be checked out by "mr update"
29     or "mr checkout" unless --force is used.
30
31  -- Joey Hess <joeyh@debian.org>  Mon, 12 Dec 2011 15:52:16 -0400
32
33 mr (1.06) unstable; urgency=low
34
35   * Fix propigation of failure from pre and post hooks and from fixups.
36   * Support chaining to absolute paths.
37   * Add support for skip = lazy, a mode where mr only operates on repositories
38     that are checked out.
39
40  -- Joey Hess <joeyh@debian.org>  Fri, 04 Nov 2011 17:03:17 -0400
41
42 mr (1.05) unstable; urgency=low
43
44   * README now gives a quick into to using mr.
45   * Brought back the "deleted" parameter, which provides an easy way to
46     mark repositories that should be removed.
47   * Allow untrusted mrconfig files to set parameters to true/false.
48     So skip=true or deleted=true can be used in an untrusted mrconfig file.
49   * Also allow order=N in an untrusted mrconfig file.
50   * Support bzr checkouts, which are updated with "bzr update",
51     and to which bzr automatically pushes commits. Closes: #643589
52   * Use bzr branch, not deprecated bzr clone when registering bzr
53     repositories. Closes: #643591
54   * Allow bzr branch|clone|get|checkout in untrusted mrconfig files.
55   * Avoid using sed -r in git-fake-bare, for OSX portability.
56   * git-fake-bare: handle fake bare repositories with core.bare not set
57     (Thanks, Julien Rebetez)
58
59  -- Joey Hess <joeyh@debian.org>  Tue, 27 Sep 2011 17:28:35 -0400
60
61 mr (1.04) unstable; urgency=low
62
63   * Improve trust errors displayed while bootstrapping. Closes: #628234
64   * Allow mr register to be used with mrconfig file that does not yet
65     exist. Closes: #629217
66
67  -- Joey Hess <joeyh@debian.org>  Sun, 19 Jun 2011 15:52:42 -0400
68
69 mr (1.03) unstable; urgency=low
70
71   * Added git-subtree library. Thanks, Svend Sorensen
72   * Now --quiet supresses all output from commands run, as well
73     as from mr, unless a command fails. Closes: #529296
74
75  -- Joey Hess <joeyh@debian.org>  Sun, 01 May 2011 19:09:35 -0400
76
77 mr (1.02) unstable; urgency=low
78
79   * Fix bug in escaping.
80
81  -- Joey Hess <joeyh@debian.org>  Sat, 22 Jan 2011 01:18:23 -0400
82
83 mr (1.01) unstable; urgency=low
84
85   * Add "mr run", which can run an arbitrary command in each repository.
86
87  -- Joey Hess <joeyh@debian.org>  Thu, 20 Jan 2011 16:50:49 -0400
88
89 mr (1.00) unstable; urgency=low
90
91   * Trust flag day. All mrconfig files except the main ~/.mrconfig are
92     now untrusted by default, until listed in ~/.mrtrust.
93   * The -p flag is now enabled by default. mr first reads ~/.mrconfig,
94     and then looks for an additional .mrconfig file in the current
95     directory or one of its parent directories. Closes: #557963
96
97  -- Joey Hess <joeyh@debian.org>  Wed, 19 Jan 2011 14:28:38 -0400
98
99 mr (0.51) unstable; urgency=low
100
101   * Fix display when absolute directories are configured in mrconfig.
102   * Add push to manpage synopsis. Closes: #603029
103   * Do not return a nonzero exit status when all repositories were skipped.
104     Closes: #607287
105
106  -- Joey Hess <joeyh@debian.org>  Thu, 16 Dec 2010 12:53:32 -0400
107
108 mr (0.50) unstable; urgency=low
109
110   * Now supports the Fossil VCS. (Thanks, Jimmy Tang)
111   * Added fixups hook, which can be used to run a command after
112     a repository is checked out or updated. Closes: #590868
113   * Added support for arbitrary pre and post hooks for all defined mr
114     commands. For example, pre_commit is run before all commits; post_update
115     is run after all updates. Closes: #481341
116
117  -- Joey Hess <joeyh@debian.org>  Sun, 29 Aug 2010 15:00:01 -0400
118
119 mr (0.49) unstable; urgency=low
120
121   * Update suggests for git-core to git transition.
122   * Use short mode status output for git and bzr.
123   * Typo. Closes: #586233, #588913
124
125  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jul 2010 23:08:06 -0400
126
127 mr (0.48) unstable; urgency=low
128
129   * Fix the hours_since function built into mr's shell library to
130     not exit, but return a true/false exit status. This allows it to be
131     used outside of skip tests.
132
133  -- Joey Hess <joeyh@debian.org>  Fri, 05 Feb 2010 17:12:01 -0500
134
135 mr (0.47) unstable; urgency=low
136
137   * Pass -L to curl to allow it to follow redirects when bootstrapping.
138     (Pavel Avgustinov)
139   * Allow empty sections to be used in mrconfig files.
140
141  -- Joey Hess <joeyh@debian.org>  Fri, 05 Feb 2010 16:40:29 -0500
142
143 mr (0.46) unstable; urgency=low
144
145   * Avoid using abs_path to determine canonical repo path, as that fails
146     when the repo has not yet been checked out.
147
148  -- Joey Hess <joeyh@debian.org>  Thu, 10 Dec 2009 17:28:26 -0500
149
150 mr (0.45) unstable; urgency=low
151
152   * Fix pod error. Closes: #558012
153   * bootstrap: Improve stats display.
154   * Add --insecure option that can be used to ignore SSL cert errors
155     when bootstrapping. (Pavel Avgustinov)
156   * Fix handling of a repository in "."
157
158  -- Joey Hess <joeyh@debian.org>  Tue, 08 Dec 2009 14:58:21 -0500
159
160 mr (0.44) unstable; urgency=low
161
162   * Make mr -i pass -i to the shell, to ensure it knows it should be an
163     interactive shell.
164   * mr help: Support man on SunOS and OS X. (Geoff Davis)
165   * mr bootstrap: Fix cross-device rename failure. Closes: #557962
166
167  -- Joey Hess <joeyh@debian.org>  Wed, 25 Nov 2009 12:39:08 -0500
168
169 mr (0.43) unstable; urgency=low
170
171   * Set User-Agent to "mr" when downloading the mrconfig file
172     with mr bootstrap. Closes: #541778
173   * Man page typo. Closes: #545412
174   * mr bootstrap: Allow a directory to checkout into to be specified,
175     and create it if necessary.
176   * mr bootstrap: If the mrconfig file contains a repository named ".",
177     check it out into the top level of the directory bootstrapped.
178
179  -- Joey Hess <joeyh@debian.org>  Tue, 08 Sep 2009 20:22:32 -0400
180
181 mr (0.42) unstable; urgency=low
182
183   * Add support for ~/.mrtrust, which can be used to list trusted mrconfig
184     files. If you create this file, all files not listed in it will be treated
185     as untrusted, and carefully limited in what they can do. This improves
186     security when using mrconfig files provided by others.
187
188  -- Joey Hess <joeyh@debian.org>  Fri, 07 Aug 2009 16:38:31 -0400
189
190 mr (0.41) unstable; urgency=low
191
192   * Add -p switch, that makes mr search the current directory and its
193     parents for a .mrconfig file to use.
194   * Add `mr bootstrap`, which downloads an url to a .mrconfig file
195     in the current directory and then checks out all repositories configured
196     in it. This is intended for projects that want to publish a mrconfig file
197     to automate use of their several repositories.
198
199  -- Joey Hess <joeyh@debian.org>  Thu, 06 Aug 2009 22:38:58 -0400
200
201 mr (0.40) unstable; urgency=low
202
203   * Pass --pull to bzr merge to avoid needing to commit
204     merged changes. Closes: #524352
205
206  -- Joey Hess <joeyh@debian.org>  Fri, 31 Jul 2009 13:47:22 -0400
207
208 mr (0.39) unstable; urgency=low
209
210   * Determine current branch for fake-bare update (martin f. krafft)
211
212  -- Joey Hess <joeyh@debian.org>  Mon, 09 Mar 2009 22:50:54 -0400
213
214 mr (0.38) unstable; urgency=low
215
216   * Remove gitless lib. It turned out to be better to simply
217     use git clone --shared when checking out. Sorry for the churn..
218
219  -- Joey Hess <joeyh@debian.org>  Thu, 22 Jan 2009 15:39:33 -0500
220
221 mr (0.37) unstable; urgency=low
222
223   * Add "gitless" file to lib. 
224     This adds a special type of git repository, where the .git directory
225     is stored on a file server, to avoid wasting space with it on the client.
226   * Revert buggy change to directory printing code.
227
228  -- Joey Hess <joeyh@debian.org>  Wed, 21 Jan 2009 01:40:59 -0500
229
230 mr (0.36) unstable; urgency=low
231
232   * Add webcheckout command. See <http://kitenet.net/~joey/rfc/rel-vcs/>
233   * Fix display of repos configured at absolute path locations.
234
235  -- Joey Hess <joeyh@debian.org>  Sat, 10 Jan 2009 16:42:07 -0500
236
237 mr (0.35) unstable; urgency=low
238
239   * Warn if an include command fails nonzero. Closes: #495306
240   * Remove stray character in pod that uglified man page. Closes: #495731
241   * Create ~/.mrlog not world readable.
242   * Pass additional options to darcs push when pushing. Closes: #495734
243
244  -- Joey Hess <joeyh@debian.org>  Thu, 16 Oct 2008 14:51:00 -0400
245
246 mr (0.34) unstable; urgency=low
247
248   * Fix bug when remembering failed commands in offline mode.
249
250  -- Joey Hess <joeyh@debian.org>  Sat, 02 Aug 2008 12:27:21 -0400
251
252 mr (0.33) unstable; urgency=low
253
254   * Add a push subcommand, which pushes committed changes for DCVS, and 
255     does nothing for svn/cvs. Closes: #491865
256
257  -- Joey Hess <joeyh@debian.org>  Tue, 22 Jul 2008 15:22:01 -0400
258
259 mr (0.32) unstable; urgency=low
260
261   * Include the right (v2) version of GPL in the source.
262
263  -- Joey Hess <joeyh@debian.org>  Tue, 22 Jul 2008 00:28:55 -0400
264
265 mr (0.31) unstable; urgency=low
266
267   * Add an offline mode. When in offline mode, mr will remember commands
268     that failed (presumably due to lack of network access), and will run
269     them again once back online. (This is for all the laptop users
270     like me who don't want to have to remember which git repos to mr push
271     when they come back from a nice long hack in the woods. :-)
272
273  -- Joey Hess <joeyh@debian.org>  Fri, 27 Jun 2008 23:19:23 -0400
274
275 mr (0.30) unstable; urgency=low
276
277   [ martin f. krafft ]
278   * Several git-fake-bare improvements.
279
280   [ Joey Hess ]
281   * Fix mr -c <config> register. (Thanks, Daniel Bungert)
282
283  -- Joey Hess <joeyh@debian.org>  Wed, 25 Jun 2008 13:38:31 -0400
284
285 mr (0.29) unstable; urgency=low
286
287   * Allow environment variables in section headers. Pass such headers
288     through the shell to expand them. Closes: #480421
289   * For the checkout command, MR_REPO was set to the name of the parent
290     directory of the directory to checkout. It is supposed to be the
291     path to the directory itself though; fixed this. Closes: #480424
292
293  -- Joey Hess <joeyh@debian.org>  Wed, 14 May 2008 19:38:18 -0400
294
295 mr (0.28) unstable; urgency=low
296
297   * Use debhelper v7, rules file minimisation.
298   * Add a Makefile.
299
300  -- Joey Hess <joeyh@debian.org>  Wed, 23 Apr 2008 21:56:06 -0400
301
302 mr (0.27) unstable; urgency=low
303
304   * Ignore exit code from darcs whatsnew, which can be nonzero if there
305     are no changes. Closes: #476650
306
307  -- Joey Hess <joeyh@debian.org>  Sat, 19 Apr 2008 16:47:04 -0400
308
309 mr (0.26) unstable; urgency=low
310
311   * Add -i option to start a shell if an operation fails. Closes: #474962
312
313  -- Joey Hess <joeyh@debian.org>  Tue, 08 Apr 2008 20:58:44 -0400
314
315 mr (0.25) unstable; urgency=low
316
317   * git-fake-bare: Add support for diff, commit, and record. (madduck)
318
319  -- Joey Hess <joeyh@debian.org>  Mon, 10 Mar 2008 15:56:17 -0400
320
321 mr (0.24) unstable; urgency=low
322
323   * Correct GIT_CONFIG settings in git-svn. Closes: #463941
324
325  -- Joey Hess <joeyh@debian.org>  Wed, 06 Feb 2008 13:04:30 -0500
326
327 mr (0.23) unstable; urgency=low
328
329   * Fix tests in git-svn include file to use MR_REPO. Closes: #463941
330
331  -- Joey Hess <joeyh@debian.org>  Tue, 05 Feb 2008 13:26:05 -0500
332
333 mr (0.22) unstable; urgency=low
334
335   * Update bzr registration code to work with current version of bzr,
336     using bzr info to get the url. Closes: #463867
337
338  -- Joey Hess <joeyh@debian.org>  Sun, 03 Feb 2008 17:04:59 -0500
339
340 mr (0.21) unstable; urgency=low
341
342   * Add a git-svn file, which can be included to add support for git-svn
343     repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
344     for implementations. Closes: #462408
345
346  -- Joey Hess <joeyh@debian.org>  Thu, 24 Jan 2008 13:45:05 -0500
347
348 mr (0.20) unstable; urgency=low
349
350   * Add -q flag.
351   * darcs: Add -u to diff to get a more usual unified diff.
352   * Add a "record" subcommand, borrowing termonology from darcs. This does a
353     local commit, but does not push changes to remote repos.
354   * Improve unison support.
355
356  -- Joey Hess <joeyh@debian.org>  Wed, 02 Jan 2008 22:49:53 -0500
357
358 mr (0.19) unstable; urgency=low
359
360   * Support versions of man that don't use -l.
361   * Updating git repos no longer uses git-pull -t by default. Git makes it
362     to much of a PITA to do this, since -t makes git-pull require the
363     repository and refspec be specified at the command line (which is a bug in
364     git (#456035). mr used to hardcode those to "origin" and "master", but
365     that's not always the right choice. So give up on forcing git to be sane
366     about pulling down all tags. It's insane. Live with it, or configure your
367     own update command.
368
369  -- Joey Hess <joeyh@debian.org>  Wed, 12 Dec 2007 21:30:45 -0500
370
371 mr (0.18) unstable; urgency=low
372
373   * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
374   * darcs: De-p register code. Closes: #453502
375
376  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 17:48:09 -0500
377
378 mr (0.17) unstable; urgency=low
379
380   * Even bigger hammer: Set LC_ALL. Closes: #453305
381
382  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 11:18:40 -0500
383
384 mr (0.16) unstable; urgency=low
385
386   * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
387     won't override it. Closes: #453305
388
389  -- Joey Hess <joeyh@debian.org>  Wed, 28 Nov 2007 15:46:38 -0500
390
391 mr (0.15) unstable; urgency=low
392
393   [ Joey Hess ]
394   * Allow -n to be passed a number to specify how deep to go into
395     subdirectories to find repositories to act on. Closes: #450621
396
397   [ Josh Triplett ]
398   * Make -j with no argument run unlimited jobs in parallel, like make -j
399     Closes: #452467
400
401   [ Joey Hess ]
402   * Add a warning about runing too many jobs at a time.
403
404  -- Joey Hess <joeyh@debian.org>  Sun, 25 Nov 2007 13:13:47 -0500
405
406 mr (0.14) unstable; urgency=low
407
408   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
409     Bloom. Closes: #449592
410   * Cut number of rcs tests run in half.
411
412  -- Joey Hess <joeyh@debian.org>  Sun, 11 Nov 2007 01:10:18 -0500
413
414 mr (0.13) unstable; urgency=low
415
416   * -c was broken, fix. Closes: #449539
417
418  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
419
420 mr (0.12) unstable; urgency=low
421
422   * Avoid creating parent directory for a checkout that will ultimately be
423     skipped.
424   * Don't try to test the repo type when doing a checkout, that can't work
425     since the repo isn't there yet. It was actually checking the repo type
426     of the parent directory, which caused several unexpected behaviors.
427
428  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
429
430 mr (0.11) unstable; urgency=low
431
432   * Avoid using commands like git-config and instead use "git config".
433     In some configurations, only the main git command is in the path.
434   * Allow option bundling, mostly so "-j2" will work.
435   * Better error message if more than one repo type test matches a single
436     directory.
437
438  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
439
440 mr (0.10) unstable; urgency=low
441
442   * Add a lib file for using unison with mr.
443   * Make registration work when no config file yet exists. Closes: #448422
444
445  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
446
447 mr (0.9) unstable; urgency=low
448
449   * Split up actions, so each rcs has its own set of action commands,
450     and mr tests to see what rcs is used by a repository, and dispatches
451     the command.
452
453     This will make it much easier to add new rcses, or modify just the
454     command that mr uses for one command for one rcs, without duplicating a
455     lot of code, and without needing to modify mr at all.
456
457     The old style unsplit actions are still supported, and are what most
458     mrconfig files will still use; this change is fully backwards compatible.
459   * Changed some things in the enviroment for the register action.
460     It's now run in the directory that the user specifies, and MR_REPO
461     is set to contain the basename of the directory that the checkout
462     command should check out. These changes should be backware compatible
463     to existing register actions.
464   * Add info and warning functions to the shell library. (madduck)
465   * Add git_bare and git_fake_bare rcs types to handle
466     bare and fake bare (non-bare with a detached worktree) git repositories.
467     (Diff and commit do not work yet to fake bare repos). (madduck)
468   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
469   * Add support for including one mrconfig file from another. Unlike chaining,
470     this doesn't change the paths, and is not tied to a particular
471     subdirectory. It's useful for loading up library mrconfig files.
472   * Split git fake-bare support out into a lib/git-fake-bare.
473     Partly because it's a good example of how to add a new revision control
474     type and use includes, and partly because it's currently too ugly to be
475     in mr itself due to bugs and limitations in git.
476
477  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
478
479 mr (0.8) unstable; urgency=low
480
481   * Improve "in subdir" message.
482   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
483     interactive updates. Closes: #447999
484
485  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
486
487 mr (0.7) unstable; urgency=low
488
489   * Fix inverted tests in tags command. (madduck)
490   * Patch from Simon McVittie, adding support for darcs repositories.
491     Closes: #447729
492
493  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
494
495 mr (0.6) unstable; urgency=low
496
497   * Add to the example mrconfig a "tags" command that lists tags.
498     (Currently only for svn and git.)
499   * hours_since was broken by design, and fixing it involved changing
500     its calling convention. If you used the old version, the new version
501     will error out.
502   * Add ability to reorder repos, if you want mr to act on a given repo first
503     or last.
504
505  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
506
507 mr (0.5) unstable; urgency=low
508
509   [ Joey Hess ]
510   * Removed special case repository deletion handling code. The same
511     thing can be accomplished in a mrconfig by skipping a repo unless
512     it exists, and printing a reminder on update. See the mrconfig file
513     for an example.
514   * Fix output of "mr config DEFAULT lib".
515   * Change mr update to use git pull -t origin master, to make sure new tags
516     are pulled. And since those might not always be the right parameters
517     for git pull, any parameters passed to mr update will replace them.
518
519   [ Alexander Wirt ]
520   * Add support for mercurial.
521
522   [ Joey Hess ]
523   * Incorporate code based on Anthony Towns's mrs, to allow running
524     multiple jobs in parallel. The -j flag controls this.
525     This can produce enormous speedups. For me, mr update takes
526     12 minutes, while mr -j 10 update takes 1 minute!
527
528  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
529
530 mr (0.4) unstable; urgency=low
531
532   * Fix mr register of a subdir to also work with -c.
533   * Signal handling for commands run by mr, including handling of SIGINT
534     to stop mr.
535   * Ensure parent dirs exist prior to checkout. (madduck)
536   * Output list of failed repos to stderr when -s is used.
537   * Fix a bug caused by a stupid typo.
538   * Add the -n switch, for disabling recursion.
539   * Allow for more complex deleted tests, such as marking a repo deleted on
540     some hosts, while not on others.
541   * Support registering CVS repositories. Closes: #447171
542   * MR_CONFIG now points to the config file that contains the repo mr is
543     acting on.
544   * Make mr register smarter about what mrconfig file to write to.
545     (It probably does what you'd expect it to do now; if it doesn't, -c
546     can still override.)
547
548  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
549
550 mr (0.3) unstable; urgency=low
551
552   * Add a check to make sure the expected directory exists after checkout.
553   * mr register will now write to whatever config file is specified with -c
554   * Typo fixes from madduck.
555
556  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
557
558 mr (0.2) unstable; urgency=low
559
560   * Fix line number display for config file parse errors.
561   * Fix a bug in inheritance of default settings in chained .mrconfig files.
562   * Add the -s option.
563
564  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
565
566 mr (0.1) unstable; urgency=low
567
568   * First release.
569
570  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400