All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.19) UNRELEASED; urgency=low
3 * Support versions of man that don't use -l.
5 -- Joey Hess <joeyh@debian.org> Tue, 04 Dec 2007 15:13:26 -0500
7 mr (0.18) unstable; urgency=low
9 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
10 * darcs: De-p register code. Closes: #453502
12 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
14 mr (0.17) unstable; urgency=low
16 * Even bigger hammer: Set LC_ALL. Closes: #453305
18 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
20 mr (0.16) unstable; urgency=low
22 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
23 won't override it. Closes: #453305
25 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
27 mr (0.15) unstable; urgency=low
30 * Allow -n to be passed a number to specify how deep to go into
31 subdirectories to find repositories to act on. Closes: #450621
34 * Make -j with no argument run unlimited jobs in parallel, like make -j
38 * Add a warning about runing too many jobs at a time.
40 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
42 mr (0.14) unstable; urgency=low
44 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
45 Bloom. Closes: #449592
46 * Cut number of rcs tests run in half.
48 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
50 mr (0.13) unstable; urgency=low
52 * -c was broken, fix. Closes: #449539
54 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
56 mr (0.12) unstable; urgency=low
58 * Avoid creating parent directory for a checkout that will ultimately be
60 * Don't try to test the repo type when doing a checkout, that can't work
61 since the repo isn't there yet. It was actually checking the repo type
62 of the parent directory, which caused several unexpected behaviors.
64 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
66 mr (0.11) unstable; urgency=low
68 * Avoid using commands like git-config and instead use "git config".
69 In some configurations, only the main git command is in the path.
70 * Allow option bundling, mostly so "-j2" will work.
71 * Better error message if more than one repo type test matches a single
74 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
76 mr (0.10) unstable; urgency=low
78 * Add a lib file for using unison with mr.
79 * Make registration work when no config file yet exists. Closes: #448422
81 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
83 mr (0.9) unstable; urgency=low
85 * Split up actions, so each rcs has its own set of action commands,
86 and mr tests to see what rcs is used by a repository, and dispatches
89 This will make it much easier to add new rcses, or modify just the
90 command that mr uses for one command for one rcs, without duplicating a
91 lot of code, and without needing to modify mr at all.
93 The old style unsplit actions are still supported, and are what most
94 mrconfig files will still use; this change is fully backwards compatible.
95 * Changed some things in the enviroment for the register action.
96 It's now run in the directory that the user specifies, and MR_REPO
97 is set to contain the basename of the directory that the checkout
98 command should check out. These changes should be backware compatible
99 to existing register actions.
100 * Add info and warning functions to the shell library. (madduck)
101 * Add git_bare and git_fake_bare rcs types to handle
102 bare and fake bare (non-bare with a detached worktree) git repositories.
103 (Diff and commit do not work yet to fake bare repos). (madduck)
104 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
105 * Add support for including one mrconfig file from another. Unlike chaining,
106 this doesn't change the paths, and is not tied to a particular
107 subdirectory. It's useful for loading up library mrconfig files.
108 * Split git fake-bare support out into a lib/git-fake-bare.
109 Partly because it's a good example of how to add a new revision control
110 type and use includes, and partly because it's currently too ugly to be
111 in mr itself due to bugs and limitations in git.
113 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
115 mr (0.8) unstable; urgency=low
117 * Improve "in subdir" message.
118 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
119 interactive updates. Closes: #447999
121 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
123 mr (0.7) unstable; urgency=low
125 * Fix inverted tests in tags command. (madduck)
126 * Patch from Simon McVittie, adding support for darcs repositories.
129 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
131 mr (0.6) unstable; urgency=low
133 * Add to the example mrconfig a "tags" command that lists tags.
134 (Currently only for svn and git.)
135 * hours_since was broken by design, and fixing it involved changing
136 its calling convention. If you used the old version, the new version
138 * Add ability to reorder repos, if you want mr to act on a given repo first
141 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
143 mr (0.5) unstable; urgency=low
146 * Removed special case repository deletion handling code. The same
147 thing can be accomplished in a mrconfig by skipping a repo unless
148 it exists, and printing a reminder on update. See the mrconfig file
150 * Fix output of "mr config DEFAULT lib".
151 * Change mr update to use git pull -t origin master, to make sure new tags
152 are pulled. And since those might not always be the right parameters
153 for git pull, any parameters passed to mr update will replace them.
156 * Add support for mercurial.
159 * Incorporate code based on Anthony Towns's mrs, to allow running
160 multiple jobs in parallel. The -j flag controls this.
161 This can produce enormous speedups. For me, mr update takes
162 12 minutes, while mr -j 10 update takes 1 minute!
164 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
166 mr (0.4) unstable; urgency=low
168 * Fix mr register of a subdir to also work with -c.
169 * Signal handling for commands run by mr, including handling of SIGINT
171 * Ensure parent dirs exist prior to checkout. (madduck)
172 * Output list of failed repos to stderr when -s is used.
173 * Fix a bug caused by a stupid typo.
174 * Add the -n switch, for disabling recursion.
175 * Allow for more complex deleted tests, such as marking a repo deleted on
176 some hosts, while not on others.
177 * Support registering CVS repositories. Closes: #447171
178 * MR_CONFIG now points to the config file that contains the repo mr is
180 * Make mr register smarter about what mrconfig file to write to.
181 (It probably does what you'd expect it to do now; if it doesn't, -c
184 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
186 mr (0.3) unstable; urgency=low
188 * Add a check to make sure the expected directory exists after checkout.
189 * mr register will now write to whatever config file is specified with -c
190 * Typo fixes from madduck.
192 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
194 mr (0.2) unstable; urgency=low
196 * Fix line number display for config file parse errors.
197 * Fix a bug in inheritance of default settings in chained .mrconfig files.
200 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
202 mr (0.1) unstable; urgency=low
206 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400