]> git.madduck.net Git - code/myrepos.git/blob - debian/rules

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Support versions of man that don't use -l.
[code/myrepos.git] / debian / rules
1 #!/usr/bin/make -f
2
3 build:
4         pod2man -c mr mr > mr.1
5         (echo "[]"; echo "checkout=") > mrconfig.tmp
6         ./mr -c mrconfig.tmp ed | grep -q "horse"
7         rm -f mrconfig.tmp
8
9 clean:
10         dh_testdir
11         dh_testroot
12         dh_clean mr.1
13
14 binary-arch: build
15
16 binary-indep: build
17         dh_testdir
18         dh_testroot
19         dh_clean -k
20         dh_install mr usr/bin
21         dh_installdocs README TODO
22         dh_installexamples mrconfig mrconfig.complex
23         dh_install lib/* usr/share/mr
24         dh_installman *.1
25         dh_installchangelogs
26         dh_compress
27         dh_fixperms
28         dh_perl
29         dh_installdeb
30         dh_gencontrol
31         dh_md5sums
32         dh_builddeb
33
34 # Not intended for use by anyone except the author.
35 announcedir:
36         @echo ${HOME}/src/joeywiki/code/mr/news
37
38 binary: binary-indep binary-arch
39 .PHONY: build clean binary-indep binary-arch binary