All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.38) unstable; urgency=low
3 * Remove gitless lib. It turned out to be better to simply
4 use git clone --shared when checking out. Sorry for the churn..
6 -- Joey Hess <joeyh@debian.org> Thu, 22 Jan 2009 15:39:33 -0500
8 mr (0.37) unstable; urgency=low
10 * Add "gitless" file to lib.
11 This adds a special type of git repository, where the .git directory
12 is stored on a file server, to avoid wasting space with it on the client.
13 * Revert buggy change to directory printing code.
15 -- Joey Hess <joeyh@debian.org> Wed, 21 Jan 2009 01:40:59 -0500
17 mr (0.36) unstable; urgency=low
19 * Add webcheckout command. See <http://kitenet.net/~joey/rfc/rel-vcs/>
20 * Fix display of repos configured at absolute path locations.
22 -- Joey Hess <joeyh@debian.org> Sat, 10 Jan 2009 16:42:07 -0500
24 mr (0.35) unstable; urgency=low
26 * Warn if an include command fails nonzero. Closes: #495306
27 * Remove stray character in pod that uglified man page. Closes: #495731
28 * Create ~/.mrlog not world readable.
29 * Pass additional options to darcs push when pushing. Closes: #495734
31 -- Joey Hess <joeyh@debian.org> Thu, 16 Oct 2008 14:51:00 -0400
33 mr (0.34) unstable; urgency=low
35 * Fix bug when remembering failed commands in offline mode.
37 -- Joey Hess <joeyh@debian.org> Sat, 02 Aug 2008 12:27:21 -0400
39 mr (0.33) unstable; urgency=low
41 * Add a push subcommand, which pushes committed changes for DCVS, and
42 does nothing for svn/cvs. Closes: #491865
44 -- Joey Hess <joeyh@debian.org> Tue, 22 Jul 2008 15:22:01 -0400
46 mr (0.32) unstable; urgency=low
48 * Include the right (v2) version of GPL in the source.
50 -- Joey Hess <joeyh@debian.org> Tue, 22 Jul 2008 00:28:55 -0400
52 mr (0.31) unstable; urgency=low
54 * Add an offline mode. When in offline mode, mr will remember commands
55 that failed (presumably due to lack of network access), and will run
56 them again once back online. (This is for all the laptop users
57 like me who don't want to have to remember which git repos to mr push
58 when they come back from a nice long hack in the woods. :-)
60 -- Joey Hess <joeyh@debian.org> Fri, 27 Jun 2008 23:19:23 -0400
62 mr (0.30) unstable; urgency=low
65 * Several git-fake-bare improvements.
68 * Fix mr -c <config> register. (Thanks, Daniel Bungert)
70 -- Joey Hess <joeyh@debian.org> Wed, 25 Jun 2008 13:38:31 -0400
72 mr (0.29) unstable; urgency=low
74 * Allow environment variables in section headers. Pass such headers
75 through the shell to expand them. Closes: #480421
76 * For the checkout command, MR_REPO was set to the name of the parent
77 directory of the directory to checkout. It is supposed to be the
78 path to the directory itself though; fixed this. Closes: #480424
80 -- Joey Hess <joeyh@debian.org> Wed, 14 May 2008 19:38:18 -0400
82 mr (0.28) unstable; urgency=low
84 * Use debhelper v7, rules file minimisation.
87 -- Joey Hess <joeyh@debian.org> Wed, 23 Apr 2008 21:56:06 -0400
89 mr (0.27) unstable; urgency=low
91 * Ignore exit code from darcs whatsnew, which can be nonzero if there
92 are no changes. Closes: #476650
94 -- Joey Hess <joeyh@debian.org> Sat, 19 Apr 2008 16:47:04 -0400
96 mr (0.26) unstable; urgency=low
98 * Add -i option to start a shell if an operation fails. Closes: #474962
100 -- Joey Hess <joeyh@debian.org> Tue, 08 Apr 2008 20:58:44 -0400
102 mr (0.25) unstable; urgency=low
104 * git-fake-bare: Add support for diff, commit, and record. (madduck)
106 -- Joey Hess <joeyh@debian.org> Mon, 10 Mar 2008 15:56:17 -0400
108 mr (0.24) unstable; urgency=low
110 * Correct GIT_CONFIG settings in git-svn. Closes: #463941
112 -- Joey Hess <joeyh@debian.org> Wed, 06 Feb 2008 13:04:30 -0500
114 mr (0.23) unstable; urgency=low
116 * Fix tests in git-svn include file to use MR_REPO. Closes: #463941
118 -- Joey Hess <joeyh@debian.org> Tue, 05 Feb 2008 13:26:05 -0500
120 mr (0.22) unstable; urgency=low
122 * Update bzr registration code to work with current version of bzr,
123 using bzr info to get the url. Closes: #463867
125 -- Joey Hess <joeyh@debian.org> Sun, 03 Feb 2008 17:04:59 -0500
127 mr (0.21) unstable; urgency=low
129 * Add a git-svn file, which can be included to add support for git-svn
130 repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
131 for implementations. Closes: #462408
133 -- Joey Hess <joeyh@debian.org> Thu, 24 Jan 2008 13:45:05 -0500
135 mr (0.20) unstable; urgency=low
138 * darcs: Add -u to diff to get a more usual unified diff.
139 * Add a "record" subcommand, borrowing termonology from darcs. This does a
140 local commit, but does not push changes to remote repos.
141 * Improve unison support.
143 -- Joey Hess <joeyh@debian.org> Wed, 02 Jan 2008 22:49:53 -0500
145 mr (0.19) unstable; urgency=low
147 * Support versions of man that don't use -l.
148 * Updating git repos no longer uses git-pull -t by default. Git makes it
149 to much of a PITA to do this, since -t makes git-pull require the
150 repository and refspec be specified at the command line (which is a bug in
151 git (#456035). mr used to hardcode those to "origin" and "master", but
152 that's not always the right choice. So give up on forcing git to be sane
153 about pulling down all tags. It's insane. Live with it, or configure your
156 -- Joey Hess <joeyh@debian.org> Wed, 12 Dec 2007 21:30:45 -0500
158 mr (0.18) unstable; urgency=low
160 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
161 * darcs: De-p register code. Closes: #453502
163 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
165 mr (0.17) unstable; urgency=low
167 * Even bigger hammer: Set LC_ALL. Closes: #453305
169 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
171 mr (0.16) unstable; urgency=low
173 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
174 won't override it. Closes: #453305
176 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
178 mr (0.15) unstable; urgency=low
181 * Allow -n to be passed a number to specify how deep to go into
182 subdirectories to find repositories to act on. Closes: #450621
185 * Make -j with no argument run unlimited jobs in parallel, like make -j
189 * Add a warning about runing too many jobs at a time.
191 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
193 mr (0.14) unstable; urgency=low
195 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
196 Bloom. Closes: #449592
197 * Cut number of rcs tests run in half.
199 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
201 mr (0.13) unstable; urgency=low
203 * -c was broken, fix. Closes: #449539
205 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
207 mr (0.12) unstable; urgency=low
209 * Avoid creating parent directory for a checkout that will ultimately be
211 * Don't try to test the repo type when doing a checkout, that can't work
212 since the repo isn't there yet. It was actually checking the repo type
213 of the parent directory, which caused several unexpected behaviors.
215 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
217 mr (0.11) unstable; urgency=low
219 * Avoid using commands like git-config and instead use "git config".
220 In some configurations, only the main git command is in the path.
221 * Allow option bundling, mostly so "-j2" will work.
222 * Better error message if more than one repo type test matches a single
225 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
227 mr (0.10) unstable; urgency=low
229 * Add a lib file for using unison with mr.
230 * Make registration work when no config file yet exists. Closes: #448422
232 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
234 mr (0.9) unstable; urgency=low
236 * Split up actions, so each rcs has its own set of action commands,
237 and mr tests to see what rcs is used by a repository, and dispatches
240 This will make it much easier to add new rcses, or modify just the
241 command that mr uses for one command for one rcs, without duplicating a
242 lot of code, and without needing to modify mr at all.
244 The old style unsplit actions are still supported, and are what most
245 mrconfig files will still use; this change is fully backwards compatible.
246 * Changed some things in the enviroment for the register action.
247 It's now run in the directory that the user specifies, and MR_REPO
248 is set to contain the basename of the directory that the checkout
249 command should check out. These changes should be backware compatible
250 to existing register actions.
251 * Add info and warning functions to the shell library. (madduck)
252 * Add git_bare and git_fake_bare rcs types to handle
253 bare and fake bare (non-bare with a detached worktree) git repositories.
254 (Diff and commit do not work yet to fake bare repos). (madduck)
255 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
256 * Add support for including one mrconfig file from another. Unlike chaining,
257 this doesn't change the paths, and is not tied to a particular
258 subdirectory. It's useful for loading up library mrconfig files.
259 * Split git fake-bare support out into a lib/git-fake-bare.
260 Partly because it's a good example of how to add a new revision control
261 type and use includes, and partly because it's currently too ugly to be
262 in mr itself due to bugs and limitations in git.
264 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
266 mr (0.8) unstable; urgency=low
268 * Improve "in subdir" message.
269 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
270 interactive updates. Closes: #447999
272 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
274 mr (0.7) unstable; urgency=low
276 * Fix inverted tests in tags command. (madduck)
277 * Patch from Simon McVittie, adding support for darcs repositories.
280 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
282 mr (0.6) unstable; urgency=low
284 * Add to the example mrconfig a "tags" command that lists tags.
285 (Currently only for svn and git.)
286 * hours_since was broken by design, and fixing it involved changing
287 its calling convention. If you used the old version, the new version
289 * Add ability to reorder repos, if you want mr to act on a given repo first
292 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
294 mr (0.5) unstable; urgency=low
297 * Removed special case repository deletion handling code. The same
298 thing can be accomplished in a mrconfig by skipping a repo unless
299 it exists, and printing a reminder on update. See the mrconfig file
301 * Fix output of "mr config DEFAULT lib".
302 * Change mr update to use git pull -t origin master, to make sure new tags
303 are pulled. And since those might not always be the right parameters
304 for git pull, any parameters passed to mr update will replace them.
307 * Add support for mercurial.
310 * Incorporate code based on Anthony Towns's mrs, to allow running
311 multiple jobs in parallel. The -j flag controls this.
312 This can produce enormous speedups. For me, mr update takes
313 12 minutes, while mr -j 10 update takes 1 minute!
315 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
317 mr (0.4) unstable; urgency=low
319 * Fix mr register of a subdir to also work with -c.
320 * Signal handling for commands run by mr, including handling of SIGINT
322 * Ensure parent dirs exist prior to checkout. (madduck)
323 * Output list of failed repos to stderr when -s is used.
324 * Fix a bug caused by a stupid typo.
325 * Add the -n switch, for disabling recursion.
326 * Allow for more complex deleted tests, such as marking a repo deleted on
327 some hosts, while not on others.
328 * Support registering CVS repositories. Closes: #447171
329 * MR_CONFIG now points to the config file that contains the repo mr is
331 * Make mr register smarter about what mrconfig file to write to.
332 (It probably does what you'd expect it to do now; if it doesn't, -c
335 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
337 mr (0.3) unstable; urgency=low
339 * Add a check to make sure the expected directory exists after checkout.
340 * mr register will now write to whatever config file is specified with -c
341 * Typo fixes from madduck.
343 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
345 mr (0.2) unstable; urgency=low
347 * Fix line number display for config file parse errors.
348 * Fix a bug in inheritance of default settings in chained .mrconfig files.
351 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
353 mr (0.1) unstable; urgency=low
357 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400