]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

changelog
[code/myrepos.git] / debian / changelog
1 mr (1.11) UNRELEASED; urgency=low
2
3   * Now supports the veracity vcs. Thanks, Jimmy Tang.
4
5  -- Joey Hess <joeyh@debian.org>  Mon, 09 Jan 2012 17:12:58 -0400
6
7 mr (1.10) unstable; urgency=low
8
9   * Fix display of trust errors.
10
11  -- Joey Hess <joeyh@debian.org>  Tue, 27 Dec 2011 12:13:15 -0400
12
13 mr (1.09) unstable; urgency=low
14
15   * Remove dir_test hack and add a way for vcs tests to run perl code,
16     using this for the same optimisation. Fixes support for git-svn
17     etc. Closes: #652317
18
19  -- Joey Hess <joeyh@debian.org>  Fri, 16 Dec 2011 13:29:40 -0400
20
21 mr (1.08) unstable; urgency=low
22
23   * Fix vcs test code. Closes: #651976
24
25  -- Joey Hess <joeyh@debian.org>  Tue, 13 Dec 2011 16:21:19 -0400
26
27 mr (1.07) unstable; urgency=low
28
29   * Added support for vcsh, enable with: include = cat /usr/share/mr/vcsh
30     Thanks, Richard Hartmann 
31   * Block tty control codes in untrusted mr config files.
32   * Correct printing of line numbers when includes are used. Closes: #650952
33   * The previous fix for chaining to absolute paths broke chaining to relative
34     paths with more than one path segment. Thanks, Adam Spiers
35   * Support _append to add on to the existing value of a parameter.
36     Thanks, Adam Spiers
37   * Optimizations. Commands like "mr list" run up to 5 times faster.
38   * Fix shell escaping of parameters passed to mr commands. Closes: #644672
39   * Added --force option that disables repository skipping.
40   * Repositories using skip = lazy will not be checked out by "mr update"
41     or "mr checkout" unless --force is used.
42
43  -- Joey Hess <joeyh@debian.org>  Mon, 12 Dec 2011 15:52:16 -0400
44
45 mr (1.06) unstable; urgency=low
46
47   * Fix propigation of failure from pre and post hooks and from fixups.
48   * Support chaining to absolute paths.
49   * Add support for skip = lazy, a mode where mr only operates on repositories
50     that are checked out.
51
52  -- Joey Hess <joeyh@debian.org>  Fri, 04 Nov 2011 17:03:17 -0400
53
54 mr (1.05) unstable; urgency=low
55
56   * README now gives a quick into to using mr.
57   * Brought back the "deleted" parameter, which provides an easy way to
58     mark repositories that should be removed.
59   * Allow untrusted mrconfig files to set parameters to true/false.
60     So skip=true or deleted=true can be used in an untrusted mrconfig file.
61   * Also allow order=N in an untrusted mrconfig file.
62   * Support bzr checkouts, which are updated with "bzr update",
63     and to which bzr automatically pushes commits. Closes: #643589
64   * Use bzr branch, not deprecated bzr clone when registering bzr
65     repositories. Closes: #643591
66   * Allow bzr branch|clone|get|checkout in untrusted mrconfig files.
67   * Avoid using sed -r in git-fake-bare, for OSX portability.
68   * git-fake-bare: handle fake bare repositories with core.bare not set
69     (Thanks, Julien Rebetez)
70
71  -- Joey Hess <joeyh@debian.org>  Tue, 27 Sep 2011 17:28:35 -0400
72
73 mr (1.04) unstable; urgency=low
74
75   * Improve trust errors displayed while bootstrapping. Closes: #628234
76   * Allow mr register to be used with mrconfig file that does not yet
77     exist. Closes: #629217
78
79  -- Joey Hess <joeyh@debian.org>  Sun, 19 Jun 2011 15:52:42 -0400
80
81 mr (1.03) unstable; urgency=low
82
83   * Added git-subtree library. Thanks, Svend Sorensen
84   * Now --quiet supresses all output from commands run, as well
85     as from mr, unless a command fails. Closes: #529296
86
87  -- Joey Hess <joeyh@debian.org>  Sun, 01 May 2011 19:09:35 -0400
88
89 mr (1.02) unstable; urgency=low
90
91   * Fix bug in escaping.
92
93  -- Joey Hess <joeyh@debian.org>  Sat, 22 Jan 2011 01:18:23 -0400
94
95 mr (1.01) unstable; urgency=low
96
97   * Add "mr run", which can run an arbitrary command in each repository.
98
99  -- Joey Hess <joeyh@debian.org>  Thu, 20 Jan 2011 16:50:49 -0400
100
101 mr (1.00) unstable; urgency=low
102
103   * Trust flag day. All mrconfig files except the main ~/.mrconfig are
104     now untrusted by default, until listed in ~/.mrtrust.
105   * The -p flag is now enabled by default. mr first reads ~/.mrconfig,
106     and then looks for an additional .mrconfig file in the current
107     directory or one of its parent directories. Closes: #557963
108
109  -- Joey Hess <joeyh@debian.org>  Wed, 19 Jan 2011 14:28:38 -0400
110
111 mr (0.51) unstable; urgency=low
112
113   * Fix display when absolute directories are configured in mrconfig.
114   * Add push to manpage synopsis. Closes: #603029
115   * Do not return a nonzero exit status when all repositories were skipped.
116     Closes: #607287
117
118  -- Joey Hess <joeyh@debian.org>  Thu, 16 Dec 2010 12:53:32 -0400
119
120 mr (0.50) unstable; urgency=low
121
122   * Now supports the Fossil VCS. (Thanks, Jimmy Tang)
123   * Added fixups hook, which can be used to run a command after
124     a repository is checked out or updated. Closes: #590868
125   * Added support for arbitrary pre and post hooks for all defined mr
126     commands. For example, pre_commit is run before all commits; post_update
127     is run after all updates. Closes: #481341
128
129  -- Joey Hess <joeyh@debian.org>  Sun, 29 Aug 2010 15:00:01 -0400
130
131 mr (0.49) unstable; urgency=low
132
133   * Update suggests for git-core to git transition.
134   * Use short mode status output for git and bzr.
135   * Typo. Closes: #586233, #588913
136
137  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jul 2010 23:08:06 -0400
138
139 mr (0.48) unstable; urgency=low
140
141   * Fix the hours_since function built into mr's shell library to
142     not exit, but return a true/false exit status. This allows it to be
143     used outside of skip tests.
144
145  -- Joey Hess <joeyh@debian.org>  Fri, 05 Feb 2010 17:12:01 -0500
146
147 mr (0.47) unstable; urgency=low
148
149   * Pass -L to curl to allow it to follow redirects when bootstrapping.
150     (Pavel Avgustinov)
151   * Allow empty sections to be used in mrconfig files.
152
153  -- Joey Hess <joeyh@debian.org>  Fri, 05 Feb 2010 16:40:29 -0500
154
155 mr (0.46) unstable; urgency=low
156
157   * Avoid using abs_path to determine canonical repo path, as that fails
158     when the repo has not yet been checked out.
159
160  -- Joey Hess <joeyh@debian.org>  Thu, 10 Dec 2009 17:28:26 -0500
161
162 mr (0.45) unstable; urgency=low
163
164   * Fix pod error. Closes: #558012
165   * bootstrap: Improve stats display.
166   * Add --insecure option that can be used to ignore SSL cert errors
167     when bootstrapping. (Pavel Avgustinov)
168   * Fix handling of a repository in "."
169
170  -- Joey Hess <joeyh@debian.org>  Tue, 08 Dec 2009 14:58:21 -0500
171
172 mr (0.44) unstable; urgency=low
173
174   * Make mr -i pass -i to the shell, to ensure it knows it should be an
175     interactive shell.
176   * mr help: Support man on SunOS and OS X. (Geoff Davis)
177   * mr bootstrap: Fix cross-device rename failure. Closes: #557962
178
179  -- Joey Hess <joeyh@debian.org>  Wed, 25 Nov 2009 12:39:08 -0500
180
181 mr (0.43) unstable; urgency=low
182
183   * Set User-Agent to "mr" when downloading the mrconfig file
184     with mr bootstrap. Closes: #541778
185   * Man page typo. Closes: #545412
186   * mr bootstrap: Allow a directory to checkout into to be specified,
187     and create it if necessary.
188   * mr bootstrap: If the mrconfig file contains a repository named ".",
189     check it out into the top level of the directory bootstrapped.
190
191  -- Joey Hess <joeyh@debian.org>  Tue, 08 Sep 2009 20:22:32 -0400
192
193 mr (0.42) unstable; urgency=low
194
195   * Add support for ~/.mrtrust, which can be used to list trusted mrconfig
196     files. If you create this file, all files not listed in it will be treated
197     as untrusted, and carefully limited in what they can do. This improves
198     security when using mrconfig files provided by others.
199
200  -- Joey Hess <joeyh@debian.org>  Fri, 07 Aug 2009 16:38:31 -0400
201
202 mr (0.41) unstable; urgency=low
203
204   * Add -p switch, that makes mr search the current directory and its
205     parents for a .mrconfig file to use.
206   * Add `mr bootstrap`, which downloads an url to a .mrconfig file
207     in the current directory and then checks out all repositories configured
208     in it. This is intended for projects that want to publish a mrconfig file
209     to automate use of their several repositories.
210
211  -- Joey Hess <joeyh@debian.org>  Thu, 06 Aug 2009 22:38:58 -0400
212
213 mr (0.40) unstable; urgency=low
214
215   * Pass --pull to bzr merge to avoid needing to commit
216     merged changes. Closes: #524352
217
218  -- Joey Hess <joeyh@debian.org>  Fri, 31 Jul 2009 13:47:22 -0400
219
220 mr (0.39) unstable; urgency=low
221
222   * Determine current branch for fake-bare update (martin f. krafft)
223
224  -- Joey Hess <joeyh@debian.org>  Mon, 09 Mar 2009 22:50:54 -0400
225
226 mr (0.38) unstable; urgency=low
227
228   * Remove gitless lib. It turned out to be better to simply
229     use git clone --shared when checking out. Sorry for the churn..
230
231  -- Joey Hess <joeyh@debian.org>  Thu, 22 Jan 2009 15:39:33 -0500
232
233 mr (0.37) unstable; urgency=low
234
235   * Add "gitless" file to lib. 
236     This adds a special type of git repository, where the .git directory
237     is stored on a file server, to avoid wasting space with it on the client.
238   * Revert buggy change to directory printing code.
239
240  -- Joey Hess <joeyh@debian.org>  Wed, 21 Jan 2009 01:40:59 -0500
241
242 mr (0.36) unstable; urgency=low
243
244   * Add webcheckout command. See <http://kitenet.net/~joey/rfc/rel-vcs/>
245   * Fix display of repos configured at absolute path locations.
246
247  -- Joey Hess <joeyh@debian.org>  Sat, 10 Jan 2009 16:42:07 -0500
248
249 mr (0.35) unstable; urgency=low
250
251   * Warn if an include command fails nonzero. Closes: #495306
252   * Remove stray character in pod that uglified man page. Closes: #495731
253   * Create ~/.mrlog not world readable.
254   * Pass additional options to darcs push when pushing. Closes: #495734
255
256  -- Joey Hess <joeyh@debian.org>  Thu, 16 Oct 2008 14:51:00 -0400
257
258 mr (0.34) unstable; urgency=low
259
260   * Fix bug when remembering failed commands in offline mode.
261
262  -- Joey Hess <joeyh@debian.org>  Sat, 02 Aug 2008 12:27:21 -0400
263
264 mr (0.33) unstable; urgency=low
265
266   * Add a push subcommand, which pushes committed changes for DCVS, and 
267     does nothing for svn/cvs. Closes: #491865
268
269  -- Joey Hess <joeyh@debian.org>  Tue, 22 Jul 2008 15:22:01 -0400
270
271 mr (0.32) unstable; urgency=low
272
273   * Include the right (v2) version of GPL in the source.
274
275  -- Joey Hess <joeyh@debian.org>  Tue, 22 Jul 2008 00:28:55 -0400
276
277 mr (0.31) unstable; urgency=low
278
279   * Add an offline mode. When in offline mode, mr will remember commands
280     that failed (presumably due to lack of network access), and will run
281     them again once back online. (This is for all the laptop users
282     like me who don't want to have to remember which git repos to mr push
283     when they come back from a nice long hack in the woods. :-)
284
285  -- Joey Hess <joeyh@debian.org>  Fri, 27 Jun 2008 23:19:23 -0400
286
287 mr (0.30) unstable; urgency=low
288
289   [ martin f. krafft ]
290   * Several git-fake-bare improvements.
291
292   [ Joey Hess ]
293   * Fix mr -c <config> register. (Thanks, Daniel Bungert)
294
295  -- Joey Hess <joeyh@debian.org>  Wed, 25 Jun 2008 13:38:31 -0400
296
297 mr (0.29) unstable; urgency=low
298
299   * Allow environment variables in section headers. Pass such headers
300     through the shell to expand them. Closes: #480421
301   * For the checkout command, MR_REPO was set to the name of the parent
302     directory of the directory to checkout. It is supposed to be the
303     path to the directory itself though; fixed this. Closes: #480424
304
305  -- Joey Hess <joeyh@debian.org>  Wed, 14 May 2008 19:38:18 -0400
306
307 mr (0.28) unstable; urgency=low
308
309   * Use debhelper v7, rules file minimisation.
310   * Add a Makefile.
311
312  -- Joey Hess <joeyh@debian.org>  Wed, 23 Apr 2008 21:56:06 -0400
313
314 mr (0.27) unstable; urgency=low
315
316   * Ignore exit code from darcs whatsnew, which can be nonzero if there
317     are no changes. Closes: #476650
318
319  -- Joey Hess <joeyh@debian.org>  Sat, 19 Apr 2008 16:47:04 -0400
320
321 mr (0.26) unstable; urgency=low
322
323   * Add -i option to start a shell if an operation fails. Closes: #474962
324
325  -- Joey Hess <joeyh@debian.org>  Tue, 08 Apr 2008 20:58:44 -0400
326
327 mr (0.25) unstable; urgency=low
328
329   * git-fake-bare: Add support for diff, commit, and record. (madduck)
330
331  -- Joey Hess <joeyh@debian.org>  Mon, 10 Mar 2008 15:56:17 -0400
332
333 mr (0.24) unstable; urgency=low
334
335   * Correct GIT_CONFIG settings in git-svn. Closes: #463941
336
337  -- Joey Hess <joeyh@debian.org>  Wed, 06 Feb 2008 13:04:30 -0500
338
339 mr (0.23) unstable; urgency=low
340
341   * Fix tests in git-svn include file to use MR_REPO. Closes: #463941
342
343  -- Joey Hess <joeyh@debian.org>  Tue, 05 Feb 2008 13:26:05 -0500
344
345 mr (0.22) unstable; urgency=low
346
347   * Update bzr registration code to work with current version of bzr,
348     using bzr info to get the url. Closes: #463867
349
350  -- Joey Hess <joeyh@debian.org>  Sun, 03 Feb 2008 17:04:59 -0500
351
352 mr (0.21) unstable; urgency=low
353
354   * Add a git-svn file, which can be included to add support for git-svn
355     repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
356     for implementations. Closes: #462408
357
358  -- Joey Hess <joeyh@debian.org>  Thu, 24 Jan 2008 13:45:05 -0500
359
360 mr (0.20) unstable; urgency=low
361
362   * Add -q flag.
363   * darcs: Add -u to diff to get a more usual unified diff.
364   * Add a "record" subcommand, borrowing termonology from darcs. This does a
365     local commit, but does not push changes to remote repos.
366   * Improve unison support.
367
368  -- Joey Hess <joeyh@debian.org>  Wed, 02 Jan 2008 22:49:53 -0500
369
370 mr (0.19) unstable; urgency=low
371
372   * Support versions of man that don't use -l.
373   * Updating git repos no longer uses git-pull -t by default. Git makes it
374     to much of a PITA to do this, since -t makes git-pull require the
375     repository and refspec be specified at the command line (which is a bug in
376     git (#456035). mr used to hardcode those to "origin" and "master", but
377     that's not always the right choice. So give up on forcing git to be sane
378     about pulling down all tags. It's insane. Live with it, or configure your
379     own update command.
380
381  -- Joey Hess <joeyh@debian.org>  Wed, 12 Dec 2007 21:30:45 -0500
382
383 mr (0.18) unstable; urgency=low
384
385   * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
386   * darcs: De-p register code. Closes: #453502
387
388  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 17:48:09 -0500
389
390 mr (0.17) unstable; urgency=low
391
392   * Even bigger hammer: Set LC_ALL. Closes: #453305
393
394  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 11:18:40 -0500
395
396 mr (0.16) unstable; urgency=low
397
398   * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
399     won't override it. Closes: #453305
400
401  -- Joey Hess <joeyh@debian.org>  Wed, 28 Nov 2007 15:46:38 -0500
402
403 mr (0.15) unstable; urgency=low
404
405   [ Joey Hess ]
406   * Allow -n to be passed a number to specify how deep to go into
407     subdirectories to find repositories to act on. Closes: #450621
408
409   [ Josh Triplett ]
410   * Make -j with no argument run unlimited jobs in parallel, like make -j
411     Closes: #452467
412
413   [ Joey Hess ]
414   * Add a warning about runing too many jobs at a time.
415
416  -- Joey Hess <joeyh@debian.org>  Sun, 25 Nov 2007 13:13:47 -0500
417
418 mr (0.14) unstable; urgency=low
419
420   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
421     Bloom. Closes: #449592
422   * Cut number of rcs tests run in half.
423
424  -- Joey Hess <joeyh@debian.org>  Sun, 11 Nov 2007 01:10:18 -0500
425
426 mr (0.13) unstable; urgency=low
427
428   * -c was broken, fix. Closes: #449539
429
430  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
431
432 mr (0.12) unstable; urgency=low
433
434   * Avoid creating parent directory for a checkout that will ultimately be
435     skipped.
436   * Don't try to test the repo type when doing a checkout, that can't work
437     since the repo isn't there yet. It was actually checking the repo type
438     of the parent directory, which caused several unexpected behaviors.
439
440  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
441
442 mr (0.11) unstable; urgency=low
443
444   * Avoid using commands like git-config and instead use "git config".
445     In some configurations, only the main git command is in the path.
446   * Allow option bundling, mostly so "-j2" will work.
447   * Better error message if more than one repo type test matches a single
448     directory.
449
450  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
451
452 mr (0.10) unstable; urgency=low
453
454   * Add a lib file for using unison with mr.
455   * Make registration work when no config file yet exists. Closes: #448422
456
457  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
458
459 mr (0.9) unstable; urgency=low
460
461   * Split up actions, so each rcs has its own set of action commands,
462     and mr tests to see what rcs is used by a repository, and dispatches
463     the command.
464
465     This will make it much easier to add new rcses, or modify just the
466     command that mr uses for one command for one rcs, without duplicating a
467     lot of code, and without needing to modify mr at all.
468
469     The old style unsplit actions are still supported, and are what most
470     mrconfig files will still use; this change is fully backwards compatible.
471   * Changed some things in the enviroment for the register action.
472     It's now run in the directory that the user specifies, and MR_REPO
473     is set to contain the basename of the directory that the checkout
474     command should check out. These changes should be backware compatible
475     to existing register actions.
476   * Add info and warning functions to the shell library. (madduck)
477   * Add git_bare and git_fake_bare rcs types to handle
478     bare and fake bare (non-bare with a detached worktree) git repositories.
479     (Diff and commit do not work yet to fake bare repos). (madduck)
480   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
481   * Add support for including one mrconfig file from another. Unlike chaining,
482     this doesn't change the paths, and is not tied to a particular
483     subdirectory. It's useful for loading up library mrconfig files.
484   * Split git fake-bare support out into a lib/git-fake-bare.
485     Partly because it's a good example of how to add a new revision control
486     type and use includes, and partly because it's currently too ugly to be
487     in mr itself due to bugs and limitations in git.
488
489  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
490
491 mr (0.8) unstable; urgency=low
492
493   * Improve "in subdir" message.
494   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
495     interactive updates. Closes: #447999
496
497  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
498
499 mr (0.7) unstable; urgency=low
500
501   * Fix inverted tests in tags command. (madduck)
502   * Patch from Simon McVittie, adding support for darcs repositories.
503     Closes: #447729
504
505  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
506
507 mr (0.6) unstable; urgency=low
508
509   * Add to the example mrconfig a "tags" command that lists tags.
510     (Currently only for svn and git.)
511   * hours_since was broken by design, and fixing it involved changing
512     its calling convention. If you used the old version, the new version
513     will error out.
514   * Add ability to reorder repos, if you want mr to act on a given repo first
515     or last.
516
517  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
518
519 mr (0.5) unstable; urgency=low
520
521   [ Joey Hess ]
522   * Removed special case repository deletion handling code. The same
523     thing can be accomplished in a mrconfig by skipping a repo unless
524     it exists, and printing a reminder on update. See the mrconfig file
525     for an example.
526   * Fix output of "mr config DEFAULT lib".
527   * Change mr update to use git pull -t origin master, to make sure new tags
528     are pulled. And since those might not always be the right parameters
529     for git pull, any parameters passed to mr update will replace them.
530
531   [ Alexander Wirt ]
532   * Add support for mercurial.
533
534   [ Joey Hess ]
535   * Incorporate code based on Anthony Towns's mrs, to allow running
536     multiple jobs in parallel. The -j flag controls this.
537     This can produce enormous speedups. For me, mr update takes
538     12 minutes, while mr -j 10 update takes 1 minute!
539
540  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
541
542 mr (0.4) unstable; urgency=low
543
544   * Fix mr register of a subdir to also work with -c.
545   * Signal handling for commands run by mr, including handling of SIGINT
546     to stop mr.
547   * Ensure parent dirs exist prior to checkout. (madduck)
548   * Output list of failed repos to stderr when -s is used.
549   * Fix a bug caused by a stupid typo.
550   * Add the -n switch, for disabling recursion.
551   * Allow for more complex deleted tests, such as marking a repo deleted on
552     some hosts, while not on others.
553   * Support registering CVS repositories. Closes: #447171
554   * MR_CONFIG now points to the config file that contains the repo mr is
555     acting on.
556   * Make mr register smarter about what mrconfig file to write to.
557     (It probably does what you'd expect it to do now; if it doesn't, -c
558     can still override.)
559
560  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
561
562 mr (0.3) unstable; urgency=low
563
564   * Add a check to make sure the expected directory exists after checkout.
565   * mr register will now write to whatever config file is specified with -c
566   * Typo fixes from madduck.
567
568  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
569
570 mr (0.2) unstable; urgency=low
571
572   * Fix line number display for config file parse errors.
573   * Fix a bug in inheritance of default settings in chained .mrconfig files.
574   * Add the -s option.
575
576  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
577
578 mr (0.1) unstable; urgency=low
579
580   * First release.
581
582  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400