]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

changelog improvement
[code/myrepos.git] / debian / changelog
1 mr (0.9) UNRELEASED; urgency=low
2
3   * Split up actions, so each rcs has its own set of action commands,
4     and mr tests to see what rcs is used by a repository, and dispatches
5     the command.
6
7     This will make it much easier to add new rcses, or modify just the
8     command that mr uses for one command for one rcs, without duplicating a
9     lot of code, and without needing to modify mr at all.
10
11     The old style unsplit actions are still supported, and are what most
12     mrconfig files will still use; this change is fully backwards compatible.
13   * Changed some things in the enviroment for the register action.
14     It's now run in the directory that the user specifies, and MR_REPO
15     is set to contain the basename of the directory that the checkout
16     command should check out. These changes should be backware compatible
17     to existing register actions.
18   * Add info and warning functions to the shell library. (madduck)
19   * Add git_bare and git_fake_bare rcs types to handle
20     bare and fake bare (non-bare with a detached worktree) git repositories.
21     (Diff and commit do not work yet to fake bare repos). (madduck)
22   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
23   * Add support for including one mrconfig file from another. Unlike chaining,
24     this doesn't change the paths, and is not tied to a particular
25     subdirectory. It's useful for loading up library mrconfig files.
26   * Split git fake-bare support out into a mrconfig.git-fake-bare.
27     Partly because it's a good example of how to add a new revision control
28     type and use includes, and partly because it's currently too ugly to be
29     in mr itself due to bugs and limitations in git.
30
31  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 21:43:36 -0400
32
33 mr (0.8) unstable; urgency=low
34
35   * Improve "in subdir" message.
36   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
37     interactive updates. Closes: #447999
38
39  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
40
41 mr (0.7) unstable; urgency=low
42
43   * Fix inverted tests in tags command. (madduck)
44   * Patch from Simon McVittie, adding support for darcs repositories.
45     Closes: #447729
46
47  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
48
49 mr (0.6) unstable; urgency=low
50
51   * Add to the example mrconfig a "tags" command that lists tags.
52     (Currently only for svn and git.)
53   * hours_since was broken by design, and fixing it involved changing
54     its calling convention. If you used the old version, the new version
55     will error out.
56   * Add ability to reorder repos, if you want mr to act on a given repo first
57     or last.
58
59  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
60
61 mr (0.5) unstable; urgency=low
62
63   [ Joey Hess ]
64   * Removed special case repository deletion handling code. The same
65     thing can be accomplished in a mrconfig by skipping a repo unless
66     it exists, and printing a reminder on update. See the mrconfig file
67     for an example.
68   * Fix output of "mr config DEFAULT lib".
69   * Change mr update to use git pull -t origin master, to make sure new tags
70     are pulled. And since those might not always be the right parameters
71     for git pull, any parameters passed to mr update will replace them.
72
73   [ Alexander Wirt ]
74   * Add support for mercurial.
75
76   [ Joey Hess ]
77   * Incorporate code based on Anthony Towns's mrs, to allow running
78     multiple jobs in parallel. The -j flag controls this.
79     This can produce enormous speedups. For me, mr update takes
80     12 minutes, while mr -j 10 update takes 1 minute!
81
82  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
83
84 mr (0.4) unstable; urgency=low
85
86   * Fix mr register of a subdir to also work with -c.
87   * Signal handling for commands run by mr, including handling of SIGINT
88     to stop mr.
89   * Ensure parent dirs exist prior to checkout. (madduck)
90   * Output list of failed repos to stderr when -s is used.
91   * Fix a bug caused by a stupid typo.
92   * Add the -n switch, for disabling recursion.
93   * Allow for more complex deleted tests, such as marking a repo deleted on
94     some hosts, while not on others.
95   * Support registering CVS repositories. Closes: #447171
96   * MR_CONFIG now points to the config file that contains the repo mr is
97     acting on.
98   * Make mr register smarter about what mrconfig file to write to.
99     (It probably does what you'd expect it to do now; if it doesn't, -c
100     can still override.)
101
102  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
103
104 mr (0.3) unstable; urgency=low
105
106   * Add a check to make sure the expected directory exists after checkout.
107   * mr register will now write to whatever config file is specified with -c
108   * Typo fixes from madduck.
109
110  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
111
112 mr (0.2) unstable; urgency=low
113
114   * Fix line number display for config file parse errors.
115   * Fix a bug in inheritance of default settings in chained .mrconfig files.
116   * Add the -s option.
117
118  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
119
120 mr (0.1) unstable; urgency=low
121
122   * First release.
123
124  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400