]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

Allow option bundling, mostly so "-j2" will work.
[code/myrepos.git] / debian / changelog
1 mr (0.11) UNRELEASED; urgency=low
2
3   * Avoid using commands like git-config and instead use "git config".
4     In some configurations, only the main git command is in the path.
5   * Allow option bundling, mostly so "-j2" will work.
6
7  -- Joey Hess <joeyh@debian.org>  Thu, 01 Nov 2007 23:52:50 -0400
8
9 mr (0.10) unstable; urgency=low
10
11   * Add a lib file for using unison with mr.
12   * Make registration work when no config file yet exists. Closes: #448422
13
14  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
15
16 mr (0.9) unstable; urgency=low
17
18   * Split up actions, so each rcs has its own set of action commands,
19     and mr tests to see what rcs is used by a repository, and dispatches
20     the command.
21
22     This will make it much easier to add new rcses, or modify just the
23     command that mr uses for one command for one rcs, without duplicating a
24     lot of code, and without needing to modify mr at all.
25
26     The old style unsplit actions are still supported, and are what most
27     mrconfig files will still use; this change is fully backwards compatible.
28   * Changed some things in the enviroment for the register action.
29     It's now run in the directory that the user specifies, and MR_REPO
30     is set to contain the basename of the directory that the checkout
31     command should check out. These changes should be backware compatible
32     to existing register actions.
33   * Add info and warning functions to the shell library. (madduck)
34   * Add git_bare and git_fake_bare rcs types to handle
35     bare and fake bare (non-bare with a detached worktree) git repositories.
36     (Diff and commit do not work yet to fake bare repos). (madduck)
37   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
38   * Add support for including one mrconfig file from another. Unlike chaining,
39     this doesn't change the paths, and is not tied to a particular
40     subdirectory. It's useful for loading up library mrconfig files.
41   * Split git fake-bare support out into a lib/git-fake-bare.
42     Partly because it's a good example of how to add a new revision control
43     type and use includes, and partly because it's currently too ugly to be
44     in mr itself due to bugs and limitations in git.
45
46  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
47
48 mr (0.8) unstable; urgency=low
49
50   * Improve "in subdir" message.
51   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
52     interactive updates. Closes: #447999
53
54  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
55
56 mr (0.7) unstable; urgency=low
57
58   * Fix inverted tests in tags command. (madduck)
59   * Patch from Simon McVittie, adding support for darcs repositories.
60     Closes: #447729
61
62  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
63
64 mr (0.6) unstable; urgency=low
65
66   * Add to the example mrconfig a "tags" command that lists tags.
67     (Currently only for svn and git.)
68   * hours_since was broken by design, and fixing it involved changing
69     its calling convention. If you used the old version, the new version
70     will error out.
71   * Add ability to reorder repos, if you want mr to act on a given repo first
72     or last.
73
74  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
75
76 mr (0.5) unstable; urgency=low
77
78   [ Joey Hess ]
79   * Removed special case repository deletion handling code. The same
80     thing can be accomplished in a mrconfig by skipping a repo unless
81     it exists, and printing a reminder on update. See the mrconfig file
82     for an example.
83   * Fix output of "mr config DEFAULT lib".
84   * Change mr update to use git pull -t origin master, to make sure new tags
85     are pulled. And since those might not always be the right parameters
86     for git pull, any parameters passed to mr update will replace them.
87
88   [ Alexander Wirt ]
89   * Add support for mercurial.
90
91   [ Joey Hess ]
92   * Incorporate code based on Anthony Towns's mrs, to allow running
93     multiple jobs in parallel. The -j flag controls this.
94     This can produce enormous speedups. For me, mr update takes
95     12 minutes, while mr -j 10 update takes 1 minute!
96
97  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
98
99 mr (0.4) unstable; urgency=low
100
101   * Fix mr register of a subdir to also work with -c.
102   * Signal handling for commands run by mr, including handling of SIGINT
103     to stop mr.
104   * Ensure parent dirs exist prior to checkout. (madduck)
105   * Output list of failed repos to stderr when -s is used.
106   * Fix a bug caused by a stupid typo.
107   * Add the -n switch, for disabling recursion.
108   * Allow for more complex deleted tests, such as marking a repo deleted on
109     some hosts, while not on others.
110   * Support registering CVS repositories. Closes: #447171
111   * MR_CONFIG now points to the config file that contains the repo mr is
112     acting on.
113   * Make mr register smarter about what mrconfig file to write to.
114     (It probably does what you'd expect it to do now; if it doesn't, -c
115     can still override.)
116
117  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
118
119 mr (0.3) unstable; urgency=low
120
121   * Add a check to make sure the expected directory exists after checkout.
122   * mr register will now write to whatever config file is specified with -c
123   * Typo fixes from madduck.
124
125  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
126
127 mr (0.2) unstable; urgency=low
128
129   * Fix line number display for config file parse errors.
130   * Fix a bug in inheritance of default settings in chained .mrconfig files.
131   * Add the -s option.
132
133  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
134
135 mr (0.1) unstable; urgency=low
136
137   * First release.
138
139  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400