All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.21) unstable; urgency=low
3 * Add a git-svn file, which can be included to add support for git-svn
4 repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
5 for implementations. Closes: #462408
7 -- Joey Hess <joeyh@debian.org> Thu, 24 Jan 2008 13:45:05 -0500
9 mr (0.20) unstable; urgency=low
12 * darcs: Add -u to diff to get a more usual unified diff.
13 * Add a "record" subcommand, borrowing termonology from darcs. This does a
14 local commit, but does not push changes to remote repos.
15 * Improve unison support.
17 -- Joey Hess <joeyh@debian.org> Wed, 02 Jan 2008 22:49:53 -0500
19 mr (0.19) unstable; urgency=low
21 * Support versions of man that don't use -l.
22 * Updating git repos no longer uses git-pull -t by default. Git makes it
23 to much of a PITA to do this, since -t makes git-pull require the
24 repository and refspec be specified at the command line (which is a bug in
25 git (#456035). mr used to hardcode those to "origin" and "master", but
26 that's not always the right choice. So give up on forcing git to be sane
27 about pulling down all tags. It's insane. Live with it, or configure your
30 -- Joey Hess <joeyh@debian.org> Wed, 12 Dec 2007 21:30:45 -0500
32 mr (0.18) unstable; urgency=low
34 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
35 * darcs: De-p register code. Closes: #453502
37 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
39 mr (0.17) unstable; urgency=low
41 * Even bigger hammer: Set LC_ALL. Closes: #453305
43 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
45 mr (0.16) unstable; urgency=low
47 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
48 won't override it. Closes: #453305
50 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
52 mr (0.15) unstable; urgency=low
55 * Allow -n to be passed a number to specify how deep to go into
56 subdirectories to find repositories to act on. Closes: #450621
59 * Make -j with no argument run unlimited jobs in parallel, like make -j
63 * Add a warning about runing too many jobs at a time.
65 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
67 mr (0.14) unstable; urgency=low
69 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
70 Bloom. Closes: #449592
71 * Cut number of rcs tests run in half.
73 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
75 mr (0.13) unstable; urgency=low
77 * -c was broken, fix. Closes: #449539
79 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
81 mr (0.12) unstable; urgency=low
83 * Avoid creating parent directory for a checkout that will ultimately be
85 * Don't try to test the repo type when doing a checkout, that can't work
86 since the repo isn't there yet. It was actually checking the repo type
87 of the parent directory, which caused several unexpected behaviors.
89 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
91 mr (0.11) unstable; urgency=low
93 * Avoid using commands like git-config and instead use "git config".
94 In some configurations, only the main git command is in the path.
95 * Allow option bundling, mostly so "-j2" will work.
96 * Better error message if more than one repo type test matches a single
99 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
101 mr (0.10) unstable; urgency=low
103 * Add a lib file for using unison with mr.
104 * Make registration work when no config file yet exists. Closes: #448422
106 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
108 mr (0.9) unstable; urgency=low
110 * Split up actions, so each rcs has its own set of action commands,
111 and mr tests to see what rcs is used by a repository, and dispatches
114 This will make it much easier to add new rcses, or modify just the
115 command that mr uses for one command for one rcs, without duplicating a
116 lot of code, and without needing to modify mr at all.
118 The old style unsplit actions are still supported, and are what most
119 mrconfig files will still use; this change is fully backwards compatible.
120 * Changed some things in the enviroment for the register action.
121 It's now run in the directory that the user specifies, and MR_REPO
122 is set to contain the basename of the directory that the checkout
123 command should check out. These changes should be backware compatible
124 to existing register actions.
125 * Add info and warning functions to the shell library. (madduck)
126 * Add git_bare and git_fake_bare rcs types to handle
127 bare and fake bare (non-bare with a detached worktree) git repositories.
128 (Diff and commit do not work yet to fake bare repos). (madduck)
129 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
130 * Add support for including one mrconfig file from another. Unlike chaining,
131 this doesn't change the paths, and is not tied to a particular
132 subdirectory. It's useful for loading up library mrconfig files.
133 * Split git fake-bare support out into a lib/git-fake-bare.
134 Partly because it's a good example of how to add a new revision control
135 type and use includes, and partly because it's currently too ugly to be
136 in mr itself due to bugs and limitations in git.
138 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
140 mr (0.8) unstable; urgency=low
142 * Improve "in subdir" message.
143 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
144 interactive updates. Closes: #447999
146 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
148 mr (0.7) unstable; urgency=low
150 * Fix inverted tests in tags command. (madduck)
151 * Patch from Simon McVittie, adding support for darcs repositories.
154 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
156 mr (0.6) unstable; urgency=low
158 * Add to the example mrconfig a "tags" command that lists tags.
159 (Currently only for svn and git.)
160 * hours_since was broken by design, and fixing it involved changing
161 its calling convention. If you used the old version, the new version
163 * Add ability to reorder repos, if you want mr to act on a given repo first
166 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
168 mr (0.5) unstable; urgency=low
171 * Removed special case repository deletion handling code. The same
172 thing can be accomplished in a mrconfig by skipping a repo unless
173 it exists, and printing a reminder on update. See the mrconfig file
175 * Fix output of "mr config DEFAULT lib".
176 * Change mr update to use git pull -t origin master, to make sure new tags
177 are pulled. And since those might not always be the right parameters
178 for git pull, any parameters passed to mr update will replace them.
181 * Add support for mercurial.
184 * Incorporate code based on Anthony Towns's mrs, to allow running
185 multiple jobs in parallel. The -j flag controls this.
186 This can produce enormous speedups. For me, mr update takes
187 12 minutes, while mr -j 10 update takes 1 minute!
189 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
191 mr (0.4) unstable; urgency=low
193 * Fix mr register of a subdir to also work with -c.
194 * Signal handling for commands run by mr, including handling of SIGINT
196 * Ensure parent dirs exist prior to checkout. (madduck)
197 * Output list of failed repos to stderr when -s is used.
198 * Fix a bug caused by a stupid typo.
199 * Add the -n switch, for disabling recursion.
200 * Allow for more complex deleted tests, such as marking a repo deleted on
201 some hosts, while not on others.
202 * Support registering CVS repositories. Closes: #447171
203 * MR_CONFIG now points to the config file that contains the repo mr is
205 * Make mr register smarter about what mrconfig file to write to.
206 (It probably does what you'd expect it to do now; if it doesn't, -c
209 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
211 mr (0.3) unstable; urgency=low
213 * Add a check to make sure the expected directory exists after checkout.
214 * mr register will now write to whatever config file is specified with -c
215 * Typo fixes from madduck.
217 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
219 mr (0.2) unstable; urgency=low
221 * Fix line number display for config file parse errors.
222 * Fix a bug in inheritance of default settings in chained .mrconfig files.
225 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
227 mr (0.1) unstable; urgency=low
231 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400