All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.14) UNRELEASED; urgency=low
3 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
6 -- Joey Hess <joeyh@debian.org> Wed, 07 Nov 2007 11:54:29 -0500
8 mr (0.13) unstable; urgency=low
10 * -c was broken, fix. Closes: #449539
12 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
14 mr (0.12) unstable; urgency=low
16 * Avoid creating parent directory for a checkout that will ultimately be
18 * Don't try to test the repo type when doing a checkout, that can't work
19 since the repo isn't there yet. It was actually checking the repo type
20 of the parent directory, which caused several unexpected behaviors.
22 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
24 mr (0.11) unstable; urgency=low
26 * Avoid using commands like git-config and instead use "git config".
27 In some configurations, only the main git command is in the path.
28 * Allow option bundling, mostly so "-j2" will work.
29 * Better error message if more than one repo type test matches a single
32 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
34 mr (0.10) unstable; urgency=low
36 * Add a lib file for using unison with mr.
37 * Make registration work when no config file yet exists. Closes: #448422
39 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
41 mr (0.9) unstable; urgency=low
43 * Split up actions, so each rcs has its own set of action commands,
44 and mr tests to see what rcs is used by a repository, and dispatches
47 This will make it much easier to add new rcses, or modify just the
48 command that mr uses for one command for one rcs, without duplicating a
49 lot of code, and without needing to modify mr at all.
51 The old style unsplit actions are still supported, and are what most
52 mrconfig files will still use; this change is fully backwards compatible.
53 * Changed some things in the enviroment for the register action.
54 It's now run in the directory that the user specifies, and MR_REPO
55 is set to contain the basename of the directory that the checkout
56 command should check out. These changes should be backware compatible
57 to existing register actions.
58 * Add info and warning functions to the shell library. (madduck)
59 * Add git_bare and git_fake_bare rcs types to handle
60 bare and fake bare (non-bare with a detached worktree) git repositories.
61 (Diff and commit do not work yet to fake bare repos). (madduck)
62 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
63 * Add support for including one mrconfig file from another. Unlike chaining,
64 this doesn't change the paths, and is not tied to a particular
65 subdirectory. It's useful for loading up library mrconfig files.
66 * Split git fake-bare support out into a lib/git-fake-bare.
67 Partly because it's a good example of how to add a new revision control
68 type and use includes, and partly because it's currently too ugly to be
69 in mr itself due to bugs and limitations in git.
71 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
73 mr (0.8) unstable; urgency=low
75 * Improve "in subdir" message.
76 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
77 interactive updates. Closes: #447999
79 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
81 mr (0.7) unstable; urgency=low
83 * Fix inverted tests in tags command. (madduck)
84 * Patch from Simon McVittie, adding support for darcs repositories.
87 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
89 mr (0.6) unstable; urgency=low
91 * Add to the example mrconfig a "tags" command that lists tags.
92 (Currently only for svn and git.)
93 * hours_since was broken by design, and fixing it involved changing
94 its calling convention. If you used the old version, the new version
96 * Add ability to reorder repos, if you want mr to act on a given repo first
99 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
101 mr (0.5) unstable; urgency=low
104 * Removed special case repository deletion handling code. The same
105 thing can be accomplished in a mrconfig by skipping a repo unless
106 it exists, and printing a reminder on update. See the mrconfig file
108 * Fix output of "mr config DEFAULT lib".
109 * Change mr update to use git pull -t origin master, to make sure new tags
110 are pulled. And since those might not always be the right parameters
111 for git pull, any parameters passed to mr update will replace them.
114 * Add support for mercurial.
117 * Incorporate code based on Anthony Towns's mrs, to allow running
118 multiple jobs in parallel. The -j flag controls this.
119 This can produce enormous speedups. For me, mr update takes
120 12 minutes, while mr -j 10 update takes 1 minute!
122 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
124 mr (0.4) unstable; urgency=low
126 * Fix mr register of a subdir to also work with -c.
127 * Signal handling for commands run by mr, including handling of SIGINT
129 * Ensure parent dirs exist prior to checkout. (madduck)
130 * Output list of failed repos to stderr when -s is used.
131 * Fix a bug caused by a stupid typo.
132 * Add the -n switch, for disabling recursion.
133 * Allow for more complex deleted tests, such as marking a repo deleted on
134 some hosts, while not on others.
135 * Support registering CVS repositories. Closes: #447171
136 * MR_CONFIG now points to the config file that contains the repo mr is
138 * Make mr register smarter about what mrconfig file to write to.
139 (It probably does what you'd expect it to do now; if it doesn't, -c
142 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
144 mr (0.3) unstable; urgency=low
146 * Add a check to make sure the expected directory exists after checkout.
147 * mr register will now write to whatever config file is specified with -c
148 * Typo fixes from madduck.
150 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
152 mr (0.2) unstable; urgency=low
154 * Fix line number display for config file parse errors.
155 * Fix a bug in inheritance of default settings in chained .mrconfig files.
158 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
160 mr (0.1) unstable; urgency=low
164 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400