]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Update bzr registration code to work with current version of bzr,
[code/myrepos.git] / debian / changelog
1 mr (0.22) UNRELEASED; urgency=low
2
3   * Update bzr registration code to work with current version of bzr,
4     using bzr info to get the url. Closes: #463867
5
6  -- Joey Hess <joeyh@debian.org>  Sun, 03 Feb 2008 17:04:30 -0500
7
8 mr (0.21) unstable; urgency=low
9
10   * Add a git-svn file, which can be included to add support for git-svn
11     repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
12     for implementations. Closes: #462408
13
14  -- Joey Hess <joeyh@debian.org>  Thu, 24 Jan 2008 13:45:05 -0500
15
16 mr (0.20) unstable; urgency=low
17
18   * Add -q flag.
19   * darcs: Add -u to diff to get a more usual unified diff.
20   * Add a "record" subcommand, borrowing termonology from darcs. This does a
21     local commit, but does not push changes to remote repos.
22   * Improve unison support.
23
24  -- Joey Hess <joeyh@debian.org>  Wed, 02 Jan 2008 22:49:53 -0500
25
26 mr (0.19) unstable; urgency=low
27
28   * Support versions of man that don't use -l.
29   * Updating git repos no longer uses git-pull -t by default. Git makes it
30     to much of a PITA to do this, since -t makes git-pull require the
31     repository and refspec be specified at the command line (which is a bug in
32     git (#456035). mr used to hardcode those to "origin" and "master", but
33     that's not always the right choice. So give up on forcing git to be sane
34     about pulling down all tags. It's insane. Live with it, or configure your
35     own update command.
36
37  -- Joey Hess <joeyh@debian.org>  Wed, 12 Dec 2007 21:30:45 -0500
38
39 mr (0.18) unstable; urgency=low
40
41   * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
42   * darcs: De-p register code. Closes: #453502
43
44  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 17:48:09 -0500
45
46 mr (0.17) unstable; urgency=low
47
48   * Even bigger hammer: Set LC_ALL. Closes: #453305
49
50  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 11:18:40 -0500
51
52 mr (0.16) unstable; urgency=low
53
54   * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
55     won't override it. Closes: #453305
56
57  -- Joey Hess <joeyh@debian.org>  Wed, 28 Nov 2007 15:46:38 -0500
58
59 mr (0.15) unstable; urgency=low
60
61   [ Joey Hess ]
62   * Allow -n to be passed a number to specify how deep to go into
63     subdirectories to find repositories to act on. Closes: #450621
64
65   [ Josh Triplett ]
66   * Make -j with no argument run unlimited jobs in parallel, like make -j
67     Closes: #452467
68
69   [ Joey Hess ]
70   * Add a warning about runing too many jobs at a time.
71
72  -- Joey Hess <joeyh@debian.org>  Sun, 25 Nov 2007 13:13:47 -0500
73
74 mr (0.14) unstable; urgency=low
75
76   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
77     Bloom. Closes: #449592
78   * Cut number of rcs tests run in half.
79
80  -- Joey Hess <joeyh@debian.org>  Sun, 11 Nov 2007 01:10:18 -0500
81
82 mr (0.13) unstable; urgency=low
83
84   * -c was broken, fix. Closes: #449539
85
86  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
87
88 mr (0.12) unstable; urgency=low
89
90   * Avoid creating parent directory for a checkout that will ultimately be
91     skipped.
92   * Don't try to test the repo type when doing a checkout, that can't work
93     since the repo isn't there yet. It was actually checking the repo type
94     of the parent directory, which caused several unexpected behaviors.
95
96  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
97
98 mr (0.11) unstable; urgency=low
99
100   * Avoid using commands like git-config and instead use "git config".
101     In some configurations, only the main git command is in the path.
102   * Allow option bundling, mostly so "-j2" will work.
103   * Better error message if more than one repo type test matches a single
104     directory.
105
106  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
107
108 mr (0.10) unstable; urgency=low
109
110   * Add a lib file for using unison with mr.
111   * Make registration work when no config file yet exists. Closes: #448422
112
113  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
114
115 mr (0.9) unstable; urgency=low
116
117   * Split up actions, so each rcs has its own set of action commands,
118     and mr tests to see what rcs is used by a repository, and dispatches
119     the command.
120
121     This will make it much easier to add new rcses, or modify just the
122     command that mr uses for one command for one rcs, without duplicating a
123     lot of code, and without needing to modify mr at all.
124
125     The old style unsplit actions are still supported, and are what most
126     mrconfig files will still use; this change is fully backwards compatible.
127   * Changed some things in the enviroment for the register action.
128     It's now run in the directory that the user specifies, and MR_REPO
129     is set to contain the basename of the directory that the checkout
130     command should check out. These changes should be backware compatible
131     to existing register actions.
132   * Add info and warning functions to the shell library. (madduck)
133   * Add git_bare and git_fake_bare rcs types to handle
134     bare and fake bare (non-bare with a detached worktree) git repositories.
135     (Diff and commit do not work yet to fake bare repos). (madduck)
136   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
137   * Add support for including one mrconfig file from another. Unlike chaining,
138     this doesn't change the paths, and is not tied to a particular
139     subdirectory. It's useful for loading up library mrconfig files.
140   * Split git fake-bare support out into a lib/git-fake-bare.
141     Partly because it's a good example of how to add a new revision control
142     type and use includes, and partly because it's currently too ugly to be
143     in mr itself due to bugs and limitations in git.
144
145  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
146
147 mr (0.8) unstable; urgency=low
148
149   * Improve "in subdir" message.
150   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
151     interactive updates. Closes: #447999
152
153  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
154
155 mr (0.7) unstable; urgency=low
156
157   * Fix inverted tests in tags command. (madduck)
158   * Patch from Simon McVittie, adding support for darcs repositories.
159     Closes: #447729
160
161  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
162
163 mr (0.6) unstable; urgency=low
164
165   * Add to the example mrconfig a "tags" command that lists tags.
166     (Currently only for svn and git.)
167   * hours_since was broken by design, and fixing it involved changing
168     its calling convention. If you used the old version, the new version
169     will error out.
170   * Add ability to reorder repos, if you want mr to act on a given repo first
171     or last.
172
173  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
174
175 mr (0.5) unstable; urgency=low
176
177   [ Joey Hess ]
178   * Removed special case repository deletion handling code. The same
179     thing can be accomplished in a mrconfig by skipping a repo unless
180     it exists, and printing a reminder on update. See the mrconfig file
181     for an example.
182   * Fix output of "mr config DEFAULT lib".
183   * Change mr update to use git pull -t origin master, to make sure new tags
184     are pulled. And since those might not always be the right parameters
185     for git pull, any parameters passed to mr update will replace them.
186
187   [ Alexander Wirt ]
188   * Add support for mercurial.
189
190   [ Joey Hess ]
191   * Incorporate code based on Anthony Towns's mrs, to allow running
192     multiple jobs in parallel. The -j flag controls this.
193     This can produce enormous speedups. For me, mr update takes
194     12 minutes, while mr -j 10 update takes 1 minute!
195
196  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
197
198 mr (0.4) unstable; urgency=low
199
200   * Fix mr register of a subdir to also work with -c.
201   * Signal handling for commands run by mr, including handling of SIGINT
202     to stop mr.
203   * Ensure parent dirs exist prior to checkout. (madduck)
204   * Output list of failed repos to stderr when -s is used.
205   * Fix a bug caused by a stupid typo.
206   * Add the -n switch, for disabling recursion.
207   * Allow for more complex deleted tests, such as marking a repo deleted on
208     some hosts, while not on others.
209   * Support registering CVS repositories. Closes: #447171
210   * MR_CONFIG now points to the config file that contains the repo mr is
211     acting on.
212   * Make mr register smarter about what mrconfig file to write to.
213     (It probably does what you'd expect it to do now; if it doesn't, -c
214     can still override.)
215
216  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
217
218 mr (0.3) unstable; urgency=low
219
220   * Add a check to make sure the expected directory exists after checkout.
221   * mr register will now write to whatever config file is specified with -c
222   * Typo fixes from madduck.
223
224  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
225
226 mr (0.2) unstable; urgency=low
227
228   * Fix line number display for config file parse errors.
229   * Fix a bug in inheritance of default settings in chained .mrconfig files.
230   * Add the -s option.
231
232  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
233
234 mr (0.1) unstable; urgency=low
235
236   * First release.
237
238  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400