All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.24) unstable; urgency=low
3 * Correct GIT_CONFIG settings in git-svn. Closes: #463941
5 -- Joey Hess <joeyh@debian.org> Wed, 06 Feb 2008 13:04:30 -0500
7 mr (0.23) unstable; urgency=low
9 * Fix tests in git-svn include file to use MR_REPO. Closes: #463941
11 -- Joey Hess <joeyh@debian.org> Tue, 05 Feb 2008 13:26:05 -0500
13 mr (0.22) unstable; urgency=low
15 * Update bzr registration code to work with current version of bzr,
16 using bzr info to get the url. Closes: #463867
18 -- Joey Hess <joeyh@debian.org> Sun, 03 Feb 2008 17:04:59 -0500
20 mr (0.21) unstable; urgency=low
22 * Add a git-svn file, which can be included to add support for git-svn
23 repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
24 for implementations. Closes: #462408
26 -- Joey Hess <joeyh@debian.org> Thu, 24 Jan 2008 13:45:05 -0500
28 mr (0.20) unstable; urgency=low
31 * darcs: Add -u to diff to get a more usual unified diff.
32 * Add a "record" subcommand, borrowing termonology from darcs. This does a
33 local commit, but does not push changes to remote repos.
34 * Improve unison support.
36 -- Joey Hess <joeyh@debian.org> Wed, 02 Jan 2008 22:49:53 -0500
38 mr (0.19) unstable; urgency=low
40 * Support versions of man that don't use -l.
41 * Updating git repos no longer uses git-pull -t by default. Git makes it
42 to much of a PITA to do this, since -t makes git-pull require the
43 repository and refspec be specified at the command line (which is a bug in
44 git (#456035). mr used to hardcode those to "origin" and "master", but
45 that's not always the right choice. So give up on forcing git to be sane
46 about pulling down all tags. It's insane. Live with it, or configure your
49 -- Joey Hess <joeyh@debian.org> Wed, 12 Dec 2007 21:30:45 -0500
51 mr (0.18) unstable; urgency=low
53 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
54 * darcs: De-p register code. Closes: #453502
56 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
58 mr (0.17) unstable; urgency=low
60 * Even bigger hammer: Set LC_ALL. Closes: #453305
62 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
64 mr (0.16) unstable; urgency=low
66 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
67 won't override it. Closes: #453305
69 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
71 mr (0.15) unstable; urgency=low
74 * Allow -n to be passed a number to specify how deep to go into
75 subdirectories to find repositories to act on. Closes: #450621
78 * Make -j with no argument run unlimited jobs in parallel, like make -j
82 * Add a warning about runing too many jobs at a time.
84 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
86 mr (0.14) unstable; urgency=low
88 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
89 Bloom. Closes: #449592
90 * Cut number of rcs tests run in half.
92 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
94 mr (0.13) unstable; urgency=low
96 * -c was broken, fix. Closes: #449539
98 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
100 mr (0.12) unstable; urgency=low
102 * Avoid creating parent directory for a checkout that will ultimately be
104 * Don't try to test the repo type when doing a checkout, that can't work
105 since the repo isn't there yet. It was actually checking the repo type
106 of the parent directory, which caused several unexpected behaviors.
108 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
110 mr (0.11) unstable; urgency=low
112 * Avoid using commands like git-config and instead use "git config".
113 In some configurations, only the main git command is in the path.
114 * Allow option bundling, mostly so "-j2" will work.
115 * Better error message if more than one repo type test matches a single
118 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
120 mr (0.10) unstable; urgency=low
122 * Add a lib file for using unison with mr.
123 * Make registration work when no config file yet exists. Closes: #448422
125 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
127 mr (0.9) unstable; urgency=low
129 * Split up actions, so each rcs has its own set of action commands,
130 and mr tests to see what rcs is used by a repository, and dispatches
133 This will make it much easier to add new rcses, or modify just the
134 command that mr uses for one command for one rcs, without duplicating a
135 lot of code, and without needing to modify mr at all.
137 The old style unsplit actions are still supported, and are what most
138 mrconfig files will still use; this change is fully backwards compatible.
139 * Changed some things in the enviroment for the register action.
140 It's now run in the directory that the user specifies, and MR_REPO
141 is set to contain the basename of the directory that the checkout
142 command should check out. These changes should be backware compatible
143 to existing register actions.
144 * Add info and warning functions to the shell library. (madduck)
145 * Add git_bare and git_fake_bare rcs types to handle
146 bare and fake bare (non-bare with a detached worktree) git repositories.
147 (Diff and commit do not work yet to fake bare repos). (madduck)
148 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
149 * Add support for including one mrconfig file from another. Unlike chaining,
150 this doesn't change the paths, and is not tied to a particular
151 subdirectory. It's useful for loading up library mrconfig files.
152 * Split git fake-bare support out into a lib/git-fake-bare.
153 Partly because it's a good example of how to add a new revision control
154 type and use includes, and partly because it's currently too ugly to be
155 in mr itself due to bugs and limitations in git.
157 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
159 mr (0.8) unstable; urgency=low
161 * Improve "in subdir" message.
162 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
163 interactive updates. Closes: #447999
165 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
167 mr (0.7) unstable; urgency=low
169 * Fix inverted tests in tags command. (madduck)
170 * Patch from Simon McVittie, adding support for darcs repositories.
173 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
175 mr (0.6) unstable; urgency=low
177 * Add to the example mrconfig a "tags" command that lists tags.
178 (Currently only for svn and git.)
179 * hours_since was broken by design, and fixing it involved changing
180 its calling convention. If you used the old version, the new version
182 * Add ability to reorder repos, if you want mr to act on a given repo first
185 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
187 mr (0.5) unstable; urgency=low
190 * Removed special case repository deletion handling code. The same
191 thing can be accomplished in a mrconfig by skipping a repo unless
192 it exists, and printing a reminder on update. See the mrconfig file
194 * Fix output of "mr config DEFAULT lib".
195 * Change mr update to use git pull -t origin master, to make sure new tags
196 are pulled. And since those might not always be the right parameters
197 for git pull, any parameters passed to mr update will replace them.
200 * Add support for mercurial.
203 * Incorporate code based on Anthony Towns's mrs, to allow running
204 multiple jobs in parallel. The -j flag controls this.
205 This can produce enormous speedups. For me, mr update takes
206 12 minutes, while mr -j 10 update takes 1 minute!
208 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
210 mr (0.4) unstable; urgency=low
212 * Fix mr register of a subdir to also work with -c.
213 * Signal handling for commands run by mr, including handling of SIGINT
215 * Ensure parent dirs exist prior to checkout. (madduck)
216 * Output list of failed repos to stderr when -s is used.
217 * Fix a bug caused by a stupid typo.
218 * Add the -n switch, for disabling recursion.
219 * Allow for more complex deleted tests, such as marking a repo deleted on
220 some hosts, while not on others.
221 * Support registering CVS repositories. Closes: #447171
222 * MR_CONFIG now points to the config file that contains the repo mr is
224 * Make mr register smarter about what mrconfig file to write to.
225 (It probably does what you'd expect it to do now; if it doesn't, -c
228 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
230 mr (0.3) unstable; urgency=low
232 * Add a check to make sure the expected directory exists after checkout.
233 * mr register will now write to whatever config file is specified with -c
234 * Typo fixes from madduck.
236 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
238 mr (0.2) unstable; urgency=low
240 * Fix line number display for config file parse errors.
241 * Fix a bug in inheritance of default settings in chained .mrconfig files.
244 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
246 mr (0.1) unstable; urgency=low
250 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400