]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

do not use eval in git-fake-bare
[code/myrepos.git] / debian / changelog
1 mr (0.25) UNRELEASED; urgency=low
2
3   * git-fake-bare: Add support for diff, commit, and record. (madduck)
4
5  -- Joey Hess <joeyh@debian.org>  Mon, 03 Mar 2008 14:55:13 -0500
6
7 mr (0.24) unstable; urgency=low
8
9   * Correct GIT_CONFIG settings in git-svn. Closes: #463941
10
11  -- Joey Hess <joeyh@debian.org>  Wed, 06 Feb 2008 13:04:30 -0500
12
13 mr (0.23) unstable; urgency=low
14
15   * Fix tests in git-svn include file to use MR_REPO. Closes: #463941
16
17  -- Joey Hess <joeyh@debian.org>  Tue, 05 Feb 2008 13:26:05 -0500
18
19 mr (0.22) unstable; urgency=low
20
21   * Update bzr registration code to work with current version of bzr,
22     using bzr info to get the url. Closes: #463867
23
24  -- Joey Hess <joeyh@debian.org>  Sun, 03 Feb 2008 17:04:59 -0500
25
26 mr (0.21) unstable; urgency=low
27
28   * Add a git-svn file, which can be included to add support for git-svn
29     repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
30     for implementations. Closes: #462408
31
32  -- Joey Hess <joeyh@debian.org>  Thu, 24 Jan 2008 13:45:05 -0500
33
34 mr (0.20) unstable; urgency=low
35
36   * Add -q flag.
37   * darcs: Add -u to diff to get a more usual unified diff.
38   * Add a "record" subcommand, borrowing termonology from darcs. This does a
39     local commit, but does not push changes to remote repos.
40   * Improve unison support.
41
42  -- Joey Hess <joeyh@debian.org>  Wed, 02 Jan 2008 22:49:53 -0500
43
44 mr (0.19) unstable; urgency=low
45
46   * Support versions of man that don't use -l.
47   * Updating git repos no longer uses git-pull -t by default. Git makes it
48     to much of a PITA to do this, since -t makes git-pull require the
49     repository and refspec be specified at the command line (which is a bug in
50     git (#456035). mr used to hardcode those to "origin" and "master", but
51     that's not always the right choice. So give up on forcing git to be sane
52     about pulling down all tags. It's insane. Live with it, or configure your
53     own update command.
54
55  -- Joey Hess <joeyh@debian.org>  Wed, 12 Dec 2007 21:30:45 -0500
56
57 mr (0.18) unstable; urgency=low
58
59   * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
60   * darcs: De-p register code. Closes: #453502
61
62  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 17:48:09 -0500
63
64 mr (0.17) unstable; urgency=low
65
66   * Even bigger hammer: Set LC_ALL. Closes: #453305
67
68  -- Joey Hess <joeyh@debian.org>  Thu, 29 Nov 2007 11:18:40 -0500
69
70 mr (0.16) unstable; urgency=low
71
72   * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
73     won't override it. Closes: #453305
74
75  -- Joey Hess <joeyh@debian.org>  Wed, 28 Nov 2007 15:46:38 -0500
76
77 mr (0.15) unstable; urgency=low
78
79   [ Joey Hess ]
80   * Allow -n to be passed a number to specify how deep to go into
81     subdirectories to find repositories to act on. Closes: #450621
82
83   [ Josh Triplett ]
84   * Make -j with no argument run unlimited jobs in parallel, like make -j
85     Closes: #452467
86
87   [ Joey Hess ]
88   * Add a warning about runing too many jobs at a time.
89
90  -- Joey Hess <joeyh@debian.org>  Sun, 25 Nov 2007 13:13:47 -0500
91
92 mr (0.14) unstable; urgency=low
93
94   * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
95     Bloom. Closes: #449592
96   * Cut number of rcs tests run in half.
97
98  -- Joey Hess <joeyh@debian.org>  Sun, 11 Nov 2007 01:10:18 -0500
99
100 mr (0.13) unstable; urgency=low
101
102   * -c was broken, fix. Closes: #449539
103
104  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
105
106 mr (0.12) unstable; urgency=low
107
108   * Avoid creating parent directory for a checkout that will ultimately be
109     skipped.
110   * Don't try to test the repo type when doing a checkout, that can't work
111     since the repo isn't there yet. It was actually checking the repo type
112     of the parent directory, which caused several unexpected behaviors.
113
114  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
115
116 mr (0.11) unstable; urgency=low
117
118   * Avoid using commands like git-config and instead use "git config".
119     In some configurations, only the main git command is in the path.
120   * Allow option bundling, mostly so "-j2" will work.
121   * Better error message if more than one repo type test matches a single
122     directory.
123
124  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
125
126 mr (0.10) unstable; urgency=low
127
128   * Add a lib file for using unison with mr.
129   * Make registration work when no config file yet exists. Closes: #448422
130
131  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
132
133 mr (0.9) unstable; urgency=low
134
135   * Split up actions, so each rcs has its own set of action commands,
136     and mr tests to see what rcs is used by a repository, and dispatches
137     the command.
138
139     This will make it much easier to add new rcses, or modify just the
140     command that mr uses for one command for one rcs, without duplicating a
141     lot of code, and without needing to modify mr at all.
142
143     The old style unsplit actions are still supported, and are what most
144     mrconfig files will still use; this change is fully backwards compatible.
145   * Changed some things in the enviroment for the register action.
146     It's now run in the directory that the user specifies, and MR_REPO
147     is set to contain the basename of the directory that the checkout
148     command should check out. These changes should be backware compatible
149     to existing register actions.
150   * Add info and warning functions to the shell library. (madduck)
151   * Add git_bare and git_fake_bare rcs types to handle
152     bare and fake bare (non-bare with a detached worktree) git repositories.
153     (Diff and commit do not work yet to fake bare repos). (madduck)
154   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
155   * Add support for including one mrconfig file from another. Unlike chaining,
156     this doesn't change the paths, and is not tied to a particular
157     subdirectory. It's useful for loading up library mrconfig files.
158   * Split git fake-bare support out into a lib/git-fake-bare.
159     Partly because it's a good example of how to add a new revision control
160     type and use includes, and partly because it's currently too ugly to be
161     in mr itself due to bugs and limitations in git.
162
163  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
164
165 mr (0.8) unstable; urgency=low
166
167   * Improve "in subdir" message.
168   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
169     interactive updates. Closes: #447999
170
171  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
172
173 mr (0.7) unstable; urgency=low
174
175   * Fix inverted tests in tags command. (madduck)
176   * Patch from Simon McVittie, adding support for darcs repositories.
177     Closes: #447729
178
179  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
180
181 mr (0.6) unstable; urgency=low
182
183   * Add to the example mrconfig a "tags" command that lists tags.
184     (Currently only for svn and git.)
185   * hours_since was broken by design, and fixing it involved changing
186     its calling convention. If you used the old version, the new version
187     will error out.
188   * Add ability to reorder repos, if you want mr to act on a given repo first
189     or last.
190
191  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
192
193 mr (0.5) unstable; urgency=low
194
195   [ Joey Hess ]
196   * Removed special case repository deletion handling code. The same
197     thing can be accomplished in a mrconfig by skipping a repo unless
198     it exists, and printing a reminder on update. See the mrconfig file
199     for an example.
200   * Fix output of "mr config DEFAULT lib".
201   * Change mr update to use git pull -t origin master, to make sure new tags
202     are pulled. And since those might not always be the right parameters
203     for git pull, any parameters passed to mr update will replace them.
204
205   [ Alexander Wirt ]
206   * Add support for mercurial.
207
208   [ Joey Hess ]
209   * Incorporate code based on Anthony Towns's mrs, to allow running
210     multiple jobs in parallel. The -j flag controls this.
211     This can produce enormous speedups. For me, mr update takes
212     12 minutes, while mr -j 10 update takes 1 minute!
213
214  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
215
216 mr (0.4) unstable; urgency=low
217
218   * Fix mr register of a subdir to also work with -c.
219   * Signal handling for commands run by mr, including handling of SIGINT
220     to stop mr.
221   * Ensure parent dirs exist prior to checkout. (madduck)
222   * Output list of failed repos to stderr when -s is used.
223   * Fix a bug caused by a stupid typo.
224   * Add the -n switch, for disabling recursion.
225   * Allow for more complex deleted tests, such as marking a repo deleted on
226     some hosts, while not on others.
227   * Support registering CVS repositories. Closes: #447171
228   * MR_CONFIG now points to the config file that contains the repo mr is
229     acting on.
230   * Make mr register smarter about what mrconfig file to write to.
231     (It probably does what you'd expect it to do now; if it doesn't, -c
232     can still override.)
233
234  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
235
236 mr (0.3) unstable; urgency=low
237
238   * Add a check to make sure the expected directory exists after checkout.
239   * mr register will now write to whatever config file is specified with -c
240   * Typo fixes from madduck.
241
242  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
243
244 mr (0.2) unstable; urgency=low
245
246   * Fix line number display for config file parse errors.
247   * Fix a bug in inheritance of default settings in chained .mrconfig files.
248   * Add the -s option.
249
250  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
251
252 mr (0.1) unstable; urgency=low
253
254   * First release.
255
256  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400