All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (1.13) UNRELEASED; urgency=low
3 * Pass -q to cvs diff and update. Closes: #673367
4 * mr bootstrap: Now supports ssh:// urls.
5 * Simpler vcsh status command line. Closes: #685089
6 * Add grep subcommand. Uses ack-grep on VCS that do not have their own.
9 -- Joey Hess <joeyh@debian.org> Fri, 18 May 2012 12:27:45 -0400
11 mr (1.12) unstable; urgency=low
13 * Ignore nonzero exit status of hg pull, which can happen
14 when there were no changes to pull. Closes: #661870
15 * Add vcsh to Suggests.
16 * Recognize a repo with a .git file as a git repo.
17 * Improve bzr register's heuristics to determine upstream repo.
20 -- Joey Hess <joeyh@debian.org> Mon, 14 May 2012 10:42:52 -0400
22 mr (1.11) unstable; urgency=low
24 * Now supports the veracity vcs. Thanks, Jimmy Tang.
25 * vcsh is now supported without including a plugin.
26 * After checkout, run fixups chdired to the just checked out directory.
28 -- Joey Hess <joeyh@debian.org> Tue, 14 Feb 2012 18:13:29 -0400
30 mr (1.10) unstable; urgency=low
32 * Fix display of trust errors.
34 -- Joey Hess <joeyh@debian.org> Tue, 27 Dec 2011 12:13:15 -0400
36 mr (1.09) unstable; urgency=low
38 * Remove dir_test hack and add a way for vcs tests to run perl code,
39 using this for the same optimisation. Fixes support for git-svn
42 -- Joey Hess <joeyh@debian.org> Fri, 16 Dec 2011 13:29:40 -0400
44 mr (1.08) unstable; urgency=low
46 * Fix vcs test code. Closes: #651976
48 -- Joey Hess <joeyh@debian.org> Tue, 13 Dec 2011 16:21:19 -0400
50 mr (1.07) unstable; urgency=low
52 * Added support for vcsh, enable with: include = cat /usr/share/mr/vcsh
53 Thanks, Richard Hartmann
54 * Block tty control codes in untrusted mr config files.
55 * Correct printing of line numbers when includes are used. Closes: #650952
56 * The previous fix for chaining to absolute paths broke chaining to relative
57 paths with more than one path segment. Thanks, Adam Spiers
58 * Support _append to add on to the existing value of a parameter.
60 * Optimizations. Commands like "mr list" run up to 5 times faster.
61 * Fix shell escaping of parameters passed to mr commands. Closes: #644672
62 * Added --force option that disables repository skipping.
63 * Repositories using skip = lazy will not be checked out by "mr update"
64 or "mr checkout" unless --force is used.
66 -- Joey Hess <joeyh@debian.org> Mon, 12 Dec 2011 15:52:16 -0400
68 mr (1.06) unstable; urgency=low
70 * Fix propigation of failure from pre and post hooks and from fixups.
71 * Support chaining to absolute paths.
72 * Add support for skip = lazy, a mode where mr only operates on repositories
75 -- Joey Hess <joeyh@debian.org> Fri, 04 Nov 2011 17:03:17 -0400
77 mr (1.05) unstable; urgency=low
79 * README now gives a quick into to using mr.
80 * Brought back the "deleted" parameter, which provides an easy way to
81 mark repositories that should be removed.
82 * Allow untrusted mrconfig files to set parameters to true/false.
83 So skip=true or deleted=true can be used in an untrusted mrconfig file.
84 * Also allow order=N in an untrusted mrconfig file.
85 * Support bzr checkouts, which are updated with "bzr update",
86 and to which bzr automatically pushes commits. Closes: #643589
87 * Use bzr branch, not deprecated bzr clone when registering bzr
88 repositories. Closes: #643591
89 * Allow bzr branch|clone|get|checkout in untrusted mrconfig files.
90 * Avoid using sed -r in git-fake-bare, for OSX portability.
91 * git-fake-bare: handle fake bare repositories with core.bare not set
92 (Thanks, Julien Rebetez)
94 -- Joey Hess <joeyh@debian.org> Tue, 27 Sep 2011 17:28:35 -0400
96 mr (1.04) unstable; urgency=low
98 * Improve trust errors displayed while bootstrapping. Closes: #628234
99 * Allow mr register to be used with mrconfig file that does not yet
100 exist. Closes: #629217
102 -- Joey Hess <joeyh@debian.org> Sun, 19 Jun 2011 15:52:42 -0400
104 mr (1.03) unstable; urgency=low
106 * Added git-subtree library. Thanks, Svend Sorensen
107 * Now --quiet supresses all output from commands run, as well
108 as from mr, unless a command fails. Closes: #529296
110 -- Joey Hess <joeyh@debian.org> Sun, 01 May 2011 19:09:35 -0400
112 mr (1.02) unstable; urgency=low
114 * Fix bug in escaping.
116 -- Joey Hess <joeyh@debian.org> Sat, 22 Jan 2011 01:18:23 -0400
118 mr (1.01) unstable; urgency=low
120 * Add "mr run", which can run an arbitrary command in each repository.
122 -- Joey Hess <joeyh@debian.org> Thu, 20 Jan 2011 16:50:49 -0400
124 mr (1.00) unstable; urgency=low
126 * Trust flag day. All mrconfig files except the main ~/.mrconfig are
127 now untrusted by default, until listed in ~/.mrtrust.
128 * The -p flag is now enabled by default. mr first reads ~/.mrconfig,
129 and then looks for an additional .mrconfig file in the current
130 directory or one of its parent directories. Closes: #557963
132 -- Joey Hess <joeyh@debian.org> Wed, 19 Jan 2011 14:28:38 -0400
134 mr (0.51) unstable; urgency=low
136 * Fix display when absolute directories are configured in mrconfig.
137 * Add push to manpage synopsis. Closes: #603029
138 * Do not return a nonzero exit status when all repositories were skipped.
141 -- Joey Hess <joeyh@debian.org> Thu, 16 Dec 2010 12:53:32 -0400
143 mr (0.50) unstable; urgency=low
145 * Now supports the Fossil VCS. (Thanks, Jimmy Tang)
146 * Added fixups hook, which can be used to run a command after
147 a repository is checked out or updated. Closes: #590868
148 * Added support for arbitrary pre and post hooks for all defined mr
149 commands. For example, pre_commit is run before all commits; post_update
150 is run after all updates. Closes: #481341
152 -- Joey Hess <joeyh@debian.org> Sun, 29 Aug 2010 15:00:01 -0400
154 mr (0.49) unstable; urgency=low
156 * Update suggests for git-core to git transition.
157 * Use short mode status output for git and bzr.
158 * Typo. Closes: #586233, #588913
160 -- Joey Hess <joeyh@debian.org> Sun, 18 Jul 2010 23:08:06 -0400
162 mr (0.48) unstable; urgency=low
164 * Fix the hours_since function built into mr's shell library to
165 not exit, but return a true/false exit status. This allows it to be
166 used outside of skip tests.
168 -- Joey Hess <joeyh@debian.org> Fri, 05 Feb 2010 17:12:01 -0500
170 mr (0.47) unstable; urgency=low
172 * Pass -L to curl to allow it to follow redirects when bootstrapping.
174 * Allow empty sections to be used in mrconfig files.
176 -- Joey Hess <joeyh@debian.org> Fri, 05 Feb 2010 16:40:29 -0500
178 mr (0.46) unstable; urgency=low
180 * Avoid using abs_path to determine canonical repo path, as that fails
181 when the repo has not yet been checked out.
183 -- Joey Hess <joeyh@debian.org> Thu, 10 Dec 2009 17:28:26 -0500
185 mr (0.45) unstable; urgency=low
187 * Fix pod error. Closes: #558012
188 * bootstrap: Improve stats display.
189 * Add --insecure option that can be used to ignore SSL cert errors
190 when bootstrapping. (Pavel Avgustinov)
191 * Fix handling of a repository in "."
193 -- Joey Hess <joeyh@debian.org> Tue, 08 Dec 2009 14:58:21 -0500
195 mr (0.44) unstable; urgency=low
197 * Make mr -i pass -i to the shell, to ensure it knows it should be an
199 * mr help: Support man on SunOS and OS X. (Geoff Davis)
200 * mr bootstrap: Fix cross-device rename failure. Closes: #557962
202 -- Joey Hess <joeyh@debian.org> Wed, 25 Nov 2009 12:39:08 -0500
204 mr (0.43) unstable; urgency=low
206 * Set User-Agent to "mr" when downloading the mrconfig file
207 with mr bootstrap. Closes: #541778
208 * Man page typo. Closes: #545412
209 * mr bootstrap: Allow a directory to checkout into to be specified,
210 and create it if necessary.
211 * mr bootstrap: If the mrconfig file contains a repository named ".",
212 check it out into the top level of the directory bootstrapped.
214 -- Joey Hess <joeyh@debian.org> Tue, 08 Sep 2009 20:22:32 -0400
216 mr (0.42) unstable; urgency=low
218 * Add support for ~/.mrtrust, which can be used to list trusted mrconfig
219 files. If you create this file, all files not listed in it will be treated
220 as untrusted, and carefully limited in what they can do. This improves
221 security when using mrconfig files provided by others.
223 -- Joey Hess <joeyh@debian.org> Fri, 07 Aug 2009 16:38:31 -0400
225 mr (0.41) unstable; urgency=low
227 * Add -p switch, that makes mr search the current directory and its
228 parents for a .mrconfig file to use.
229 * Add `mr bootstrap`, which downloads an url to a .mrconfig file
230 in the current directory and then checks out all repositories configured
231 in it. This is intended for projects that want to publish a mrconfig file
232 to automate use of their several repositories.
234 -- Joey Hess <joeyh@debian.org> Thu, 06 Aug 2009 22:38:58 -0400
236 mr (0.40) unstable; urgency=low
238 * Pass --pull to bzr merge to avoid needing to commit
239 merged changes. Closes: #524352
241 -- Joey Hess <joeyh@debian.org> Fri, 31 Jul 2009 13:47:22 -0400
243 mr (0.39) unstable; urgency=low
245 * Determine current branch for fake-bare update (martin f. krafft)
247 -- Joey Hess <joeyh@debian.org> Mon, 09 Mar 2009 22:50:54 -0400
249 mr (0.38) unstable; urgency=low
251 * Remove gitless lib. It turned out to be better to simply
252 use git clone --shared when checking out. Sorry for the churn..
254 -- Joey Hess <joeyh@debian.org> Thu, 22 Jan 2009 15:39:33 -0500
256 mr (0.37) unstable; urgency=low
258 * Add "gitless" file to lib.
259 This adds a special type of git repository, where the .git directory
260 is stored on a file server, to avoid wasting space with it on the client.
261 * Revert buggy change to directory printing code.
263 -- Joey Hess <joeyh@debian.org> Wed, 21 Jan 2009 01:40:59 -0500
265 mr (0.36) unstable; urgency=low
267 * Add webcheckout command. See <http://kitenet.net/~joey/rfc/rel-vcs/>
268 * Fix display of repos configured at absolute path locations.
270 -- Joey Hess <joeyh@debian.org> Sat, 10 Jan 2009 16:42:07 -0500
272 mr (0.35) unstable; urgency=low
274 * Warn if an include command fails nonzero. Closes: #495306
275 * Remove stray character in pod that uglified man page. Closes: #495731
276 * Create ~/.mrlog not world readable.
277 * Pass additional options to darcs push when pushing. Closes: #495734
279 -- Joey Hess <joeyh@debian.org> Thu, 16 Oct 2008 14:51:00 -0400
281 mr (0.34) unstable; urgency=low
283 * Fix bug when remembering failed commands in offline mode.
285 -- Joey Hess <joeyh@debian.org> Sat, 02 Aug 2008 12:27:21 -0400
287 mr (0.33) unstable; urgency=low
289 * Add a push subcommand, which pushes committed changes for DCVS, and
290 does nothing for svn/cvs. Closes: #491865
292 -- Joey Hess <joeyh@debian.org> Tue, 22 Jul 2008 15:22:01 -0400
294 mr (0.32) unstable; urgency=low
296 * Include the right (v2) version of GPL in the source.
298 -- Joey Hess <joeyh@debian.org> Tue, 22 Jul 2008 00:28:55 -0400
300 mr (0.31) unstable; urgency=low
302 * Add an offline mode. When in offline mode, mr will remember commands
303 that failed (presumably due to lack of network access), and will run
304 them again once back online. (This is for all the laptop users
305 like me who don't want to have to remember which git repos to mr push
306 when they come back from a nice long hack in the woods. :-)
308 -- Joey Hess <joeyh@debian.org> Fri, 27 Jun 2008 23:19:23 -0400
310 mr (0.30) unstable; urgency=low
313 * Several git-fake-bare improvements.
316 * Fix mr -c <config> register. (Thanks, Daniel Bungert)
318 -- Joey Hess <joeyh@debian.org> Wed, 25 Jun 2008 13:38:31 -0400
320 mr (0.29) unstable; urgency=low
322 * Allow environment variables in section headers. Pass such headers
323 through the shell to expand them. Closes: #480421
324 * For the checkout command, MR_REPO was set to the name of the parent
325 directory of the directory to checkout. It is supposed to be the
326 path to the directory itself though; fixed this. Closes: #480424
328 -- Joey Hess <joeyh@debian.org> Wed, 14 May 2008 19:38:18 -0400
330 mr (0.28) unstable; urgency=low
332 * Use debhelper v7, rules file minimisation.
335 -- Joey Hess <joeyh@debian.org> Wed, 23 Apr 2008 21:56:06 -0400
337 mr (0.27) unstable; urgency=low
339 * Ignore exit code from darcs whatsnew, which can be nonzero if there
340 are no changes. Closes: #476650
342 -- Joey Hess <joeyh@debian.org> Sat, 19 Apr 2008 16:47:04 -0400
344 mr (0.26) unstable; urgency=low
346 * Add -i option to start a shell if an operation fails. Closes: #474962
348 -- Joey Hess <joeyh@debian.org> Tue, 08 Apr 2008 20:58:44 -0400
350 mr (0.25) unstable; urgency=low
352 * git-fake-bare: Add support for diff, commit, and record. (madduck)
354 -- Joey Hess <joeyh@debian.org> Mon, 10 Mar 2008 15:56:17 -0400
356 mr (0.24) unstable; urgency=low
358 * Correct GIT_CONFIG settings in git-svn. Closes: #463941
360 -- Joey Hess <joeyh@debian.org> Wed, 06 Feb 2008 13:04:30 -0500
362 mr (0.23) unstable; urgency=low
364 * Fix tests in git-svn include file to use MR_REPO. Closes: #463941
366 -- Joey Hess <joeyh@debian.org> Tue, 05 Feb 2008 13:26:05 -0500
368 mr (0.22) unstable; urgency=low
370 * Update bzr registration code to work with current version of bzr,
371 using bzr info to get the url. Closes: #463867
373 -- Joey Hess <joeyh@debian.org> Sun, 03 Feb 2008 17:04:59 -0500
375 mr (0.21) unstable; urgency=low
377 * Add a git-svn file, which can be included to add support for git-svn
378 repositories. Thanks to Clifford W. Hansen and Bastian Kleineidam
379 for implementations. Closes: #462408
381 -- Joey Hess <joeyh@debian.org> Thu, 24 Jan 2008 13:45:05 -0500
383 mr (0.20) unstable; urgency=low
386 * darcs: Add -u to diff to get a more usual unified diff.
387 * Add a "record" subcommand, borrowing termonology from darcs. This does a
388 local commit, but does not push changes to remote repos.
389 * Improve unison support.
391 -- Joey Hess <joeyh@debian.org> Wed, 02 Jan 2008 22:49:53 -0500
393 mr (0.19) unstable; urgency=low
395 * Support versions of man that don't use -l.
396 * Updating git repos no longer uses git-pull -t by default. Git makes it
397 to much of a PITA to do this, since -t makes git-pull require the
398 repository and refspec be specified at the command line (which is a bug in
399 git (#456035). mr used to hardcode those to "origin" and "master", but
400 that's not always the right choice. So give up on forcing git to be sane
401 about pulling down all tags. It's insane. Live with it, or configure your
404 -- Joey Hess <joeyh@debian.org> Wed, 12 Dec 2007 21:30:45 -0500
406 mr (0.18) unstable; urgency=low
408 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
409 * darcs: De-p register code. Closes: #453502
411 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
413 mr (0.17) unstable; urgency=low
415 * Even bigger hammer: Set LC_ALL. Closes: #453305
417 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
419 mr (0.16) unstable; urgency=low
421 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
422 won't override it. Closes: #453305
424 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
426 mr (0.15) unstable; urgency=low
429 * Allow -n to be passed a number to specify how deep to go into
430 subdirectories to find repositories to act on. Closes: #450621
433 * Make -j with no argument run unlimited jobs in parallel, like make -j
437 * Add a warning about runing too many jobs at a time.
439 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
441 mr (0.14) unstable; urgency=low
443 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
444 Bloom. Closes: #449592
445 * Cut number of rcs tests run in half.
447 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
449 mr (0.13) unstable; urgency=low
451 * -c was broken, fix. Closes: #449539
453 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
455 mr (0.12) unstable; urgency=low
457 * Avoid creating parent directory for a checkout that will ultimately be
459 * Don't try to test the repo type when doing a checkout, that can't work
460 since the repo isn't there yet. It was actually checking the repo type
461 of the parent directory, which caused several unexpected behaviors.
463 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
465 mr (0.11) unstable; urgency=low
467 * Avoid using commands like git-config and instead use "git config".
468 In some configurations, only the main git command is in the path.
469 * Allow option bundling, mostly so "-j2" will work.
470 * Better error message if more than one repo type test matches a single
473 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
475 mr (0.10) unstable; urgency=low
477 * Add a lib file for using unison with mr.
478 * Make registration work when no config file yet exists. Closes: #448422
480 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
482 mr (0.9) unstable; urgency=low
484 * Split up actions, so each rcs has its own set of action commands,
485 and mr tests to see what rcs is used by a repository, and dispatches
488 This will make it much easier to add new rcses, or modify just the
489 command that mr uses for one command for one rcs, without duplicating a
490 lot of code, and without needing to modify mr at all.
492 The old style unsplit actions are still supported, and are what most
493 mrconfig files will still use; this change is fully backwards compatible.
494 * Changed some things in the enviroment for the register action.
495 It's now run in the directory that the user specifies, and MR_REPO
496 is set to contain the basename of the directory that the checkout
497 command should check out. These changes should be backware compatible
498 to existing register actions.
499 * Add info and warning functions to the shell library. (madduck)
500 * Add git_bare and git_fake_bare rcs types to handle
501 bare and fake bare (non-bare with a detached worktree) git repositories.
502 (Diff and commit do not work yet to fake bare repos). (madduck)
503 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
504 * Add support for including one mrconfig file from another. Unlike chaining,
505 this doesn't change the paths, and is not tied to a particular
506 subdirectory. It's useful for loading up library mrconfig files.
507 * Split git fake-bare support out into a lib/git-fake-bare.
508 Partly because it's a good example of how to add a new revision control
509 type and use includes, and partly because it's currently too ugly to be
510 in mr itself due to bugs and limitations in git.
512 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
514 mr (0.8) unstable; urgency=low
516 * Improve "in subdir" message.
517 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
518 interactive updates. Closes: #447999
520 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
522 mr (0.7) unstable; urgency=low
524 * Fix inverted tests in tags command. (madduck)
525 * Patch from Simon McVittie, adding support for darcs repositories.
528 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
530 mr (0.6) unstable; urgency=low
532 * Add to the example mrconfig a "tags" command that lists tags.
533 (Currently only for svn and git.)
534 * hours_since was broken by design, and fixing it involved changing
535 its calling convention. If you used the old version, the new version
537 * Add ability to reorder repos, if you want mr to act on a given repo first
540 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
542 mr (0.5) unstable; urgency=low
545 * Removed special case repository deletion handling code. The same
546 thing can be accomplished in a mrconfig by skipping a repo unless
547 it exists, and printing a reminder on update. See the mrconfig file
549 * Fix output of "mr config DEFAULT lib".
550 * Change mr update to use git pull -t origin master, to make sure new tags
551 are pulled. And since those might not always be the right parameters
552 for git pull, any parameters passed to mr update will replace them.
555 * Add support for mercurial.
558 * Incorporate code based on Anthony Towns's mrs, to allow running
559 multiple jobs in parallel. The -j flag controls this.
560 This can produce enormous speedups. For me, mr update takes
561 12 minutes, while mr -j 10 update takes 1 minute!
563 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
565 mr (0.4) unstable; urgency=low
567 * Fix mr register of a subdir to also work with -c.
568 * Signal handling for commands run by mr, including handling of SIGINT
570 * Ensure parent dirs exist prior to checkout. (madduck)
571 * Output list of failed repos to stderr when -s is used.
572 * Fix a bug caused by a stupid typo.
573 * Add the -n switch, for disabling recursion.
574 * Allow for more complex deleted tests, such as marking a repo deleted on
575 some hosts, while not on others.
576 * Support registering CVS repositories. Closes: #447171
577 * MR_CONFIG now points to the config file that contains the repo mr is
579 * Make mr register smarter about what mrconfig file to write to.
580 (It probably does what you'd expect it to do now; if it doesn't, -c
583 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
585 mr (0.3) unstable; urgency=low
587 * Add a check to make sure the expected directory exists after checkout.
588 * mr register will now write to whatever config file is specified with -c
589 * Typo fixes from madduck.
591 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
593 mr (0.2) unstable; urgency=low
595 * Fix line number display for config file parse errors.
596 * Fix a bug in inheritance of default settings in chained .mrconfig files.
599 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
601 mr (0.1) unstable; urgency=low
605 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400