All patches and comments are welcome. Please squash your changes to logical
commits before using git-format-patch and git-send-email to
patches@git.madduck.net.
If you'd read over the Git project's submission guidelines and adhered to them,
I'd be especially grateful.
1 mr (0.19) UNRELEASED; urgency=low
3 * Support versions of man that don't use -l.
4 * Updating git repos no longer uses git-pull -t by default. Git makes it
5 to much of a PITA to do this, since -t makes git-pull require the
6 repository and refspec be specified at the command line (which is a bug in
7 git (#456035). mr used to hardcode those to "origin" and "master", but
8 that's not always the right choice. So give up on forcing git to be sane
9 about pulling down all tags. It's insane. Live with it, or configure your
12 -- Joey Hess <joeyh@debian.org> Tue, 04 Dec 2007 15:13:26 -0500
14 mr (0.18) unstable; urgency=low
16 * darcs: Use record subcommand, there is no commit subcommand. Closes: #453501
17 * darcs: De-p register code. Closes: #453502
19 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 17:48:09 -0500
21 mr (0.17) unstable; urgency=low
23 * Even bigger hammer: Set LC_ALL. Closes: #453305
25 -- Joey Hess <joeyh@debian.org> Thu, 29 Nov 2007 11:18:40 -0500
27 mr (0.16) unstable; urgency=low
29 * Use LC_MESSAGES=C not LANG=C, as if the user has LC_MESSAGES set, LANG
30 won't override it. Closes: #453305
32 -- Joey Hess <joeyh@debian.org> Wed, 28 Nov 2007 15:46:38 -0500
34 mr (0.15) unstable; urgency=low
37 * Allow -n to be passed a number to specify how deep to go into
38 subdirectories to find repositories to act on. Closes: #450621
41 * Make -j with no argument run unlimited jobs in parallel, like make -j
45 * Add a warning about runing too many jobs at a time.
47 -- Joey Hess <joeyh@debian.org> Sun, 25 Nov 2007 13:13:47 -0500
49 mr (0.14) unstable; urgency=low
51 * Portability fixes for the non-POSIX shell of SunOS 5. Patch from Ken
52 Bloom. Closes: #449592
53 * Cut number of rcs tests run in half.
55 -- Joey Hess <joeyh@debian.org> Sun, 11 Nov 2007 01:10:18 -0500
57 mr (0.13) unstable; urgency=low
59 * -c was broken, fix. Closes: #449539
61 -- Joey Hess <joeyh@debian.org> Tue, 06 Nov 2007 11:39:04 -0500
63 mr (0.12) unstable; urgency=low
65 * Avoid creating parent directory for a checkout that will ultimately be
67 * Don't try to test the repo type when doing a checkout, that can't work
68 since the repo isn't there yet. It was actually checking the repo type
69 of the parent directory, which caused several unexpected behaviors.
71 -- Joey Hess <joeyh@debian.org> Sat, 03 Nov 2007 14:22:00 -0400
73 mr (0.11) unstable; urgency=low
75 * Avoid using commands like git-config and instead use "git config".
76 In some configurations, only the main git command is in the path.
77 * Allow option bundling, mostly so "-j2" will work.
78 * Better error message if more than one repo type test matches a single
81 -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:28:52 -0400
83 mr (0.10) unstable; urgency=low
85 * Add a lib file for using unison with mr.
86 * Make registration work when no config file yet exists. Closes: #448422
88 -- Joey Hess <joeyh@debian.org> Sun, 28 Oct 2007 19:55:03 -0400
90 mr (0.9) unstable; urgency=low
92 * Split up actions, so each rcs has its own set of action commands,
93 and mr tests to see what rcs is used by a repository, and dispatches
96 This will make it much easier to add new rcses, or modify just the
97 command that mr uses for one command for one rcs, without duplicating a
98 lot of code, and without needing to modify mr at all.
100 The old style unsplit actions are still supported, and are what most
101 mrconfig files will still use; this change is fully backwards compatible.
102 * Changed some things in the enviroment for the register action.
103 It's now run in the directory that the user specifies, and MR_REPO
104 is set to contain the basename of the directory that the checkout
105 command should check out. These changes should be backware compatible
106 to existing register actions.
107 * Add info and warning functions to the shell library. (madduck)
108 * Add git_bare and git_fake_bare rcs types to handle
109 bare and fake bare (non-bare with a detached worktree) git repositories.
110 (Diff and commit do not work yet to fake bare repos). (madduck)
111 * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
112 * Add support for including one mrconfig file from another. Unlike chaining,
113 this doesn't change the paths, and is not tied to a particular
114 subdirectory. It's useful for loading up library mrconfig files.
115 * Split git fake-bare support out into a lib/git-fake-bare.
116 Partly because it's a good example of how to add a new revision control
117 type and use includes, and partly because it's currently too ugly to be
118 in mr itself due to bugs and limitations in git.
120 -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:00:40 -0400
122 mr (0.8) unstable; urgency=low
124 * Improve "in subdir" message.
125 * Patch from Simon McVittie, to pass -a to darcs commands to avoid
126 interactive updates. Closes: #447999
128 -- Joey Hess <joeyh@debian.org> Thu, 25 Oct 2007 06:22:45 -0400
130 mr (0.7) unstable; urgency=low
132 * Fix inverted tests in tags command. (madduck)
133 * Patch from Simon McVittie, adding support for darcs repositories.
136 -- Joey Hess <joeyh@debian.org> Wed, 24 Oct 2007 01:18:27 -0400
138 mr (0.6) unstable; urgency=low
140 * Add to the example mrconfig a "tags" command that lists tags.
141 (Currently only for svn and git.)
142 * hours_since was broken by design, and fixing it involved changing
143 its calling convention. If you used the old version, the new version
145 * Add ability to reorder repos, if you want mr to act on a given repo first
148 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 21:53:28 -0400
150 mr (0.5) unstable; urgency=low
153 * Removed special case repository deletion handling code. The same
154 thing can be accomplished in a mrconfig by skipping a repo unless
155 it exists, and printing a reminder on update. See the mrconfig file
157 * Fix output of "mr config DEFAULT lib".
158 * Change mr update to use git pull -t origin master, to make sure new tags
159 are pulled. And since those might not always be the right parameters
160 for git pull, any parameters passed to mr update will replace them.
163 * Add support for mercurial.
166 * Incorporate code based on Anthony Towns's mrs, to allow running
167 multiple jobs in parallel. The -j flag controls this.
168 This can produce enormous speedups. For me, mr update takes
169 12 minutes, while mr -j 10 update takes 1 minute!
171 -- Joey Hess <joeyh@debian.org> Sun, 21 Oct 2007 01:27:23 -0400
173 mr (0.4) unstable; urgency=low
175 * Fix mr register of a subdir to also work with -c.
176 * Signal handling for commands run by mr, including handling of SIGINT
178 * Ensure parent dirs exist prior to checkout. (madduck)
179 * Output list of failed repos to stderr when -s is used.
180 * Fix a bug caused by a stupid typo.
181 * Add the -n switch, for disabling recursion.
182 * Allow for more complex deleted tests, such as marking a repo deleted on
183 some hosts, while not on others.
184 * Support registering CVS repositories. Closes: #447171
185 * MR_CONFIG now points to the config file that contains the repo mr is
187 * Make mr register smarter about what mrconfig file to write to.
188 (It probably does what you'd expect it to do now; if it doesn't, -c
191 -- Joey Hess <joeyh@debian.org> Thu, 18 Oct 2007 16:20:34 -0400
193 mr (0.3) unstable; urgency=low
195 * Add a check to make sure the expected directory exists after checkout.
196 * mr register will now write to whatever config file is specified with -c
197 * Typo fixes from madduck.
199 -- Joey Hess <joeyh@debian.org> Wed, 17 Oct 2007 12:48:55 -0400
201 mr (0.2) unstable; urgency=low
203 * Fix line number display for config file parse errors.
204 * Fix a bug in inheritance of default settings in chained .mrconfig files.
207 -- Joey Hess <joeyh@debian.org> Tue, 16 Oct 2007 02:39:08 -0400
209 mr (0.1) unstable; urgency=low
213 -- Joey Hess <joeyh@debian.org> Sun, 14 Oct 2007 14:14:40 -0400