]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* Avoid creating parent directory for a checkout that will ultimately be
[code/myrepos.git] / debian / changelog
1 mr (0.12) UNRELEASED; urgency=low
2
3   * Avoid creating parent directory for a checkout that will ultimately be
4     skipped.
5
6  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 13:58:39 -0400
7
8 mr (0.11) unstable; urgency=low
9
10   * Avoid using commands like git-config and instead use "git config".
11     In some configurations, only the main git command is in the path.
12   * Allow option bundling, mostly so "-j2" will work.
13   * Better error message if more than one repo type test matches a single
14     directory.
15
16  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
17
18 mr (0.10) unstable; urgency=low
19
20   * Add a lib file for using unison with mr.
21   * Make registration work when no config file yet exists. Closes: #448422
22
23  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
24
25 mr (0.9) unstable; urgency=low
26
27   * Split up actions, so each rcs has its own set of action commands,
28     and mr tests to see what rcs is used by a repository, and dispatches
29     the command.
30
31     This will make it much easier to add new rcses, or modify just the
32     command that mr uses for one command for one rcs, without duplicating a
33     lot of code, and without needing to modify mr at all.
34
35     The old style unsplit actions are still supported, and are what most
36     mrconfig files will still use; this change is fully backwards compatible.
37   * Changed some things in the enviroment for the register action.
38     It's now run in the directory that the user specifies, and MR_REPO
39     is set to contain the basename of the directory that the checkout
40     command should check out. These changes should be backware compatible
41     to existing register actions.
42   * Add info and warning functions to the shell library. (madduck)
43   * Add git_bare and git_fake_bare rcs types to handle
44     bare and fake bare (non-bare with a detached worktree) git repositories.
45     (Diff and commit do not work yet to fake bare repos). (madduck)
46   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
47   * Add support for including one mrconfig file from another. Unlike chaining,
48     this doesn't change the paths, and is not tied to a particular
49     subdirectory. It's useful for loading up library mrconfig files.
50   * Split git fake-bare support out into a lib/git-fake-bare.
51     Partly because it's a good example of how to add a new revision control
52     type and use includes, and partly because it's currently too ugly to be
53     in mr itself due to bugs and limitations in git.
54
55  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
56
57 mr (0.8) unstable; urgency=low
58
59   * Improve "in subdir" message.
60   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
61     interactive updates. Closes: #447999
62
63  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
64
65 mr (0.7) unstable; urgency=low
66
67   * Fix inverted tests in tags command. (madduck)
68   * Patch from Simon McVittie, adding support for darcs repositories.
69     Closes: #447729
70
71  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
72
73 mr (0.6) unstable; urgency=low
74
75   * Add to the example mrconfig a "tags" command that lists tags.
76     (Currently only for svn and git.)
77   * hours_since was broken by design, and fixing it involved changing
78     its calling convention. If you used the old version, the new version
79     will error out.
80   * Add ability to reorder repos, if you want mr to act on a given repo first
81     or last.
82
83  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
84
85 mr (0.5) unstable; urgency=low
86
87   [ Joey Hess ]
88   * Removed special case repository deletion handling code. The same
89     thing can be accomplished in a mrconfig by skipping a repo unless
90     it exists, and printing a reminder on update. See the mrconfig file
91     for an example.
92   * Fix output of "mr config DEFAULT lib".
93   * Change mr update to use git pull -t origin master, to make sure new tags
94     are pulled. And since those might not always be the right parameters
95     for git pull, any parameters passed to mr update will replace them.
96
97   [ Alexander Wirt ]
98   * Add support for mercurial.
99
100   [ Joey Hess ]
101   * Incorporate code based on Anthony Towns's mrs, to allow running
102     multiple jobs in parallel. The -j flag controls this.
103     This can produce enormous speedups. For me, mr update takes
104     12 minutes, while mr -j 10 update takes 1 minute!
105
106  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
107
108 mr (0.4) unstable; urgency=low
109
110   * Fix mr register of a subdir to also work with -c.
111   * Signal handling for commands run by mr, including handling of SIGINT
112     to stop mr.
113   * Ensure parent dirs exist prior to checkout. (madduck)
114   * Output list of failed repos to stderr when -s is used.
115   * Fix a bug caused by a stupid typo.
116   * Add the -n switch, for disabling recursion.
117   * Allow for more complex deleted tests, such as marking a repo deleted on
118     some hosts, while not on others.
119   * Support registering CVS repositories. Closes: #447171
120   * MR_CONFIG now points to the config file that contains the repo mr is
121     acting on.
122   * Make mr register smarter about what mrconfig file to write to.
123     (It probably does what you'd expect it to do now; if it doesn't, -c
124     can still override.)
125
126  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
127
128 mr (0.3) unstable; urgency=low
129
130   * Add a check to make sure the expected directory exists after checkout.
131   * mr register will now write to whatever config file is specified with -c
132   * Typo fixes from madduck.
133
134  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
135
136 mr (0.2) unstable; urgency=low
137
138   * Fix line number display for config file parse errors.
139   * Fix a bug in inheritance of default settings in chained .mrconfig files.
140   * Add the -s option.
141
142  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
143
144 mr (0.1) unstable; urgency=low
145
146   * First release.
147
148  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400