]> git.madduck.net Git - code/myrepos.git/blob - debian/changelog

madduck's git repository

Every one of the projects in this repository is available at the canonical URL git://git.madduck.net/madduck/pub/<projectpath> — see each project's metadata for the exact URL.

All patches and comments are welcome. Please squash your changes to logical commits before using git-format-patch and git-send-email to patches@git.madduck.net. If you'd read over the Git project's submission guidelines and adhered to them, I'd be especially grateful.

SSH access, as well as push access can be individually arranged.

If you use my repositories frequently, consider adding the following snippet to ~/.gitconfig and using the third clone URL listed for each project:

[url "git://git.madduck.net/madduck/"]
  insteadOf = madduck:

* -c was broken, fix. Closes: #449539
[code/myrepos.git] / debian / changelog
1 mr (0.13) unstable; urgency=low
2
3   * -c was broken, fix. Closes: #449539
4
5  -- Joey Hess <joeyh@debian.org>  Tue, 06 Nov 2007 11:39:04 -0500
6
7 mr (0.12) unstable; urgency=low
8
9   * Avoid creating parent directory for a checkout that will ultimately be
10     skipped.
11   * Don't try to test the repo type when doing a checkout, that can't work
12     since the repo isn't there yet. It was actually checking the repo type
13     of the parent directory, which caused several unexpected behaviors.
14
15  -- Joey Hess <joeyh@debian.org>  Sat, 03 Nov 2007 14:22:00 -0400
16
17 mr (0.11) unstable; urgency=low
18
19   * Avoid using commands like git-config and instead use "git config".
20     In some configurations, only the main git command is in the path.
21   * Allow option bundling, mostly so "-j2" will work.
22   * Better error message if more than one repo type test matches a single
23     directory.
24
25  -- Joey Hess <joeyh@debian.org>  Fri, 02 Nov 2007 23:28:52 -0400
26
27 mr (0.10) unstable; urgency=low
28
29   * Add a lib file for using unison with mr.
30   * Make registration work when no config file yet exists. Closes: #448422
31
32  -- Joey Hess <joeyh@debian.org>  Sun, 28 Oct 2007 19:55:03 -0400
33
34 mr (0.9) unstable; urgency=low
35
36   * Split up actions, so each rcs has its own set of action commands,
37     and mr tests to see what rcs is used by a repository, and dispatches
38     the command.
39
40     This will make it much easier to add new rcses, or modify just the
41     command that mr uses for one command for one rcs, without duplicating a
42     lot of code, and without needing to modify mr at all.
43
44     The old style unsplit actions are still supported, and are what most
45     mrconfig files will still use; this change is fully backwards compatible.
46   * Changed some things in the enviroment for the register action.
47     It's now run in the directory that the user specifies, and MR_REPO
48     is set to contain the basename of the directory that the checkout
49     command should check out. These changes should be backware compatible
50     to existing register actions.
51   * Add info and warning functions to the shell library. (madduck)
52   * Add git_bare and git_fake_bare rcs types to handle
53     bare and fake bare (non-bare with a detached worktree) git repositories.
54     (Diff and commit do not work yet to fake bare repos). (madduck)
55   * Add a vim modeline to preserve joey's tabbing prefs. (madduck)
56   * Add support for including one mrconfig file from another. Unlike chaining,
57     this doesn't change the paths, and is not tied to a particular
58     subdirectory. It's useful for loading up library mrconfig files.
59   * Split git fake-bare support out into a lib/git-fake-bare.
60     Partly because it's a good example of how to add a new revision control
61     type and use includes, and partly because it's currently too ugly to be
62     in mr itself due to bugs and limitations in git.
63
64  -- Joey Hess <joeyh@debian.org>  Fri, 26 Oct 2007 03:00:40 -0400
65
66 mr (0.8) unstable; urgency=low
67
68   * Improve "in subdir" message.
69   * Patch from Simon McVittie, to pass -a to darcs commands to avoid
70     interactive updates. Closes: #447999
71
72  -- Joey Hess <joeyh@debian.org>  Thu, 25 Oct 2007 06:22:45 -0400
73
74 mr (0.7) unstable; urgency=low
75
76   * Fix inverted tests in tags command. (madduck)
77   * Patch from Simon McVittie, adding support for darcs repositories.
78     Closes: #447729
79
80  -- Joey Hess <joeyh@debian.org>  Wed, 24 Oct 2007 01:18:27 -0400
81
82 mr (0.6) unstable; urgency=low
83
84   * Add to the example mrconfig a "tags" command that lists tags.
85     (Currently only for svn and git.)
86   * hours_since was broken by design, and fixing it involved changing
87     its calling convention. If you used the old version, the new version
88     will error out.
89   * Add ability to reorder repos, if you want mr to act on a given repo first
90     or last.
91
92  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 21:53:28 -0400
93
94 mr (0.5) unstable; urgency=low
95
96   [ Joey Hess ]
97   * Removed special case repository deletion handling code. The same
98     thing can be accomplished in a mrconfig by skipping a repo unless
99     it exists, and printing a reminder on update. See the mrconfig file
100     for an example.
101   * Fix output of "mr config DEFAULT lib".
102   * Change mr update to use git pull -t origin master, to make sure new tags
103     are pulled. And since those might not always be the right parameters
104     for git pull, any parameters passed to mr update will replace them.
105
106   [ Alexander Wirt ]
107   * Add support for mercurial.
108
109   [ Joey Hess ]
110   * Incorporate code based on Anthony Towns's mrs, to allow running
111     multiple jobs in parallel. The -j flag controls this.
112     This can produce enormous speedups. For me, mr update takes
113     12 minutes, while mr -j 10 update takes 1 minute!
114
115  -- Joey Hess <joeyh@debian.org>  Sun, 21 Oct 2007 01:27:23 -0400
116
117 mr (0.4) unstable; urgency=low
118
119   * Fix mr register of a subdir to also work with -c.
120   * Signal handling for commands run by mr, including handling of SIGINT
121     to stop mr.
122   * Ensure parent dirs exist prior to checkout. (madduck)
123   * Output list of failed repos to stderr when -s is used.
124   * Fix a bug caused by a stupid typo.
125   * Add the -n switch, for disabling recursion.
126   * Allow for more complex deleted tests, such as marking a repo deleted on
127     some hosts, while not on others.
128   * Support registering CVS repositories. Closes: #447171
129   * MR_CONFIG now points to the config file that contains the repo mr is
130     acting on.
131   * Make mr register smarter about what mrconfig file to write to.
132     (It probably does what you'd expect it to do now; if it doesn't, -c
133     can still override.)
134
135  -- Joey Hess <joeyh@debian.org>  Thu, 18 Oct 2007 16:20:34 -0400
136
137 mr (0.3) unstable; urgency=low
138
139   * Add a check to make sure the expected directory exists after checkout.
140   * mr register will now write to whatever config file is specified with -c
141   * Typo fixes from madduck.
142
143  -- Joey Hess <joeyh@debian.org>  Wed, 17 Oct 2007 12:48:55 -0400
144
145 mr (0.2) unstable; urgency=low
146
147   * Fix line number display for config file parse errors.
148   * Fix a bug in inheritance of default settings in chained .mrconfig files.
149   * Add the -s option.
150
151  -- Joey Hess <joeyh@debian.org>  Tue, 16 Oct 2007 02:39:08 -0400
152
153 mr (0.1) unstable; urgency=low
154
155   * First release.
156
157  -- Joey Hess <joeyh@debian.org>  Sun, 14 Oct 2007 14:14:40 -0400